Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Can't install Backup Exec Archiving Option

Created: 26 Mar 2012 | 16 comments

Because we are ordering a new backup server I'm creating a test installation on a virtual machine. I've installed Windows 2008 R2 and SQL Express 2008. The installation of Backup Exec 2010 R3 goes ok except for the Archiving Option which doesn't install.

BKUPINST.HTM says:

03-26-2012,11:48:44 : ERROR: EVRunDll.exe process has returned error code -2147024827.
03-26-2012,11:48:44 : Review silent configuration log in C:\Program Files\Symantec\Backup Exec\Enterprise Vault\Reports for more details.
03-26-2012,11:48:44 : Review Symantec Enterprise Vault event logs for errors.
03-26-2012,11:48:44 : AgentSeqDlgs::Misc_BE_CommonOps
03-26-2012,11:48:44 : The Backup Exec Archiving Option installation did not complete successfully. To find a solution, go to: http://entsupport.symantec.com/umi/V-225-277 

The SilentCfgLog says,

Failed to create Enterprise Vault Directory database
 Silent Configuration Registry key value written (ReturnCode = 46).

I have tried reinstalling Backup Exec, and a reinstall of the whole machine but got no luck.

Can anyone tell me what causes this error?

Thanks

Comments 16 CommentsJump to latest comment

SNLTSC's picture

I tried whitout a virusscanner (SEP in this case) installed. No change.

SNLTSC's picture

That refers to the same article as in the TS. It basically tells to uninstall the option and try again the exact same thing.

Tried did and it didn't help. Exact same result.

VJware's picture

Have you looked at - http://www.symantec.com/docs/TECH143687   ?

EDIT***

In case, the above KB doesn't open, here is the excerpt:

The selected database location for the Archiving Option Database must be a supported SQL version.

Software Compatibility Lists (SCL)

BE SCL - http://www.symantec.com/docs/TECH137682

EV SCL - http://www.symantec.com/docs/TECH38537

SNLTSC's picture

From page 43 of the BE SCL: "SQL 2008 32 and 64 bit versions are supported as database backend servers". No specific version information about R1 or R2 listed.

SQL Server 2008 Express isn't supported for EV, page 14 of the EV SCL. But I'm not using EV on this sever, only BE, so would this matter?

VJware's picture

This SQL version must be a supported one by both EV & BE...So if you are using the default SQL express, it isn't supported for this option.

SNLTSC's picture

I now installed BE with the default installation of SQL Express 2005 and now the Archive Options installed.

Strange thing because this SQL versions isn't supported by EV either.

VJware's picture

Actually SQL Express 2005 is supported with EV 2007, 8.x & 9.x, albeit limited support :)

SNLTSC's picture

So I saw, but not with EV10. That doesn't makes it logical to work with BE 2010 don't you think?

Jana.T's picture

ERROR: EVRunDll.exe process has returned error code -2147024842.

I'm using BE 2012 and trying to install  Archive option. I use sql database that came with BE, so there should be no problem there.

Enterprise Vault folder after failed install is completely empty.

this is a part of my install log:

+ 06-21-2012,11:27:30 : ERROR: EVRunDll.exe process has returned error code -2147024842.

+ 06-21-2012,11:27:30 : Review silent configuration log in C:\Program Files\Symantec\Backup Exec\Enterprise Vault\Reports for more details.

+ 06-21-2012,11:27:30 : Review Symantec Enterprise Vault event logs for errors.

06-21-2012,11:27:30 : Copying the Silent Config log and EVEinstall.log files.

06-21-2012,11:27:30 : Silent Config Log File Source: C:\Program Files\Symantec\Backup Exec\Enterprise Vault\Reports\

06-21-2012,11:27:30 : Silent Config Log File Destination: C:\ProgramData\Symantec\Backup Exec\Logs

06-21-2012,11:27:30 : Checking EVE Log file at C:\ProgramData\Symantec\Backup Exec\LogsEVE\EVEInstall.log

06-21-2012,11:27:30 : Checking EVE Log file at C:\Program Files\Symantec\Backup Exec\Enterprise Vault\Installation Logs\EVEInstall.log

06-21-2012,11:27:30 : Copying C:\Program Files\Symantec\Backup Exec\Enterprise Vault\Installation Logs\EVEInstall.log TO C:\ProgramData\Symantec\Backup Exec\Logs\EVEInstall 2012-06-21 11-27-30.log

06-21-2012,11:27:30 : EVE Install Log and Silent Config Log File(s) are copied at C:\ProgramData\Symantec\Backup Exec\Logs

06-21-2012,11:27:30 : AgentSeqDlgs::Misc_BE_CommonOps

06-21-2012,11:27:30 : Check if need to Rollback BEAO

06-21-2012,11:27:30 : Set EXCHARCH state to Not Installed

06-21-2012,11:27:30 : Exch Arch Feature State After Rollback :False

06-21-2012,11:27:30 : NTFS Arch Feature State After Rollback :False

06-21-2012,11:27:30 : Uninstalling Symantec Enterprise Vault Embedded.

06-21-2012,11:27:30 : AHDebug: InitSiteId. Error 2 loading siteId value

06-21-2012,11:27:30 : AHDebug: AHShared::Initialize. Error 0xe0009867 in InitSiteId

06-21-2012,11:27:30 : AHDebug: AHShared::CreateInstance(AHErr). Error 0xe0009867 in AHShared::Initialize

06-21-2012,11:27:30 : AHDebug: CArchivalAdmin::PreEVUnInstallCallback. Error 0xe0009867 in AHShared::CreateInstance

+ 06-21-2012,11:27:30 : Error 0xe0009867 in PreEVUnInstallCallback

06-21-2012,11:27:30 : Deleted the EVE ConfigLocation registry value.

06-21-2012,11:27:30 : "C:\Program Files (x86)\InstallShield Installation Information\{7042DC99-7779-4C5C-A7F2-B9957BFA04EC}\setup.exe" -uninst -s -f1"C:\Program Files (x86)\InstallShield Installation Information\{7042DC99-7779-4C5C-A7F2-B9957BFA04EC}\Setup.iss"

06-21-2012,11:28:02 : Symantec Enterprise Vault Embedded has been successfully uninstalled.

06-21-2012,11:28:02 : Detaching the BEAO Database...

06-21-2012,11:28:02 : C:\Program Files\Symantec\Backup Exec\BEAODatabases.xml does not exist.

06-21-2012,11:28:02 : AHDebug: CArchivalAdmin::PostEVUnInstallCallback. Computer alias could not be obtained

06-21-2012,11:28:02 : PostEVUnInstallCallback executed successfuly.

06-21-2012,11:28:02 : BEAO options are not being installed. Continue with BEWS services start.

06-21-2012,11:28:02 : Successfully started service - bedbg

06-21-2012,11:28:02 : Successfully started service - MSSQL$BKUPEXEC

06-21-2012,11:28:02 : Successfully started service - BackupExecAgentAccelerator

06-21-2012,11:28:02 : Successfully started service - BackupExecDeviceMediaService

06-21-2012,11:28:02 : Successfully started service - BackupExecRPCService

06-21-2012,11:28:02 : Successfully started service - BackupExecManagementService

06-21-2012,11:28:02 : Successfully started service - BackupExecJobEngine

06-21-2012,11:28:02 : Successfully started service - BackupExecAgentBrowser

06-21-2012,11:28:02 : Successfully started service - elementmgr

06-21-2012,11:28:02 : AgentSeqDlgs::Misc_BE_CommonOps

06-21-2012,11:28:02 : Current Maintenance Path : C:\ProgramData\Symantec\Backup Exec\{017CF375-DCCC-4717-B3A2-F549CE54BDE5}

06-21-2012,11:28:02 : Removed BEAOConfig value

06-21-2012,11:28:02 : The return value for Symantec Backup Exec Archiving Option returned error code: 1603

06-21-2012,11:28:02 : Clean up Symantec installer keys.

06-21-2012,11:28:04 : Terminal Services enabled.

06-21-2012,11:28:04 : Terminal Services server has been set to Execute mode.

06-21-2012,11:28:04 : Failure Detected during Install Progress

06-21-2012,11:28:14 : Skipping push of remote servers and agents due to failed local install.

06-21-2012,11:28:14 : BeSeqDlgs::DlgInstallComplete

06-21-2012,11:28:14 : AgentSeqDlgs::Misc_BE_CommonOps

06-21-2012,11:28:14 : Dialog Sequence Returning errorlevel 1603

06-21-2012,11:28:14 : Setting up failed completion dialog.

06-21-2012,11:28:14 : Setting up failed completion dialog (Install).

06-21-2012,11:28:14 : Initialize the telemetry items on the dialog

06-21-2012,11:28:14 : Skipping push of remote servers and agents due to failed local install.

can anyone help?

regards,

jana

Jana

Anshuma Patni's picture

Hi SNLTSC,

Actually with BE 2010 R3 and also with BE 2012 we install EV 9.x as part of Archiving Option and hence BE Archiving Option got installed with the default installation of SQL Express 2005 in your case.

Hope this answers your question.

Anshuma Patni's picture

Hi Jana,

Two things here I would like to know in order to get more insight into the cause of the issue:

1. Can you copy the error log from Silent Config Log File present at: C:\ProgramData\Symantec\Backup Exec\Logs? This is a file name whose name starts with 'SilentCfgLog '.

2. Also do you see any errors in Symantec Enterprise Vault event logs?

Thanks.

vijay1876's picture

i am having  the exact issue....been working with support for quite some time without a resolution

santoshv's picture

Hi Vijay,

I hope this issue has been resolved by now.

If not, please can you share the following logs so that it will help us to diagnose the exact cause of failure.

%ALLUSERSPROFILE%\Application Data\Symantec\Backup Exec\Logs\SilentCfgLog*.log

%ALLUSERSPROFILE%\Application Data\Symantec\Backup Exec\Logs\EVEInstall*.log

%ALLUSERSPROFILE%\Application Data\Symantec\Backup Exec\Logs\BKUPINST*.htm

Thanks,

Santosh

DBorse's picture

Hello,

It might be possible that the Backup Exec Service username do not have sysadmin permission to SQL instance. Please verify  this using below steps before any other workaround.

  1. Start a command prompt with any user having sysadmin rights to SQL instance.
  2. type SQLCMD –S  <HostName>\<instance name>  e.g (local)\BKUPEXEC
  3. type “SELECT NAME FROM SYS.SERVER_PRINCIPALS”
  4. type “GO”  and press Enter

If the Backup Exec Service username is listed in the output then it has sysadmin rights to SQL instance.

If the Backup Exec Service username IS NOT  a sysadmin then please follow below steps to give rights to the user

  1. Start a command shell with any user having sysadmin rights to SQL instance.
  2. type SQLCMD –S <HostName>\ <instance name> e.g.  (local)\BKUPEXEC
  3. type SP_ADDSRVROLEMEMBER ‘darth\vader’, ‘sysadmin’
  4. type GO

Please see the below link for more details.

http://blogs.msdn.com/b/dparys/archive/2009/09/17/create-database-permission-denied-in-database-master-my-fix.aspx

Thanks,

-Digambar

Regards,

-DB