Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Can't make Managed Software of manually added package (CMS 7.1)

Created: 14 Mar 2011 | 5 comments

When I try to make a Managed Software out of a manually added package (Software Release) it won't list my packages under Identify Inventory. No matter what search criteria I use, I get nothing to select from.

This works however if I try it on a Newly Discovered Software.

If I rightclick on Managed Software, and select Open i New Window, I get the Symantec Management Server Error-page, and the below error in the Application log on the server. My guess is that this is somehow related.

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 2011-03-14 13:41:28
Event time (UTC): 2011-03-14 12:41:28
Event ID: 1eed21d2ef814452be24337eb46d5bc9
Event sequence: 11068
Event occurrence: 5
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/Altiris/NS-5-129445394055205736
Trust level: Full
Application Virtual Path: /Altiris/NS
Application Path: C:\Program Files\Altiris\Notification Server\Web\
Machine name: ALTIRIS

Process information:
Process ID: 139084
Process name: w3wp.exe
Account name: IIS APPPOOL\Classic .NET AppPool

Exception information:
Exception type: NullReferenceException
Exception message: Object reference not set to an instance of an object.

Request information:
Request URL: https://altiris:443/Altiris/NS/Admin/Collections/N... unhandled exception has occurred.faltirisAn unhandled exception has occurred.fconsoleAn unhandled exception has occurred.fItemPage.aspx&ParentGuid=cede1e9a-1ff4-4a1c-acc7-0b3e3b6cc564&TreeGuid=0136c3e7-1502-4c08-8d80-3f5c1787eb75&ItemGuid=968c897b-5a07-483a-a9a1-3f8bc349598e&ContentFrame=rightPane&CallbackPageId=6fdc50a09bad40859c7cea46da725352
Request path: /Altiris/NS/Admin/Collections/NSResourceCollection.aspx
User host address: 172.17.23.80
User: KOMMUN\stekar1
Is authenticated: True
Authentication Type: Negotiate
Thread account name: KOMMUN\altiri1

Thread information:
Thread ID: 43
Thread account name: KOMMUN\altiri1
Is impersonating: False
Stack trace: at Altiris.Reporting.DataSource.ResourceDataSourceEditControl.DataBindResolvedQuery()
at Altiris.Reporting.UI.DataSourceEditControl`1.DataBind()
at Altiris.Reporting.UI.DataSourceEditControl`1.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Comments 5 CommentsJump to latest comment

Andrew Bosch's picture

The Identify Inventory tab will only search for software components that are installed on at least 1 machine in your environment.  If you are starting with a software release, then the process would go as follows.

1. Import software and create a new software release
2. At this point, do not create a software product - we will do that later
3. From the Deliverable Software view, deploy this software to the desired target
4. Allow software inventory to run and report this software has been installed.
5. In the Newly Discovered Software list, this software should now show up.  Select it, and in the right hand pane, select 'Manage this software'.

Again, the key here is to deploy the software and then allow software inventory to run and report back that it is installed.  Then, it can be easily managed just like the newly discovered software.

------------------------------------
Sr. Principal SQA Engineer
Symantec

NiklasG's picture

This worked. It worked differently in the beta, I think. Thanks.

I still get the error when I right-click on Managed software and select Open in new Windows though.

Andrew Bosch's picture

So if you go to Manage->Software to the new Silverlight UI and select Managed Software and then a software product, you have a right click option of "Open in New Window"?  Which product versions do you have installed?  I vaguely remember an "Open in new window" option like 6 months ago but not anymore...

This is the right-click menu I get on managed software using the GA version of ITMS 7.1:

------------------------------------
Sr. Principal SQA Engineer
Symantec

mclemson's picture

I've confirmed this in my GA environment.  I see what the OP is saying now.

Go to Manage > Software

In the left-most pane (the "Office 2010" pane), under Software, under Installed Software, right-click on the words 'Managed Software' and choose 'Open in New Window'

The following error appears immediately:

Symantec Management Server Error

An error has occurred that prevents the Symantec Management Console displaying correctly.

 

Speaking of which, what's the best way to report bugs?  I've been submitting support cases.  Not getting replies yet and it's been 7 days on some.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Andrew Bosch's picture

OK, now I get it.  Yes, I get the same error - I have logged a defect against this.  Reporting bugs through Support is the best method right now - I am also monitoring Connect trying to catch as many as I can as well...

------------------------------------
Sr. Principal SQA Engineer
Symantec