Video Screencast Help

Can't upgrade from BackupExec 2010 R3 to 2012 due to deduplication option

Created: 04 Apr 2012 | 26 comments
GAG's picture

Hello,

I'm triying to upgrade my Backup Exec 2010 R3 server to Backup Exec 2012.

Upgrade installation fails beacuse I have installed "Deduplication option" so I must uninstall it first (in fact I've never used this option, I've just installed it for testing purposes).

The problem is that I can't uninstall this option. It appears ticked (installed) but I can't uninstall it in order to launch the upgrade process.

Any ideas ?

Thanks in advance

Comments 26 CommentsJump to latest comment

ZeRoC00L's picture

How do you mean, cannot remove the deduplication option ?
Do you receive an error during uninstall of the dedup option ?

Do you still have a deduplication folder configured ? Can you remove that before uninstall ?

If this response answers your concern, please mark it as a "solution"

GAG's picture

Hi,

As you can see in the attached image, I've installed deduplication option as "60 days test option".

It shows installed but now, I can't uncheck it.

I've never used this option.

DedupOption.png
ZeRoC00L's picture

Just tested it myself, you cannot de-install an agent/option untill you have a valid license key entered....
Strange but true.

I think you don't have much options left, other than complete remove BE and install it again....

 

If this response answers your concern, please mark it as a "solution"

Colin Weaver's picture

Hi ZeRoC00L - does that mean you added an Evaluation option for Dedup on your test and then added a BE 2010 Serial number for DeDup to remove it?

ZeRoC00L's picture

Correct.

If this response answers your concern, please mark it as a "solution"

GAG's picture

I'm afraid I agree with you Zerocool and don't see any options but complete uninstalling Bexec 2010 and reinstalling 2012.

Such a strange bug isn't it ?

 

pkh's picture

It may not be bug, but was done this way deliberately so that users cannot just deselect and select the option again to being a new trial.  Just guessing.

Backup_Exec's picture

Hi in this case please complete the install of be2012 with dedup in trialware and once installation is done you can uncheck dedup option and continue install and that should resolve the issue
Thanks

Sameer

Don't forget to give a "Thumbs Up" or Mark as "Solution" if someones advice has helped you.

BernardJL's picture

This definitely does NOT work.  As outline in a post here, we did just that since that is what the error message said to do. 

And then it complained about "Desktop/Laptop Option".  Suggesting we removed it.

When we removed that one (which we did have a license for) it took us back to the "deduplication" problem.

This is a mess.

 

Colin Weaver's picture

A colleague has mentioned that when he saw a similar issue, taking the complete 2010 Install back to trialware by removing all the serial numbers but otherwise leaving 2010 installed allowed the upgrade to 2012 to take place. (Even if 2010 has gone beyond the 60 day expiry)

M Strong's picture

I had the same exact issue.  However, I had never installed a trial of dedup in previous versions and still was presented with the above issue, checkbox grayed out and not de-selectable.  I found this answer in another thread and it worked for me:

Fire up Regedit and delete the key [HKLM\Software\Symantec\Puredisk] and all subkeys.
(Export a backup of the key first...)

Then re-run the setup.  You should not be prompted with the error.

Hope it helps...

-M

GAG's picture

Sorry guys, I've been on holidays.

After succesfully installing Bexec 2012, I uninstalled it and installed again 2010 R3.

Bexec 2012 seems too new for me and quite different from 2010. After playing with it for a couple of hours, I didn't feel confortable with the new GUI, and prefered switching back to 2010. I'll try the new version on a test server.

Thanks for your help.

BWells64's picture

I ran into the exact same issue today.  I tried deleting the registry key as mentioned in this article: http://www.symantec.com/connect/forums/howto-upgrade#comment-6824421

However, this did not resolve the issue for me.  The suggestion made by Colin Weaver did the trick.

  1. From the Backup Exec 2010, Select Tools | Install Options and License Keys on this Media Server...
  2. Remove all the license keys to convert the installation to trialware, click "Next"
  3. In Configure Options, you can now uncheck the Deduplication Option
  4. Complete the installation of these changes to Backup Exec 2010

After this completed, I was able to successfully run the Backup Exec 2012 installation.

Thank you for your help.

thecurtis's picture

Neither solution worked for me. Upgrading from 2010 R3 SP2 to 2012.

I removed the license keys from the list in 2010 and was informed that my 60 day trial had ended and all jobs would be suspended, and I was not given the option to click "Next".

Also, the registry modification did not work. I'm stuck.

BernardJL's picture

This is really frustrating.  We scheduled the Backup Exec 2012 upgrade and cannot get passed the "Deduplication Option is no longer licensed in this upgrade....."

We are on Backup Exec 2010 R3 with all the updates.  We never used deduplication, it is not checked on our current installation configuration.

So why is it talking about this?

The "Deduplication Option" is neither licensed nor selected for "trialware"on our current installation period.

How do you do an upgrade from Backup Exec 2010 R3?

 

BernardJL's picture

OK, we followed what the error message said to do.  It said to make "Deduplication" a "trialware" and that would fix the problem.

So we re-configured "Backup Exec 2010 R3" and checked the "De-duplication" under "Available for 60 day trial."

No go.

For some reason now it  is complaining about "Desktop and Laptop Option" and can not continue.  We had turned that one off earlier.  Not clear how that got back on.

So we re-configured "Backup Exec 2010 R3" and removed the "Desktop and Laptop Option". 

No go.

We are now back to the "De-duplication" problem.  But we now have a check box on "De-duplication" in our Backup Exec 2010 R3 installation as trial-ware.

Which is what the upgrade message said to do. 

What is going on with this software?.  We have wasted a number of hours now trying to upgrade the software and did what the warning message told us to do.  And messing around with an option we never used, tried, or purchased. 

Any ideas what is going on here? 

Thanks in advance for any help here.

 

jtb1965's picture

Can't believe that no one at Symantec attempted to upgrade SBS 2010 to SBS 2012!

BernardJL's picture

Well we remain stuck with this problem. 

Has anyone been able to complete an upgrade after this "error" condition?

We appreciate any help.

Jtb1965, we are wondering the same thing.

BernardJL's picture

Just to close this off, we had a support call on this issue.  The technician knew about the problem and did the install WITHOUT serial numbers.

So the procedure was to start the Backup Exec 2012 install, and when it asked for serial numbers, remove all the serial numbers.

Then click on the blue link below the box of serial numbers.  The link says something like "Install as trial software."

So you end up installed a complete "trial" version. 

After the install when you start up Backup Exec 2012, you can then enter the serial numbers and remove the dedup feature.

Hope that helps someone else.  There really should be a "knowledge base" article on this.

 

BBIAngie's picture

I agree completely. I had the same issue only with the DLO option.  I had to revert 2010 to a trial before I could do the upgrade!

 

Glad I didnt spend hours digging as it seems the support for BE 2012 is not so great yet.

Henrik Frølund's picture

The solution is to install BE2012 as a trial to upgrade BE 2010.

We have upgraded BE2010R3 to BE2012 as a trial. First we strugled with the same problems with DLO and deduplication.

Unfortunately we already did try to upgrade with the serialnumbers, and was not able to delete these. But it is possible to install BE2012 without selecting the serialnumbers already supplied.

After installation/upgrade to BE2012 we just activated the licenses with no problems.

The update was done on a fully updated SB2011 with BE2010R3.

Jimmy Andrews's picture

This is piss poor Symantec, time to call my Dell rep to deal with this.  So, I uninstalled the DLO option and to my surprise, that didn't help the upgrade to 2012, still showing as installed (even though it is showing unchecked in 2010 R3).  Come to find out, it never deregisters the DLO Maintenance Service...grrr, I bet that is why it won't upgrade...maybe I'll deregister it myself.

Fortunately for me, I do have the dedupe option selected, but within the 60 day grace period.  I activated it with hopes of actually using it...however due to some bad information given to me and unclear descriptions on the Symantec site, it isn't a practical solution for us.  I hope that once I get this DLO stuff figured out, it will be smooth sailing.

 

Jimmy Andrews's picture

Well, the whole SC DELETE didn't work, went into the registry to delete that service.  Also noticed that DLO was not even touched for the uninstall that was supposed to happen after unchecking the option in 2010R3, in fact, I could still fully run the program from the folder...grrr.

So, rebooting the server now to get that DLO Maint service out of there, then I am going to rename the DLO folder in program files...Lets see if it stops me again.

Jimmy Andrews's picture

Nope, didn't work.  Time to do some more registry diving...and starting another thread about this issue.

tsvare's picture

jandrews@mjdatacorp.com,

 

Would you mind if I contacted you via email?  I think I can help you get DLO removed but would like to get a little further information.

Jimmy Andrews's picture

You are absolutely welcome to contact me via email!  My address is my username that you used to respond.  I have since corrected that to just show my name.

 

Jimmy