Video Screencast Help

Can`t Uprade v.11.x to v.12.x

Created: 11 Jul 2013 • Updated: 28 Jan 2014 | 40 comments
This issue has been solved. See solution.

Hi all.

I have some problem in time uprgate my Symantec  Endpoint product 11.x.

what i do:

  1. Back up the database.
     
  2. Turn off replication. -not use
     
  3. If you have Symantec Network Access Control installed, enable local authentication. -not use
  4. Stop the Symantec Endpoint Protection Manager service 

When i run setup.exe, after some time i have message: error.2.jpg

and my installation stoped aftet this.

Can you help me?

 

Operating Systems:

Comments 40 CommentsJump to latest comment

GeoGeo's picture

Raise a case with Symantec to get the latest cleanwipe to completly clear all components of SEP off the machine then the installer should run smothly. 

Please review ideas and vote there could be something useful :)

https://www-secure.symantec.com/connect/security/ideas

 

GeoGeo's picture

Or if it's just the SEPM service it's detecting try manually stopping it from services.msc select symantec endpoint protection manager stop the service and try install again.

Please review ideas and vote there could be something useful :)

https://www-secure.symantec.com/connect/security/ideas

 

cloom@live.ru's picture

i stoped all services that were and not result(((

Mithun Sanghavi's picture

Hello,

It is suggested to stop the SEPM services and Embedded database services before upgrading the SEPM.

Check this Article:

Best practices for upgrading to Symantec Endpoint Protection 12.1.x

http://www.symantec.com/business/support/index?page=content&id=TECH163700

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SOLUTION
.Brian's picture

Did you stop the SEPM service first?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Chetan Savade's picture

Hi,

Thank you for posting in Symantec community.

I would be glad to answer your query.

Open the task manager & go to the users tab. Check if any other console session is open or not.

If you see any other active session, right click on that session and click on connect. Check SEPM console is open or not in that session.

Have you tried to reboot SEPM 11.x installed machine?

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

SOLUTION
cloom@live.ru's picture

You right!!! I did that you tell me and i saw there alse user session. I killed this session and i can upgrade)))

Thank you very much

cloom@live.ru's picture

My be you help me agane?)))

I trying install soft to client, but sometimes on some clients there is a mistake not the correct login and the password... May be ports need to be opened for this purpose on the client? And  is this  ports?

Mithun Sanghavi's picture

Hello,

I would suggest you to make sure that perform the steps provided in the article below before deploying client packages - 

Preparing Windows operating systems for remote deployment

http://www.symantec.com/docs/HOWTO80805

Hope that helps!!

 

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

SOLUTION
Chetan Savade's picture

Hi,

Good to know previously mentioned issue has resolved.

When you tries to deploy SEP client remotely where exactly you get stuck?

Machine is not accepting username and password for remote deployment? Try to check local admin account details on that particular OS & then try to use those credentials to deploy remotely.

Check if issue is with any specific operating system?

I would like to share the following article but personally I don't think it can be the issue because you are able to deploy on other clients. 

About client deployment methods

http://www.symantec.com/docs/HOWTO81302

Steps to prepare computers to install Symantec Endpoint Protection 12.1 client

http://www.symantec.com/docs/TECH163112

How to prepare computers for remote deployment

http://www.symantec.com/docs/HOWTO16365

Preparing Windows operating systems for remote deployment 

http://www.symantec.com/docs/HOWTO81300

Installing Symantec Endpoint Protection clients remotely

http://www.symantec.com/docs/HOWTO59432

Remote Installation Troubleshooting

ftp://ftp.symantec.com/public/english_us_canada/products/symantec_endpoint_protection/11.0/manuals/mr4/remote_troubleshoot.html

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

cloom@live.ru's picture

Thanks  o lot. I can do it))) But i have any questions...

1) I did Disable the Windows Firewall. After installation,  whether it is necessary to open ports or it is simple to  enabled it?

2) I Enable and start the Remote Registry service.  After installation i have to Disable this services or not?

 

 

Chetan Savade's picture

Hi,

Thank for the update.

1) I did Disable the Windows Firewall. After installation,  whether it is necessary to open ports or it is simple to  enabled it?

--> If SEP client is installed with Network Threat Protection (NTP) then it's not needed to enable windows firewall. If NTP is not installed then it's recommended to use Windows firewall. But never use both the firewalls at the same time. 

If using Windows firewall then need to enable the ports.

Refer this article to know more about it.

Which Communications Ports does Symantec Endpoint Protection use?

http://www.symantec.com/docs/TECH163787  

2) I Enable and start the Remote Registry service.  After installation i have to Disable this services or not?

--> You can disable it if it's not required by any other application.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

pete_4u2002's picture

once installed you can stop the ports on firewall as well remote registry service

AJ_01's picture

You can enable the remote registry and if port require then open, after complete the activity if you no need to work remotely then close the port.

Login id password issue cause of many reason.

Port issue

Password not accepted.

Servcie stop

Firewall service enabled.

At last computer has not trust relationship(computer is in workgroup, entry removed from AD)

If you can see the issue again check according to above steps.

Regard

AJ

cloom@live.ru's picture

Hi Friends!

I have one questions else.

Tell me pls. How pors i need to open on my network firewall, that my client  can communicate with my Antivirus server?

Chetan Savade's picture

Hi,

You can refer the following articles:

Which Communications Ports does Symantec Endpoint Protection use?

http://www.symantec.com/docs/TECH163787

Ports and Protocols to be allowed when using a proxy in a SEP environment.

 http://www.symantec.com/docs/TECH131843 

Processes and Services used by Symantec Endpoint Protection

http://www.symantec.com/docs/TECH102748

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

pete_4u2002's picture

by default the server listens on port 8014 that needs to be opened.

check this link to understand on the ports used

Which communications ports does Symantec Endpoint Protection use?

http://www.symantec.com/docs/TECH163787

SameerU's picture

Hi

Restart the Server and close all active sessions other than yours

Regards

 

Chetan Savade's picture

Hi,

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

cloom@live.ru's picture

I opened ports 80 and 8014. Client is connected with Server - thats good. But i need, that client can update antivirus database. what`s ports need open now?

pete_4u2002's picture

its again the server listening port 8014 by default.

cloom@live.ru's picture

Hmm. I have next structure. We have  one client and one server, but antivirus  database on other server.

We need  that client connect to server where put database...

pete_4u2002's picture

don't understand your question.

do you want to move SEPM to be moved to machine where SQL is running?

cloom@live.ru's picture

No, dont move. We have WSUS server and on this server we have antivirus base

cloom@live.ru's picture

And i want to know what ports i need to open on network level, that my client can update antivirus database.

The classical shema is when antivirus database and SEP its one server. But i have SEP its one server and antivirus  database on other server....

Chetan Savade's picture

Hi,

Refer the following articles to know more about ports used by Symantec.

About firewalls and communication ports

http://www.symantec.com/docs/HOWTO55379

Which Communications Ports does Symantec Endpoint Protection use?

http://www.symantec.com/docs/TECH163787

Ports and Protocols to be allowed when using a proxy in a SEP environment.

 http://www.symantec.com/docs/TECH131843 

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

pete_4u2002's picture

SEPM talks to database. clients can be configured to get the updates from SEPM.in this case client will talk to SEPM on assigned port (default 8014),

SUPPORT-2-SUPPORT's picture

Which Communications Ports does Symantec Endpoint Protection use?
 Article URL http://www.symantec.com/docs/TECH163787

Regards,

S2S

 

Please don't forget to mark your thread solved with whatever answer helped you.

Chetan Savade's picture

Hi,

By looking at diagram, Network design look preety simple.

Refer the given articles about SEPM and SEP client communication.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Chetan Savade's picture

Hi,

Is there any update on this.

OR

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.

 

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

cloom@live.ru's picture

Friends, hi.

Help me agane. I need unstall client, but i cant open ports(((

What ports need to be opened what successfully to establish the client remote and that he would normally be displayed in the SEP console

 

I use this Art. but ot work 

http://www.symantec.com/business/support/index?pag...

James007's picture

You can't uninstall SEP client from SEPM.

Upgrade clients to SEP 12.1 by Auto upgrade feature

http://www.symantec.com/connect/articles/upgrade-clients-sep-121-auto-upgrade-feature

 

 

Ports used for client software deployment with the Push Deployment Wizard

 

Client computers

Symantec Endpoint Protection Manager

TCP 139 and 445

Ephemeral TCP ports

Ephemeral TCP ports

TCP 139 and 445

UDP 137, 138

UDP 137, 138

 

James007's picture

It's means Install ?

Ports used for client software deployment with the Push Deployment Wizard

 

 

Client computers

Symantec Endpoint Protection Manager

TCP 139 and 445

Ephemeral TCP ports

Ephemeral TCP ports

TCP 139 and 445

UDP 137, 138

UDP 137, 138

 

cloom@live.ru's picture

We opened 

TCP 139 and 445

Ephemeral TCP ports

Ephemeral TCP ports

TCP 139 and 445

UDP 137, 138

UDP 137, 138

and we opened all from http://www.symantec.com/business/support/index?page=content&id=TECH163787

but not work!!! If we open all port -than work. What can i do else?