Video Screencast Help

Catalog logs on two locations

Created: 22 Aug 2013 • Updated: 22 Aug 2013 | 3 comments
This issue has been solved. See solution.


I am using Backup Exec 2010 R3.
My local C drive is running low on diskspace. I noticed that catalog files are written to two locations:
1.) C:\Program Files\Symantec\Backup Exec\Logs
2.) C:\Program Files\Symantec\Backup Exec\Catalogs\[servername]

Number one is causing me troubles because it contains a CatLog_[number].log file which grows very fast. In two weeks it grows from 0 to 30 GB!
Number two isn't really big. The whole folder contains a small 2 GB of data.

- Tool > options > Settings > Catalog: 'Use storage media-based catalogs'checked; 'Truncate catalogs after' set to 1 month; 'Catalog path' set to \Program Files\Symantec\Backup Exec\Catalogs

When I start BEUtility.exe the option 'Change catalog location' is greyed out

Please help me out. I don't understand what and why there is a huge Catalog file at location 1.

Operating Systems:

Comments 3 CommentsJump to latest comment

pkh's picture

Check that debug is not enabled.  See this document

Colin Weaver's picture
Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.

Just to add to that I can't see that the document referenced by PKH actually mentions the registry keys for Catalog debugging:

HKEY_LOCALMACHINE\Software\Symantec\Backup Exec for Windows\Backup Exec\Debug\Enabled

HKEY_LOCALMACHINE\Software\Symantec\Backup Exec for Windows\Backup Exec\Debug\Verbose

Should both be set to 0 (which turns off the extra debugging)

Also if the catalog path cannot be changed in Beutility or inside the BE Admin Console, then as long as a CASO/MMS setup is not involved  you can change it via the registry

a) Stop the services, Move (or copy and then delete when happy) the existing Catalog folder to where you want it to be.

b) Then change

HKEY_LOCALMACHINE\Software\Symantec\Backup Exec for Windows\Backup Exec\Engine\Misc\Catalog Path

c) Then start the services again.

bastwin's picture

Thank you pkh and Colin Weaver. Debug was enabled.