Video Screencast Help

catalogs/media sets

Created: 30 Jul 2013 | 14 comments

Trying to wrap my head around catalogs and their association to tape.  I need to be able to restore as far back as a year and be able to tell what tape I need to pull for said restore.  My current setup is 1 caso and 2 mms, 2012,  caso catalog options are to purge after 1 year, media sets are set to 2 weeks.  Will I also have to set media set to 1 year?

With the current settings I see random things, setting up a restore on some servers I can go back to around 6 weeks where BE is able show which tape I need to retreive but that seems to be the limit- around 6 weeks before BE no longer shows media/tape details.  So I'm not sure what determines this.

My media rotation is 4 week rotation where the 4th week is kept for a year.  SO week 1, 2, 3 and wk4A through L.

Operating Systems:

Comments 14 CommentsJump to latest comment

Kunal.Mudliyar's picture

Purge after 1 year, media sets are set to 2 weeks.  Will I also have to set media set to 1 year?

It means you have to recatalog the tape after 1 year

Tape will be protected from overwriting for 2 weeks if media set for 2 weeks, If you set this to 1 year the tape will be protected for 1 year from getting overwritten.

Nothing will change in the way you restore the data if you change the media set settings.

Have you cleared the date filter in the restore selections.

 

 

 

Technical Support

Symantec

user9's picture

Yes.  I see the the dates going back a year, and can browse the backup sets however when I select something from before a certain point, generally around 6 weeks,  and proceed through the steps, at the last step, the summary screen- there is no media/tape info.

So essentially after wk4 set, if I need to restore from it after a month/2, I have to recatalog tapes to get BE to tell me which tape I need for that particular restore.

Kunal.Mudliyar's picture

Navigate to

Backup Exec round-yellow icon > Configuration and Settings > Backup Exec Settings > Catalogs

Check the option that says Truncate Catalogs After.

WHat is this set on?

Technical Support

Symantec

user9's picture

Its set to 12 months on caso.  On both mms, it is not checked.

 

 

Kunal.Mudliyar's picture

Are you restoring from CASO or MMS?

Can you goto the \catalogs folder manually which is located in the default BE directory and see if the xml and .fh files for those days are present.

 

Technical Support

Symantec

lmosla's picture

Hello,

Try running a catalog with "Use Storage-based catalogs" option unchecked.  (Backup Exec button - Configuration and Settings - Backup Exec Settings - Catalogs)  

  • Check "Request all media in sequence"
  • Uncheck "Use storage-based catalogs" 
  • Uncheck "Request all media in sequence" 
user9's picture

Just made the change- so request all media and purge (after 12 months) are enabled.  Use storage based catalogs is disabled/unchecked.

Setting up a restore I select the date of the week4 set from 2 months ago, I browse the down to a single folder, I see all files but at the summary screen no tape information is displayed.

 

Kunal.Mudliyar's picture

Do you export the media after week 4 ? or do you let the media to be there in the robotic library...

The 4th week job is it a differnt stage of a job which uses a media set that says protect it for 1 year?

 

Technical Support

Symantec

user9's picture

No- I do not export media.

Essentially I use the same media set (Keep data for 2 weeks) for all jobs.  However our backup rotation is 4 a month, friday's basically but the 4th friday's tapes are removed offsitte, week 1 through 3 gets re-used each month but I end up with 12 "week 4's at the end of the year.

I don't stage the jobs any different for that 4th week.

Kunal.Mudliyar's picture

So that means no ways the tapes are overwritten

Its something to do with the BE not able to pull the catalog infomation from the catalogs folder

As you are able to select the resources but the media is not listed in the summary , can you run a backup job and see what media it prompts for?

Also as a last resort try to rebuild the catalog indexes

1. Stop the Backup Exec Services.
2. Open a command prompt on the media server
3. Change the directory to the Backup Exec installation directory:
    \Program Files\Symantec\Backup Exec
4. Type the follow and then press Enter:
    catrebuildindex -r
5. After the process completes restart all of the Backup Exec Services on the media server.

 

 

Technical Support

Symantec

MusSeth's picture

how do you have your CASO MMS catalogs configured eg replicated, distributed or centralized.

if centarlized it could be because of the same : BE 2012 Admin guide page 1017

All catalog files are replicated from the
managed Backup Exec server to the central
administration server. Both the managed
Backup Exec server and the central
administration server store the catalogs that
are produced by the managed Backup Exec
server.
Deletions of catalog files are replicated
between the managed Backup Exec server
and the central administration server only
when the catalog files are deleted by Backup
Exec according to the catalog settings. If
catalog files on the managed Backup Exec
server are deleted as a result of a backup job
or a manual deletion, the deletions are
replicated the next time that the catalogs
are synchronized.

user9's picture

Setup a restore, it did not show the media info, I run it and get the followring error;

#testjob-- The job failed with the following error: Invalid Physical Volume Library Drive Identifier.

Not much more to the job log;

Drive and media mount requested: 7/30/2013 3:37:21 PM
V-79-57344-33031 - Unable to acquire device for the specified pool and media
Invalid Physical Volume Library Drive Identifier.
 
 
Kunal.Mudliyar's picture

Can you locate a job log/history and see which tape it used and later try to catalog that tape from the servers tab?

Can you go to the media set tab under storage and locate the tapes which has the last modified data around the same time when you are trying to do a restore and do a catalog.

 

Technical Support

Symantec

MusSeth's picture

Please upgrade your backup exec to latest SP2 and than retry with the job

Backup Exec 2012 revision 1798 Service Pack 2