Video Screencast Help

CCS Query scope with a DFS share

Created: 09 Jan 2012 | 7 comments
Sunny G's picture

Hi all,

Am having some difficulty with running a query for files in a directory (last modification) using CCS RMS (Bindview) when trying to enumerate a dfs path.

there is a a support article which has not worked:

http://www.symantec.com/business/support/index?page=content&id=TECH140866&actp=search&viewlocale=en_US&searchid=1326136448825

I think it may be a syntax issue.  If someone has done it successfully could you please provide some guidance on how to write the query correctly?

·  Enter Domain Name/OU In the container filed : I put : <mydomain>

·  Enter domain name\DFS share name : I put <my dfs path>

The following are some error messages received in attempts:

--> When I run my query I obtain no data and the following message : Following scopes did not resolve to a list of computer error code 0xcfff2afc

--> Unable to enumerate shares on target computer "server_which_is_referenced_by_dfs"; Reason: Access is denied. (Error Code: 5)

Thanks,

Sunny

Comments 7 CommentsJump to latest comment

Kevin_K's picture

For the advanced scope I use the following , just tested again on a share

 

Domain Name - <Your Domain>

Machine Name - <Machine Name>

Directory Path or Share - You can enter the name of a share on the server, or use the <drive letter>:\<path>

 

I tested it on ver 10.5.1 pcu 2011-4 with a c$\<folder name> and a c:\<foldername> as well as just typing in the shared folder name

AuL's picture

Let say that I have a dfs path as : \\mydomain\dfs\rep1\rep2\mydirectory which is also: \\server1\d$\mydirectory
On domain: mydomain
and I like to run an RMS query for having information about files in this directory

I tried as said with :

******************************************************
Domain Name - mydomain
Machine Name - server1
Directory Path or Share - d$\mydirectory

--> I get as error message "While collecting information. Access is denied"
But I have access with explorer to  \\mydomain\dfs\rep1\rep2\mydirectory and \\server1\d$\mydirectory

*******************************************************
Domain Name - mydomain
Machine Name - server1
Directory Path or Share - d:\mydirectory

--> I get as error message "d:\mydirectory - Access refused

******************************************************

I also tried with the setting Scope to a directory or Share on Machines in a Container

Container : mydomain
Files on machines in this container and all of its suvcontainers selected
Directory Path or share: \\mydomain\dfs\rep1\rep2\mydirectory

--> On task status , I get "Evaluationg path bases scope.." , "Enumerating based scopes", "Evaluationg path bases scope.." ... (Cycle)
Even if there is only about 10 files to check, it never stops

Do you have some idea about the configuration or if there is some specifix access to get on my server?

Thanks

 

Kevin_K's picture

Thats odd because I used those settings and was able to produce a report. (Domain , Machine name , and folder path)

 

Can you run a query against the machine in question for a listing of directories , volumes or shares?

AuL's picture

I forgot to say that the Machine is virtual and two clusters servers answer to this name.

I tried with the virtual and cluster name and I get the same error message :

"server1: Unable to locate any volumes on target computer "server1" for the following reason(s):
Unable to enumerate shares on target computer "\\server1"; Reason: Access is denied. (Error Code: 5)
The following admin share detection rules were applied: Use default admin share. To modify administrative share selection rules, use the Administrative Share Selections configuration item for bv-Control for Windows. - Unable to identify an administrative share to query
volume information."

Changing admin share is the solution?
The admin share is a setting only in CCS or on server?
What is the impact of this change?

I do not have access to this change, I need to have information for requesting the change.

 

Thanks a lot for your help

Kevin_K's picture

two servers have the same name...I may not be following correctly though have you tried to enter in the IP Address for the desired target instead of the machine name? I am guessing they wouldn't have the same IP or there would be other conflicts

 

Even if the machine is virtual , CCS will see it as a machine from an RMS query standpoint. The VM should have its own IP address...I would suggest trying to run a machine report against the target first....with teh IP as the scope to make sure you have access from a top level to basic information

 

if you get information back from that, I would the shares, or directories report again using the ipaddress as the scope

AuL's picture

I can run a query about user on server1 with active directory scope
I get the info

If I tried the same think for having volumes I get when I try to select the server in active directory tree : "Unable to locate any volume on target computer"

I tried also scope in a machine in a domain

domain: my domain
machine: serve1
volume : d

And I get "server1\d" access refused

If I tried a directory query with scope to a directory or share on a Machine in a Domain I get:

domain: mydomain
machine name : server1
directory path or share: d$\mydirectory

"\\server1\d$\mydirectory while collecting information. Access is denied. - Unable to resolve object(s)

But on my PC I'm able to access \\server1\d$\mydirectory

 

Do you have any idea, I try a lot of configuration and still not able to access the directory ?

I have a lot of reference to do like this in RMS, if there was a way to use \\mydomain\dfs\rep1\rep2\mydirectory without server1 it would be wonderful.

Thanks

Sunny G's picture

Hi,

One other thing to check if you are getting access is denied then perhaps the share permissions on the DFS are not allowing the user account you are using to enumerate them.

It does not use your login, but the credentials listed in the credential database to run the query.  Perhaps it is the wrong account or the password is changed or something.  Have you validated the username/password which is being used for the query?

Since you are getting an access denied message, I think the query scope is correct and it can find the folder/share.  Check the permissions on it, and make sure to use an account that has the correct access.  I do not think it is syntax at this point.  You may try to use your user account as the account that runs the query as a test.

Sunny