Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

CCS v11 Queries - Failing

Created: 09 Sep 2013 • Updated: 09 Sep 2013 | 26 comments

I am getting the following error only when trying to run Queries on an asset. I am able to run Data Collection and Evaluations on the asset just fine. Query job fails immediately with "An error occurred in Data activity: Unable to retrieve list of Assets from ADAM. No assets were resolved from the directory either due to insufficient permissions or invalid job definition." I have followed every KB article on this error but cannot get Queries to run. Running v11 (fresh/new install) PU 2013-2 SCU 2013-2 PACU 2013-21 Server OS - all in one install Windows Server 2008 R2 MS SQL server 2008 R2

Operating Systems:

Comments 26 CommentsJump to latest comment

Rohit_Goel's picture

Hello,

The issue can be with either one, or both of the following:

a. Query job definition

b. The asset

Is it happening for all the query jobs, or for a particular query job.?

What kind of a Query job are you trying to run.?

Try and create another simple machines query job, and target any other asset, for which data collection is successful, and see if that works.

 

Thanks & Regards,

 

Rohit Goel

Technical Support Engineer,

ESS Data Center Security & Compliance,

Symantec Corporation

ahumphries's picture

Issue happens with any asset and so far with all target types except for Windows Domain.
Queries run successfully on Windows Domain. ??? Again, data collections seem to be working.
Have tried many different assets in multiple domains.
Have tried simple Windows Machine query, Group, File, and Directory queries.

Matt Plourde's picture

The simplest thing to try:

- Make a Windows-Volumes query (don't add any fields) targeting your CCS App server asset only.

Same error?

ahumphries's picture

Same error occurs on the Volume query. Didn't even have to think about it. Query started and failed almost simultaneously.

ahumphries's picture

Do I have to configure/register CCS Agent in v11 on the App Server?

Matt Plourde's picture

only if they asset is an agent.

Are you trying agent-based or agentless?

ahumphries's picture

Using agentless.  

But was just being curious on the agent-based side.

I have a support ticket opened but at the point of just enabling verbose logging on the Application server then will send in the logs this morning.  They've walked through entire config and cannot figure this out yet.

Something else just uncovered but not sure if related is when defining the Directory Server(LDAP) in the CCS Manager settings.  When I set Windows Machine and select the Data Location I configured for the domain controller then save, when I come back into the settings Directory Server(LDAP), the entry just defined is now duplicated.  Only 1 CCS Manager registered with Default Site.

Afraid to continue on developing new Standards in case I have to blow away the entire implementation and start from scratch...again.

Rick_D's picture

Any other suggestions on this issue?  I too am having the same problem.

App Server, 1 CCS Manager trying to query a windows machine that has successfully been collected from and evaluated! 

Trying a simple query on Groups on that machine but query fails instantly.

Any assistance would be greatly appreciated!!

Matt Plourde's picture

What are the error "Details"?

You gave us the Error "Message"

IE, the details could say: "Credentials are not valid. Error - access denied"

 

Rick_D's picture

The exact status detail is:

Error occurred during CCS Manager activity:  Unable to retrieve list of Assets from ADAM: [Field] not found: [Wnt.Machine.VMWARECENTERSERVERVERSION]

cmccoy2's picture

It sounds like you need to update to the latest PU and SCU.  I saw this problem with earlier versions and one of the latest SCU or PU's solved the issue.  What version is your appserver, managers on ?

Rick_D's picture

CCS App Server SCU - 11.0.10400.1087

CCS App Server PU - 11.0.10300.1148

CCS App Server PACU - 11.0.13900.1000

CCS MGR - 10.0.104.1087

CCS MGR - 11.0.10300.1148

CCS MGR - 11.0.13900.1000

cmccoy2's picture

So it looks like your manager may not have the latest SCU applied.    from your post it looks like the CCS MGR SCU is 10.0.104.1087  Did you mean 11.0.10400.1087?    Also, Make sure that the Windows.Schema.dll file in the ...\Symantec\CCS\Reporting and Analytics\DPS folder is at 10.0.10400.1087.   Also you may want to make sure you have done an Asset Import using the "Network" as the source and add the hosts that you are having issues with.  Sometimes with CCS 11 when you do asset imports with LDAP you only get about half of the properties.  You have to follow that up with the Asset Import with the Network to get the rest of the properties.

 

Rick_D's picture

11.0.10400.1087 is the correct update (fat fingered it!!)

 

Network Asset import only allows me to import from current assets!

 

Rick_D's picture

Query Name and Description
Name:
Stale Assets - Workstations

Platform and Datasource
Platform name:
Windows

Datasource name:
Machines

Query fields
Domain/Workgroup Name
Machine Name (Pre-Windows 2000)
Account Disabled?

Query scope
All Windows Servers (Asset System\Domains\DOMAIN\Machines) - Asset Group
All Windows Workstations (Asset System\Domains\DOMAIN\Machines) - Asset Group

Query results filter
  Account Disabled? Equal To 'True'

Query result sort fields
Domain/Workgroup Name - Ascending
Machine Name (Pre-Windows 2000) - Ascending

Duplicate key options
Allow records with duplicate key

Schedule
Not scheduled

Success notification
Not available

Failure notification
Not available

Query results notification
Not available

Query export settings
Not available

Rick_D's picture

 

I get following with even the most basic "volume" query on a single machine!!

Error occured during CCS Manager activity:  Unable to retrieve list of Assets from ADAM. 

[Field] not found [Wnt.Machine.VMWARECENTERSERVERVERSION]

 

Here is a bit of the details of the Asset Import I used:

General details
Job name:
AI - Windows Servers

Job details
Asset type:
Windows Machine

Source:
Network

Fields:
Domain/Workgroup Name
Machine Name
OS Major Version Number
OS Minor Version Number
OS Type
Machine Is Server
Machine Is Domain Controller
Member of Domain
FQDN
TCP/IP Addresses <LIST>
SharePoint Server Version
IIS Version
VMware vCenter Server Version
Is Apache Tomcat Server Installed
Confidentiality
Integrity
Availability
Asset Tags
Asset Custodian
Asset Department
Asset Location
Asset Owner
Asset Site
Source ID

Folder location:
BusinessObjects\Asset Management\Asset System\Domains\DOMAIN\Machines

Rules:
Pre - Naming Convention - PRE
Update asset - UPDATE
Add asset to the Asset System - ADD
Domain Controllers - ADD
EXTDOMAIN Domain Redirect - ADD
TESTDOMAIN Domain Redirect - ADD

Asset scope:
All Windows Servers (Asset System\Domains\DOMAIN\Machines) - [Asset Group]

Field Filter:
  Machine Is Server? Equal To 'True' and  Account Disabled? Equal To 'False'

Schedule
Schedule:
Not Scheduled

Job success notification details
Success Notification:
Not Set

Job failure notification details
Failure Notification:
Not Set

 

 

cmccoy2's picture

So are you getting the message:  Error occurred during CCS Manager activity:  Unable to retrieve list of Assets from ADAM: [Field] not found: [Wnt.Machine.VMWARECENTERSERVERVERSION] on all assets or just a select few?   

It looks like you are trying to look for stale assets.   There is a script or powershell cmdlet that can help out with stale assets.   Maybe you can use that. Here is a link to that tech doc:  http://www.symantec.com/docs/TECH173175 

Rick_D's picture

I get the same error if I was just trying to get the local admins on all servers.  Seem that it doesn't matter what kind of query I try, I get the same error.  I will look at this doc you posted.

I'd like to clean up the assets I have imported already as quite a few of them are listed in AD but not marked as disabled.  I'd like to filter out those that have't been accessed in at least a month!!

cmccoy2's picture

the script stale assets script should work for that cause.  If you are up to date with all of your product updates and Content updates, you shouldn't be seeing the message about "VMWARECENTERSERVERVERSION".   if you continue to get it, you need to open up a tech support case.

AlexLU's picture

Hello everyone,

 

I faced this error, when i changed the WindowsSchema.dll, to fix a bug.

Never been able to Query Windows asset anymore.

Trying to fix the problem, would probable have cost more time.

So we went for reinstallation, and did not change the WindowsSchema.dll manually (waiting that the problem is corrected in a SCU / PU)

Sorry, i can't help you more than give you my experience.

ahumphries's picture

Glad to see this thread still going and others are experiencing now. I still do not have a resolution from Support. It's escalated to Engineering but a very slow process and been weeks since hearing anything back. They are trying to recreate this problem.
Interesting that you mention ...schema. I had edited the Windows Machine type to add a couple of "Optional" fields. But I had not tried the Queries yet prior to editing.

I have a feeling we may be in store for a reinstall. :(

Any other thoughts out there?

TheMagician's picture

For the sake of clarity, did you install any PU or SCU recently?

We have seen a problem when you apply the latest PU, then at a later stage install a SCU/PACU which is older than the PU which causes all sorts of weird problems.  Like corruption of some database tables/views etc. while others work perfectly.

Applying the latest updates in the correct order may fix your problem, but the chances are slim.

 

ahumphries's picture

As listed in initial post, still running the same versions. I believe the order of install was PU, then SCU, then PACU. Have updated PACU twice since the fresh install.

Rick_D's picture

So perhaps a complete reinstall may be the answer?  Is there a tool to completely remove everything so I don't run into any issues when trying to reinstall CCS?  I have 1 App Server and 4 CCS Managers.

ahumphries's picture

A quick update, working with engineering. Found errors in verbose logging possibly related to schema changes that I made where the query is referring to an LDAP entry in Windows Machine that it cannot find. I think I tried to add a new asset type of Users and extend the Windows Machine type to include local users and groups. Trying to go back through what I did months back to document for support.
I also found when trying to do a search for an asset in LDAP using ADSI Edit that the query string for displayName attribute should have been displayName=domain\machinename but instead had to use displayName=domain\5Cmachinename. The \5C tome represents the ASCII value of the backslash. But....don't know why. Engineer said he has never had to search this way before.
Sure wish there was a way to return the original Windows Machine type and/or entire Schema back to original. So, this may be related to similar issue that AlexLU mentioned earlier. ???
Will keep you updated.
Aaron