Video Screencast Help

Certain archived file types will not open

Created: 18 Apr 2006 • Updated: 22 May 2010 | 24 comments

I have noticed that any archive that has a photo in it will not open. It tries to open but gives an error of "Photo failed to load". This happens with .jpg, .eps, .psd(photoshop) and pdf's that contain photos. I am able to open up archived word and excel files. The EV Server is Windows Server 2003 Standard Ed. SP1 and EV 6.0 SP2.

Discussion Filed Under:

Comments 24 CommentsJump to latest comment

Micah Wyenn 2's picture

Just so we're clear, is this happening after you restore an item from the client's desktop? So the steps you're taking is, select a shortcut, double click to open it, then double click on the attachment and it fails?

If this is true, try this troubleshooting the message, select restore from vault, then try to access the jpg.


Jason Szeto's picture

What is the default viewer for graphic files? I would change it to another program and see if you still have the same issue.

Adrian Lowrance's picture

After future review, I realized that it is any file on a certain share that will not open. I tried some notepad files and I get the error "make sure a disk is in the drive you specified." The other shares that are archived on this server archives open with no problem. Just this one share, nothing will open.

I am also seeing the following in event viewer "Could not obtain the computer name on which to query for an IStorageOnlineOpns interface. Unspecified error ".

I have opened a case with support.

Adrian Lowrance's picture

Also when i look on the file server where the fileplaceholder service is running in event viewer there is

Error downloading file: \\?\G:\Departments\Marketing\folder\folder2\01150002.JPG, Url:
Error An unspecified error occurred. Access is denied

Jason Szeto's picture

Hi Adrian,

Can you set the disableloopbackcheck reg key on your EV server? Did you just recently install Windows 2003 SP1? If you did you'll need the disableloopbackcheck. I remember when I was onsite EV 6.0 just came out and we had problems with SP1 and we did not know about that reg key yet.

Adrian Lowrance's picture

I upgraded to 2003 SP1 awhile back and already had the DisableLoopbackCheck set to 1. Here is what I get when I click on help on the error in event viewer.

Event Number 20491
Severity Error
Application or service Messa
Typical message
Error downloading file: %2 Url: %3 Error %1
Users cannot open internet shortcuts
Error downloading file: D:\Data\BUSINE~1\IPN~1.S\FY2002\SEPYSG~1.DOC,


Error Account detail required, you must supply your account details


Using the account credentials that the placeholder service is running under, log on to the computer that is running the placeholder service.

Click Start, then Settings, then Control Panel.

Double-click Internet Options.

Click the Security tab.

In the list of zones, click Local intranet.

Click Sites.

Click Advanced.

Enter the computer name, without the DNS domain, of the Web Access application computer and then click Add.

Click OK.

Click OK to close the Local intranet settings.

Click OK to close Internet Properties.

Ensure that Integrated Windows Authentication is set on the Enterprise Vault virtual directory

Adrian Lowrance's picture

I noticed on the Enterprise Vault Server there is a registry key called ExcludedFileTypesFromConversion. In this are included .jpg and .bmp. Can these types of files not be archived. If not then why does EV still try to archive them if they are included in this registry key. Can I remove the extensions from this reg key and try to see if this archives these files. Enterprise Vault has tried to archive this file types but they fail to open no matter what type of viewer i choose to try to open them.

Micah Wyenn 2's picture

That regkey controls what types of files are "skipped" when the conversion process attempts to turn them in to html/text for indexing. In effect, what happens is that the email gets indexed (turned in to html), and then the attachment is archived "as is" (as in not turned to in to text/html...which would be messy for binary files). The metadata concerning the attachment _is_ recorded and indexed (so you can search on name, etc), but the contents are not.

So for example, if you had "shortsellthisstock.gif", in the gif was the typed words, "ABCX!", and you sent that to your accountant. If EV archives that mail message, both the message and the gif are archived. You can search on the message metadata, or the gif's file metadata, however, you couldn't search for the "ABCX" that's contained in the gif itself.

Does that make more sense?


Adrian Lowrance's picture

What about for file archiving, not for the email part. Can you not archive .jpg's or .bmp? Any file is this format when i try to retrieve them comes up photo failed to load. It doesnt matter what type of viewer I try to use. Any other type of file that I try to open, .ppt, .xls and .doc I have no problem retrieving. There is no rule set to not archive these file types. They all have a placeholder stub on them but will not open. I've worked with support for 3 weeks now and they dont seem to have an answer.

Micah Wyenn 2's picture

Whelp, have you tried to restore the items via archive explorer or the full website (with baskets)? That'll get you your jpgs back on to the file server and clean up the shortcuts. Next you'd just need to modify your file system archiving rule to skip the jpgs and other binaries. You can do that by just adding a rule at the top of the policy.


Adrian Lowrance's picture

Yes, when i use archive explorer i get the error Conversion excluded for this file type. On my other file server i can open up jpg's that are archived. Also on the server that the jpgs will not open, other files types will, such as word and excel files. they are all under the same share on this file server. the vault account has full control to this files. im just not sure why the jpgs and any type of photo file will not open on this share.

C H's picture

Have you checked if the value for the EnabledVolumes registry key is correct? Or can you open other items on the same volume ok?

You may need to run a dtrace of the PHS to get more information

Adrian Lowrance's picture

I can open other items on the same volume with no problems. After digging further into it, I can also open jpgs in one of the folders under this share but there are a lot of them jpgs in other folders in this same Share that will not open.

I ran a dtrace and sent it to Support and they suggested maybe it was a dns issue and had me to put the servers name and ip address in the host files of the EV Server and the file server. This didnt fix the issue.

Adrian Lowrance's picture

I have checked the vault account permissions and it has rights to the folders. Below is the error I get on the file server that has the placeholder service.

Error downloading file: \\?\X:\Departments\Marketing\Test\Pictures\01150004.JPG, Url:
Error An unspecified error occurred. Access is denied

Adrian Lowrance's picture

On the Enterprise Vault Server I get the following error message

Could not obtain the computer name on which to query for an IStorageOnlineOpns interface
Unspecified error

Richard ware's picture


If you copy the http url location (get from DTrace) into a web browser, can you open the file with no problems, If it comes up with a login box, enter vault admin credentials and see if it opens. Let me know


Adrian Lowrance's picture

I have tried this and get a message that the item could not be found. After escalating the case and getting another support person from KVS we seem to be on the right track. We were able to use the saveset id and find the archived files and extract them to verify that the data is there and accessible. It seems to be something with the sql database. From what I was told there are 3 items in the database that have to correlate, the saveset id, vault id and i believe it was the vault identity. The first two did but the last one didnt on any of the archives that wouldnt open. So the way around this for now if a user needs an item is for me to use the saveset id and do a sql query and find the exact location of the file and extract it. We started out at 6.0 and have since upgraded to SP1 and SP2. Support seems to think that some of the items that were originally archived under 6.0 are the ones that are missing the part in sql to allow them to be recalled. Either this or that the items were deleted and somehow recreated and now they arent able to be recalled via the shortcuts or using archiveexplorer. I know that they havent been deleted because it is various folders under one of my shares that is used by different users, unless they all decided one day to delete all their items. It seems like there should be some way to fix the broken items within SQL. Support isnt sure yet and said I may have to get the backup tape of the items before they were archived and restore them from tape.

Lone-Wolf's picture

dude u sure your archive exists in the EV Dir DB?

check the archiveview

it queries this D/B for the storgae computer that owns that VaultId hence:

Could not obtain the computer name on which to query for an IStorageOnlineOpns interface
Unspecified error

Daniel R.'s picture

I have the same issue

Event Type:Error
Event Source:Enterprise Vault
Event Category:File Placeholder Service
Event ID:20491
Time:12:13:15 PM
Error downloading file: \\?\D:\sharetmp\EVSPS.pdf, Url:
Error An unspecified error occurred. Access is denied

did you solve?


Adrian Lowrance's picture

I am able to go into archive explorer and take the transaction number and do a sql query to find what stores the archived file. According to KVS Support it appears that the link between the shortcut and the database is not there. So for now, I can manually go into the cab files and extract files that users may need. Which sucks, been over a month and no fix from KVS. Supposedly, there is a hotfix that has eta of June 19th to fix this issue.

Adrian Lowrance's picture

Applied the hotfix supplied and can now access all files again.

Andy Burton's picture

Can you provide the name or number of the hotfix you applied? I have been having very simalar issues as this without any resolution.

Thank you

W Wintermute's picture

Contact support and request the hotfix associated with Etrack: 619448 and 583530