Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

CFS NFS configuration

Created: 20 Mar 2014 | 2 comments

Hello team,

I'm trying to configure a CFS NFS HA service, so I've executed this command on the cluster:

cfsshare config -p nfs apbasedg locks /locks and then configured all the shares.

The cfsnfs_locks volume was already created and mounted on the vcs, but now it's not able to mount it anymore:

cfsshare display
VCS WARNING V-16-1-10260 Resource does not exist: cfsnfs_locks
  CNFS metadata filesystem : 
  Protocols Configured : none
  #RESOURCE    MOUNTPOINT    PROTOCOL   OPTIONS
  scs-ESP-nfsshare_ESPgoldclient /ESP/goldclient NFS                            
  scs-ESP-nfsshare_ESPusrsaptrans /ESP/usr/sap/trans NFS                            
  scs-ESP-nfsshare_sapmntESP /sapmnt/ESP     NFS                            
  scs-ESP-nfsshare_userdataESP /userdata/ESP   NFS    

 

#cfsmntadm display

  List of mount points registered with cluster-configuration but not associated with any node :  /locks

# vxdisk -g  apbasedg list 
DEVICE       TYPE            DISK         GROUP        STATUS
vmdk0_10     auto:sliced     apbasedg_0   apbasedg     online shared

 

this is the volume where the cfsnfs_locks volume is available

v  cnfs_locks   fsgen        ENABLED  2097152  -        ACTIVE   -       -
pl cnfs_locks-01 cnfs_locks  ENABLED  2097152  -        ACTIVE   -       -

 

but I'm not able to mount the volume:

 

# cfsmount /locks
  Error: V-35-33: cfsmount: Cluster mount /locks not associated with any node

 

It worked at first, but now no more.

 

Can you please help

 

 

Thanks

 

 

Operating Systems:

Comments 2 CommentsJump to latest comment

Dario Pulcinelli's picture

sorry I first configured the cfsnfs_locks with the volume locks, then, as it faulted after a first time, I've deleted it, recreated and manually changed the volume name to cfsnfs_locks on the main.cf, that's because the cfsshare config it's been done with locks volume in the previous post...

Dario Pulcinelli's picture

getting this error on the engine_A.log:

CFSMount:cnfs_locks:online:Mount Error : UX:vxfs mount.vxfs: ERROR: V-3-21266: /dev/vx/rdsk/apbasedg/cnfs_locks not a block device

but the volume was created and formatted  using VOM and I first mounted it on another mount point to check it was working....