Video Screencast Help

CFS PostOnline Trigger

Created: 08 Jan 2014 • Updated: 09 Jan 2014 | 3 comments
This issue has been solved. See solution.

Version: SFCFS 5.0MP3 on Solaris 10u9.

A "postonline" VCS trigger perl script has been created and tested at the command line using the "hatrigger" utiltiy but the "postonline" trigger script  is not automatically run by VCS when the SF Cluster File System is mounted.  We see in the VCS EngineA Log where the "postonline" trigger is run for other Service Groups (both parallel and failover), but it is not run for the SF-CFS Service Group. 

Will VCS run the "postonline" Trigger script after the CFS Service Group is Online?  if so, how can this be acomplished/configured?

TIA --

Operating Systems:

Comments 3 CommentsJump to latest comment

Gaurav Sangamnerkar's picture

Hi,

post offline trigger should work after CFS service group moves to online state.

I would suggest to refer below links on how to use it

https://sort.symantec.com/public/documents/sfha/6....

https://sort.symantec.com/public/documents/sfha/6....

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

mikebounds's picture

There is nothing special about CFS service groups and I have used postonline triggers for CFS service groups for VCS 5.0 on hp-ux.  If you mean the cvm service group, then this is possibly a special service group, although I would still be surprised if the postonline trigger was not called for this.

Have you put something like "echo postonline has been called > /tmp/logfile" or "halog" at beginning of postonline trigger to confirm if it is being called?

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

ocns's picture

Hui Gaurav and Mike --

Your commnents and suggestions were helpful.  After further analysis, I noticed that the "cfscluster" was in some odd state, for instance: the results of the command "cfscluster status" reported that the cfscluster was not started however, the CFS F/S system was mounted (not local but to the EMC SANs).  Additionally, after completely stopping (force stop was required as node 0 would not Exit), the cluster the CFS still mounted.

To resolve, I rebooted all nodes in the Local Cluster and Wa La, the "postonline" Trigger script worked as expected.  Perhaps there is some known issue in the SFCFS 5.0MP3 release.

At this time, the issue is solved.

Thanks again for your assistance :-)

RB

SOLUTION