Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Citrix 4.5 Terminal Server 2003 Outlook 2003 IE7 Vault 7.0 SP3 Hangs

Created: 13 Feb 2008 • Updated: 09 Oct 2012 | 10 comments
This issue has been solved. See solution.
Alrighty here's a weird one.
On a citrix server with outlook 2003. I can restore vautlted items fine. I can preview vautlted items fine. I can vault items fine.
 
BUT....
 
If I try to just open (double-click) a vaulted item outlook hangs.
If I try to open a vaulted message from the searcho2k webpage in IE7, outlook.exe opens in task manager, but hangs.
If I try to open a vaulted attachment from the webpage (such as a word doc) it opens just fine.
 
I have the offline vault disabled and I have added the OUTLVBS.dll to the office11 folder.
 
Anybody else run into something like this?
 
Discussion Filed Under:

Comments 10 CommentsJump to latest comment

TonySterling's picture
In your mailbox policy > Advanced tab> Desktop settings try making the Download Format msg instead of dvs.
 
Most likely you do not allow pst's to be created even temporarily on the Citrix and is causing your issue.  I believe this issue is being worked between symc and msft to make them play nicely together.  :)
Download format

Controls the format used when an Enterprise Vault shortcut is opened. The item can be downloaded to the user's computer in either of the following formats:

  • As a .DVS file that is then unpacked by the client to create a temporary .PST file containing the item
  • As a .MSG file that the client can open immediately without creating a temporary PST file
596707540's picture
Thanks for the tip. But my policy already defines MSG as the download format.
 
Hmmm. If I open up Outlook in safe mode, and leave it open, I can now open up the vaulted items from the IE7 searcho2k.asp page.
 
Getting closer. It looks like my Outlook running with with extensions on is having a problem with the .msg file.
 
Any other thoughts?
596707540's picture
Also.... if I save a nonVaulted email in msg format (both standard and unicode) to the desktop. I can open either without any problem.
596707540's picture
I've now had a case open for 2 days with no response....

Case # 320-092-773

grumble grumble grumble

TonySterling's picture
Hey mate,
your case is logged as a sev 4, that is the lowest priority.  ;)
 
Call support and have the severity raised.  You need to call, not email.
 
Regards,
Tony
596707540's picture

I figured it out.

open Dcomcnfg from the run prompt

Open My computer properties under Component Service,Computers,My Computer

Click on the "Default Properties" tab

The setting for "Provide additional security for reference tracking" needs to be UNCHECKED. (at least for me).

As soon as I unchecked that box, everything immediately sprang to life.

SOLUTION
TonySterling's picture
WOW!  what a find that is, thanks for sharing.
 
I like this statement, "The last item on the Default Properties tab is the "Provide additional security for reference tracking" check box, which tells the server to track connected client applications by keeping an additional reference count. Checking this box uses more memory and may cause COM to slow down"
 
Some slow down it caused you!  :)