Video Screencast Help

Class not registered Error | Reinstall Enterprise Vault

Created: 26 Oct 2012 • Updated: 16 Nov 2012 | 8 comments
vmds's picture
This issue has been solved. See solution.

Hi,

 

we have an corrupted EV 9 with SP1 Installation located on a Windows 2008 Server.

Synchronizing, Enabling, Disabling Users are all failing with a "Class not registered" error.

I checked the KB, but there is only a solution for Windows 2003 which I cannot transfer to Windows 2008 settings.

 

I thought about reinstalling the EV binaries. To my knowledge, it will not change any settings or the database, correct?

Can i also just update to the latest SP for 9.0 ? Or is that not recommended cause of the issue i have with the current installation?

 

 

regards

 

 

Comments 8 CommentsJump to latest comment

JesusWept3's picture

Reinstalling the binaries will not change any database settings or really anything
You could try running C:\Program Files (x86)\Enterprise Vault\FileReRegister.bat and restart the EV Admin server and seeing if that helps

 

Failing that, just re-install the binaries, you will probably be required to restart your server though

SOLUTION
vmds's picture

Hi JesusWept3,

 

Seems like the Installation doesnt have a FileReRegister.bat. What is that?

 

Restarting the server is ok. There is no archiving happening atm anyway. Journal Archiving doesnt work either. It just marks the item pending but doesnt archive it. If i try to manually archive an item it tells me, that the EV server isnt available atm.

 

 

JesusWept3's picture

manually archiving through the client?
That causes an issue because when you do that, it then believes the journaling needs to be provisioned and all journaling stops, that happens if you do a cancel pending through the client as well, never use client actions on a journal mailbox

And it could be that FileReRegister.bat is an EV10 utility, but i swear i've used it on EV9
basically it just does a regsvr32 and /regserver against many .exe files

But go ahead with the reinstall, it won't change any settings , you won't need to re-run the config or anything, all its going to be doing is basically re-registering each com component and DLL file etc

vmds's picture

@JesusWept3

I reinstalled the EV binaries and restarted the Server.

When i try to synchronize an exchange task i now get an access denied error. I know that the whole exchange environment got renewed (from one EX2010 to 2x Ex2010 + Load Balancer). Someone created the new EX tasks and also the mailboxes + user accounts.

What i already did now:

- gave the Service Account Domain Admin Permissions (only as a test for now, someone gave the right permissions to the wrong vault service account)

- gave the right service account send as permissions for the service mailboxes (one per mbx server)

- recreated the outlook 2007 mail profiles (one per mbx, journaling) on the ev server, confirmed i can log in

- confirmed that the EV Service Account is a member of the local admin group on the EV and on all the Exchange Servers

- as a test i have used a different mailbox for the exchange task (restart after the change), still access denied

 

When i try to activate an user i also get an error that points me to the exchange. The Windows Eventlog is clear.

 

Any ideas? 

 

JesusWept3's picture

Domain Admins have Deny's across the board.
You need to make sure that the EVAdmin is a regular domain user and has Send As/Receive As permissions against the entire exchange org

If the customer has Blackberry Enterprise Servers (BES) in the environment, then the EVAdmin should have the identical permissions and setup as the BESAdmin

vmds's picture

JesusWept3

I gave the VSA the following rights:

Domain Users
Public Folder Management
Recipient Management
View-Only Organization Management

The VSA has Send/Receive Rights on the MBX Mailboxes. I am also able to open any other User Mailbox with the VSA Account. 

I rechecked the Local Security Policys and made sure, that the VSA has the following rights on the Exchange:

Log on as a Service
Act as part of the OS
Debug Programs
Replace a process-level token
log on as a batch job

Its still not working. The items in the Journal Mailbox get the pending item icon but nothing else happens. 

When trying to sync or enabling an user i get the access denied error. 
 

I doubt an upgrade to 9.04 will help? (we are on 9.01 with some hotfixes now). 
 

greetings

 

JesusWept3's picture

Probably won't help
Does it still not work per chance?
Exchange caches those permissions for two hours and can take time for the changes to be propogated.

Just as a matter of interest, did you assign the rights yourself or did you use the permissions powershell script that EV provides?

Also if you log on to the EV Server as the EV Admin and you attempt to open a mailbox, do you get prompted for credentials?

vmds's picture

Hi,

 

sorry for my late reply. I got it fixed!

 

I had to reconfigure the VSA in the Admin Console. There was no change to this account, but apparently it was needed. After that, i was able to sync, archiv, etc again. 

 

thanks for your help!