Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Cleaning of drive is failing with 98 error

Created: 05 Apr 2014 • Updated: 14 May 2014 | 3 comments
rajkumarbaniwal's picture
This issue has been solved. See solution.

Hi,

 

Need support as  LTO4 tape drives cleaning is failing with 98 error (error requesting media (tpreq)(98)). Inserted new cleaning media and tested on all drives but still same error on all tape drives.

Master Server : Solaris 10 netbackup 7.1.0.3

Media server : windows 2003 Netbackup 7.1.0.3

Tape drive Type: LTO4, HP.

Operating Systems:

Comments 3 CommentsJump to latest comment

Marianne's picture

Please show us all text in Details tab of failed cleaning job and also how cleaning tape is configured. Show output of:

/usr/openv/netbackup/bin/admincmd/nbemmcmd -listmedia -mediaid <media-id>

You can also check your config against this TN: http://www.symantec.com/docs/TECH164472

Important that tape must be in None pool and density must be of correct Cleaning type that matches the drive type.
E.g. if drive density is HCART, cleaning cartridge type must be 1/2" cleaning tape.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

rajkumarbaniwal's picture

Hi Marriane,

Thanks for replying. These configuration are already set, tape is in none pool,density is HCART and cartridge type is also 1/2' cleaning tape.  

 

4/4/2014 11:54:21 AM - granted resource CLNU08
4/4/2014 11:54:21 AM - granted resource HP.ULTRIUM4-SCSI.017
4/4/2014 11:54:22 AM - Info bptm(pid=45619) start            
4/4/2014 11:54:23 AMCleaning drive HP.ULTRIUM4-SCSI.017 from server gnndwh01-bkp with media CLNU08.
4/4/2014 11:54:28 AM - Error bptm(pid=45619) error requesting media, TpErrno = Robot operation failed     
4/4/2014 11:54:28 AM - current media CLNU08 complete, requesting next resource HP.ULTRIUM4-SCSI.017:None:CLNU08
4/4/2014 11:54:29 AM - Info bptm(pid=45619) EXITING with status 98 <----------        
4/4/2014 11:54:29 AM - Error nbjm(pid=4110) NBU status: 98, EMM status: The media server reported a system error 
error requesting media (tpreq)(98)

 

nbemmcmd output

bash-3.2# ./nbemmcmd -listmedia -mediaid CLNU08

NBEMMCMD, Version:7.1
====================================================================
Media GUID:                     715ae182-baa8-11e3-8000-86b3e8570ee7
Media ID:                       CLNU08
Partner:                        -
Media Type:                     HC_CLN
Volume Group:                   000_00000_TLD
Application:                    Netbackup
Media Flags:                    1
Description:                    ---
Barcode:                        CLNU08
Partner Barcode:                --------
Last Write Host:                NONE
Created:                        04/02/2014 15:20
Time Assigned:                  -
First Mount:                    -
Last Mount:                     -
Volume Expiration:              -
Data Expiration:                -
Last Written:                   -
Last Read:                      -
Robot Type:                     TLD
Robot Control Host:             gnnbkp01
Robot Number:                   0
Slot:                           161
Side/Face:                      -
Cleanings Remaining:            96
Number of Mounts:               -1
Maximum Mounts Allowed:         -1
Media Status:                   ACTIVE
Kilobytes:                      0
Images:                         0
Valid Images:                   0
Retention Period:               -
Number of Restores:             0
Optical Header Size Bytes:      0
Optical Sector Size Bytes:      0
Optical Partition Size Bytes:   0
Last Header Offset:             0
Adamm Guid:                     00000000-0000-0000-0000-000000000000
Rsm Guid:                       00000000-0000-0000-0000-000000000000
Origin Host:                    NONE
Master Host:                    -
Server Group:                   -
Upgrade Conflicts Flag:
Pool Number:                    0
Volume Pool:                    None
Previous Pool Name:             -
Vault Flags:                    -
Vault Container:                -
Vault Name:                     -
Vault Slot:                     -
Session ID:                     -
Date Vaulted:                   -
Return Date:                    -
====================================================================
Command completed successfully.
bash-3.2#

 

 

 

Thanks,

 

rajkumarbaniwal's picture

This issue is solved with help of oracle.

Actually we are using CLNXXXL1 media barcode for cleaning. As recommended we should use  CLNXXXCU(unversal bar code) for cleaning of tape drives.

 

Thanks,

 

SOLUTION