Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Client installation issue

Created: 17 Jun 2013 | 5 comments
Yajith's picture

Hello everyone,

I'm having an issue with installing NetBackup client (7.1) on a Solaris (x86) system. I have read similar issues reported on the community and followed the advices on them, but the issue continue to occur.

Installation fails giving the below error.

========= Installing package ==========
 
Processing package instance <SYMCnbclt> from </tmp/nb_pkg>
 
NetBackup Client(i386) 7.1.0.0
## Executing checkinstall script.
Copyright 1993 - 2010 Symantec Corporation, All Rights Reserved.
pkginfo: ERROR: attach door: Not owner
/var/tmp//installJtaGI4/checkinstallLtaGI4: test: unknown operator 1
pkgadd: ERROR: checkinstall script did not complete successfully
 
Installation of <SYMCnbclt> failed.
No changes were made to the system.
 
I have attached my install.trace as well. Appreciate any advice on how to fix this.
 
Regards,
Yajith
Operating Systems:

Comments 5 CommentsJump to latest comment

Yajith's picture

attached install trace

AttachmentSize
install_trace.7z 5.28 KB
Will Restore's picture

Trying running truss per Revaroo's post here:

https://www-secure.symantec.com/connect/forums/nbu-71-client-install-fails-solaris-10

Will Restore -- where there is a Will there is a way

Yajith's picture

I have attached the truss output. Appreciate any help to identify the issue.

AttachmentSize
truss.txt 53.48 KB
Dyneshia's picture

Ensure you are logged in as root, ensure you have priviledges to access the package.

Also ensure /tmp and /var/tmp are writable to you (when logged in as root) and that there is enough space in them. /tmp should be write permissions (dwxrwxrwt) same for  /var/tmp 

ls -ld /tmp /var/tmp - what does it say?

df -k /tmp /var/tmp

Did you follow the instructions to use gtar to extract the NetBackup_7.1_CLIENTS.tar file?

See this TN: http://www.symantec.com/docs/TECH154080

try re-downloading the software
 
Are there any harmful alias in your shell? Run "unalias -a" and try again.
 
Check for PBX version on the zone

pkgchk  -l VRTSpbx

Remove PBX on the local zone client if the version of pbx is incorrect:

 pkgrm VRTSpbx

What is $LD_LIBRARY_PATH set to ?

 
Other things to try :
 
https://www-secure.symantec.com/connect/forums/client-install-issues-0#comment-5808981
 
Yajith's picture

I have followed the instructions on the technote, and also have tried re-downloading.

Below are the command outputs.

phm1svewmm1:/# ls -ld /tmp /var/tmp
drwxrwxrwt  10 root     sys         3949 Jun 18 10:25 /tmp
drwxrwxrwx  19 root     sys         6144 Jun 17 17:49 /var/tmp
 
phm1svewmm1:/# df -k /tmp /var/tmp
Filesystem            kbytes    used   avail capacity  Mounted on
swap                 43238232 9553204 33685028    23%    /tmp
/dev/dsk/c0t0d0s0    237754134 55896161 179480432    24%    /
 
phm1svewmm1:/# id
uid=0(root) gid=0(root)
 
I have attached the pkgchk -l VRTSpbx output herewith. I'm not sure how to check the version, could you kindly advice on that ?
 
echo $LD_LIBRARY_PATH does not give any output, I think it is not set.
 
Additionaly, i noticed below application is also installed on this system somehow.
application SYMCnetbp                        NetBackup and Media Manager
AttachmentSize
pkgchk -l VRTSpbx 11.76 KB