Video Screencast Help

CMS 7 SP2 MR 2 Released

Created: 29 Sep 2010 • Updated: 30 Sep 2010 | 42 comments

MR2 has been released in the SIM including Inventory, Patch Management, DS and Software Management MR2 releases. SMP 7 SP5 doesn't looked to be released fully yet. When I updated SIM it prompted to install Windows Installer 4.5 and .Net Framework 3.5 SP1. No release notes that I can find yet, though the SP5 user guide and release notes were published last week.

EDIT - As discussed below, these updates have been pulled and are no longer available. I wonder what’s going on?

Comments 42 CommentsJump to latest comment

powellbc's picture

I really wish that release notes were available in SIM BEFORE installation.  It's a drag having to search through the KB hoping they have been posted.

powellbc's picture

Also, I can't believe how sloppy it is that SMP 7 SP5 is not available but other pieces of SP% are.

jessek's picture

http://www.symantec.com/business/support/index?pag...

All of the SP5 release notes were actually published ahead of time.  What I can't find are the release notes for all of those MR2 upgrades.

Jesse Kozikowski
Aspirus, Inc.

Scott Gerber's picture

I tried installing the Event Console SP5 on 2 lab NS boxes and the install fails with an error that it cannot configure the solution. Also, I cannot start the Event Services and the Application Event files has msi '1004' errors complaining of resources that don't exist.

 

Anyone else see this?

 

Troy Whittaker's picture

Similar experience here.  I installed SP2 MR2 releases and now EventReceiver and EventEngine fail to start.  SIM reported 100% success with the install, but those 2 services generate a 1053 error when attempting to start and Event Console SP5 shows up in both installed solutions and available upgrades.

powellbc's picture

I too had this error, probably because I got over enthusiastic about installing it ahead of the SMP SP5 piece.  That's what test/dev environments are for though.

billasullivan's picture

Here is a screenshot for it on a brand new install

I tried to create a mysupport ticket for this but there is no solution that matches CLient Managment Suite in the list.  OMG!!!

Takes hours to get through to support so I hope that someone in Symantec will see this

 

powellbc's picture

I looked this morning to see if SMP 7 SP5 was released and it looks like all of the updates were pulled back. Between this and pulling back the 64-bit SVS, i wonder what is going on at Symantec.

ChrisDallas's picture

It also looks like SIM 7.0.814 has been pulled... 

treyjack's picture

Same issue here. I have a bunch of broken Notification Servers now.

treyjack's picture

I just spoke to someone from Symantec and supposedly they will be releasing SP5 later today sometime and will resolve the issues we are seeing.

xalamu005's picture

I recieved .NET errors all through the [install] process and the Server's event logs show the 'Altiris Event Engine' failing.  Since the NS console repeatedly tries to use this service, it creates entries in both the System Event viewer and Altiris Log viewer every 5 min.

treyjack's picture

New updates have been published by Symantec. Applying them to one of my Notification Servers. *crosses fingers*

pro.gti's picture

Found the MR2 release notes here, the updates are back in the SIM, here are the version details:

Altiris Inventory Solution SP2 MR2 (7.0.1278)
Symantec Management Agent for UNIX, Linux and Mac SP5 (7.0.8641)
Symantec Management Platform SP5 (7.0.8641)
Altiris Event Console SP5 (7.0.8641)
Altiris Pluggable Protocol Architecture SP5 (7.0.8641)
Altiris Patch Management Solution for Linux SP2 MR2 (7.0.4305)
Altiris Patch Management Solution Core Services SP2 MR2 (7.0.4310)
Altiris Deployment Solution WinPE Support MR2 (7.1.629)
Altiris Patch Management Solution for Windows SP2 MR2 (7.0.4312)
Altiris Deployment Solution Linux Support MR2 (7.1.629)
Altiris Network Discovery SP5 (7.0.8641)
Altiris Software Management Solution SP2 MR2 (7.0.1866)
Altiris Deployment Solution Core MR2 (7.1.629)
Symantec Management Platform Documentation SP5 (7.0.8641)
Altiris Deployment Solution Documentation Update MR2 (7.0.1017)
Migration 7.0 SP5 (7.0.8641) 

As posted previously, here are the SMP SP5 release notes.

Installing now (on a VM)!

xalamu005's picture

Can not update due to incompatibility with some of the Dell Managment Components...

xalamu005's picture

Apparently this can not be done until Dell release updates for their products.  To install SP5 updates, one must uninstall the Dell Managment components.  And Why Not!!....

Pascal KOTTE's picture

I must say for the moment, I never install the Dell or HP client Managers, in production servers.

What I do, I install on a LAB/VM server, exports or "reverse engeniring" the Items I would like to use, and import/recreate them into the standard "pure Altiris" in production.

It is more work to do, but a better chance to get a stable install. I do not like installing a suite, making thousand additionnal jobs/taks/error running my Altiris server, just to inventory and update Dell/HP client BIOS !!! :)

~Pascal @ Kotte.net~ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF

xalamu005's picture

The Dell console is (apparently) a pain the .... BUTT to uninstall, as it incorporates itself into the Altiris console as Internet Explorer into Windows.

 

This is going to be painful I think...

mmooney's picture

Really?  it would seem to be fairly straightforward to uninstall.  Just go into SIM, and filter by Product Type and Suite and uninstall the DMC.  If necessary run repairs on the Altiris suites installed and you're done.

It's even easier if you are running the Altiris server Virtually since you can take a snapshot before doing any of this and if something goes wrong you just revert.

I'm planning on doing exactly this within the next few days as my Altiris install is having all sorts of issues that these updates are supposed to fix.  I would rather do without the Dell components for awhile if I can fix some functionality (Curse you Silverlight!) and maybe gain a few features along the way.

pmakaveev's picture

Can you guys publish the link for known issues fixed and the substantial number of bug fixes fixed in SMP 7.0 SP5? And the same for CMS 7.0 Sp2 MR2.

 

Also, I am looking for a best practices document on upgrade from SMP SP4 to SP5 and from CMS SP2 to SP2 MR2 in order to plan the upgrade properly.

Thank you!

chris.vanderlinden's picture

So, based on the release notes (I didn't see DS in there for some reason), don't bother upgrading?

 

Don't get me wrong, there were a lot of issues resolved, but they don't seem to outweigh all the new issues that are caused by the updates as listed in those release notes 

 

(IMO of course)

treyjack's picture

With .NET 3.5 SP1 now supported and actually required to upgrade SIM our consoles appear to be responding a bit faster. That in itself made it worth it to us.

powellbc's picture

So, which components cannot be upgraded due to the Dell issue?  Is it just the MR2 updates or also SMP SP5?

xalamu005's picture

Just the SMP SP5 components.  The main culprit is the [Symantec Management Platform] SP5, as it is reporting incompatibility with the Dell console components.  Since all other SP5 components rely on the main SMP, they will not install either.

The Dell cuprits are:

-Dell Solutions (1.1.0)

-Dell Solutions Update (1.1.1)

-Dell Management Console (1.1.0)

 

I can not speak for the MR2 updates, as I was unfortunate enough to jump the gun and install the updates during the 'unofficial release'.  The [MR2] installs did not seem to have issues with any Dell components.  --Just everything else Altiris--

Now I am stuck until I hear from an NS engineer.  1 week so far...

xalamu005's picture

The uninstall of the DMC was not as bad as I thought it would be.  'Dell Management Console' is still stamped all over the NS though.  The Dell Client Manager is still installed, and does not seem to cause any issues with SMP SP5.

Doing SP5 updates now...

powellbc's picture

Niot sure whwere I found this on Connect, but this SQL query will change the branding of the console back to Symantec:

 

--To change branding back to Symantec Managament Console after installation of Dell Client Manager; run this query on the Altiris 7 Database

UPDATE Item SET ModifiedDate = ( select getdate() )
WHERE Guid = (    SELECT Item.Guid
                        FROM Item
                        Join ItemClass ON Item.Guid = ItemClass.Guid
                        WHERE ItemClass.ClassGuid = '1f768417-511a-4c22-afbc-4a66720f793a'
                        and Item.Name like 'Default%' )
mmooney's picture

How did this go for you?  Did you run into any issues or was it as smooth as expected?

xalamu005's picture

Okay, so I thought the uninstall of the Dell Management Console went well, and then...

Restarted the console to ensure proper uninstall of components.  Come to find out, now SP5 is complaigning about the rest of the Dell components.  I now have to uninstall all the Dell Client Manager components.

xalamu005's picture

The Dell Client Manager components uninstalled much easier.  Other than a few complications, I am done.  Had to set the Altiris Event Reporting Service to manual until after the install.  The Altiris Monitor Solution for Servers (SP5) update was having trouble handling this service during install.  It is set back to automatic and all seems well so far.

The NS does seem a little more responsive now.

Also, the 'Dell Management' Console branding is gone from the NS.

xalamu005's picture

All Dell components are gone, however I am now getting a multitude of 'error loading dataclass' warnings associated with old Dell components.

Also, I am back to getting the 'taskserverhandler' not installed.  Will have to fix this again.

dlopes's picture

Like this one from Patch-Management

Daniel Lopes de Oliveira
Technical Team Leader - Endpoint Management & Mobility

faigi's picture

Through Symantec trailware site http://www.symantec.com/business/products/downloads/index.jsp, i am able to download only Symantec Installation Manager (SIM) version 7.0.715 . Anyone knows where i can download the sim 7.0.814 version? without that it is failing to download the installation files. Also i am unable to get this through current SIM (Snapshot attached).

Untitled picture.png
xalamu005's picture

Did you try looking in the SIM installs folder to see if the file exists (downloaded)  '.\Altiris\Symantec Installation Manager\Installs\Altiris\'?

 

What do the OS [system] event logs say when trying to install the upgrade?  And the Altiris Event Viewer?

xalamu005's picture

I guess I will have to live with the Dell 'data class' errors as, I've been told, the only (current) fix is to reinstall the NS.  Not worth it.  The errors are not causing any major problems, just an annoyance.

The Event Engine portion of the SP5 update never installed correctly giving me repeated errors in the OS event logs.  Worked with Symantec support to get the Event Engine update to install correctly, but now I'm stuck with new errors:

---------------------------------------------------------------------------------------

Event Type:    Error
Event Source:    Application Popup
Event Category:    None
Event ID:    333
Date:        10/24/2010
Time:        8:35:10 PM
User:        N/A
Computer:    MCMHALTIRIS2
Description:
An I/O operation initiated by the Registry failed unrecoverably. The Registry could not read in, or write out, or flush, one of the files that contain the system's image of the Registry.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 00 00 00 00 01 00 6c 00   ......l.
0008: 00 00 00 00 4d 01 00 c0   ....M..À
0010: 00 00 00 00 4d 01 00 c0   ....M..À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........

-----------------------------------------------------------------------------------

Event Type:    Error
Event Source:    EventEngine, Version=7.1.1641.0, Culture=neutral, PublicKeyToken=null
Event Category:    None
Event ID:    0
Date:        10/24/2010
Time:        2:02:11 PM
User:        N/A
Computer:    ********
Description:
An internal error occurred.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

--------------------------------------------------------------------------------------

Oddly, there are no errors concerning the Event Engine within the Altiris event viewer.  But that's another topic... (Check out 'Event Engine errors after SP5 upgrade' if interested)

TeleFragger's picture

well i have a ns 7 box that i setup as a test a while ago..

 

now im trying to go out and get my updates.. it tells me that sim 7.0.814 is out and when i try and download it it fails.....

the following files have failed to validate:

http://www.solutionsam.com/solutions/7/qa/sp5/sim_814/symantec_sim_7_0_kb49812_x86.exe?symct=1289593979_03f7f4bb7ede6951aff428f3481f2293

 

so it  says sp5 in the link... but what is the qa?

can someone point a link to this for me?

the file does not download to the install folder..... and i cant update my 19 product updates!!!!!

Did we help you? Please Mark As Solution those posts which resolve your problem,

xalamu005's picture

I ended up having to reinstall the CMS product to total.  The preemptive MR2 release before the SP5 caused version discrepancies and nothing was working right.  Luckily most settings in the NS console are easily exported before reinstall and imported after reinstall.

powellbc's picture

We've had some disastrous results since upgrading to SMP SP5 and may need to reinstall as well.  How do you export the console settings?  Do you mean using right click > Export XML?

Thanks,

Bryan

TeleFragger's picture

well our issue was we were denied access to solutionsam.com (via internal ways..) and now that is fixed.. but it is seeming im having a difficult time updating everything else.. maybe im gonna do the same.. uninstall it all... however I dont have to export anything.. we never started using it!!!!!!!!

Did we help you? Please Mark As Solution those posts which resolve your problem,

xalamu005's picture

Are you, by any chance, having an issue with your [Altiris] licenses?  Check the Windows certificates for Symantec/Altiris entries and see if these have entries for 'http://licensingca.altiris.com/...' which is no longer a valid CA.  This has been causing my organization greef.

The Symantec/Altiris licenses are pulled in to the system as OS certificates and uses the certificate manager to validate your 'licenses'.  Since there is no valid server labeled to validate against, the licenses have a tendency to appear 'invalid' or 'expired'.

I ended up having to reinstall my whole NS, it works for the most part, but I can not get or see many updates.

xalamu005's picture

That is correct, this can be done with all policies, filters, jobs, etc...

I would suggest to put each in a properly named folder at export so that it will be easy to know where to reimport at the time of resetup.

The reimport will create new guids to associate the NS with these saved exports.  There is no way, however to save resources.  If a job is associated with a resource, the resource will have to be set up in the new install and then reassociated with the job.

ie - To setup up an imaging job that was previously in my old NS/DS, I reimported the job and all associated tasks.  I then had to import the image files into the console via the Resource Import tool (located: "C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\Task Handler\Tools\ResourceImportTool.exe").  Then I had to Add the OS licenses back in.  After pointing the Job to these two pieces, it was back to normal.

This is because I completely deleted all Altiris related program folders after the uninstall.  I also used a new database with the new install as to avoid any issues they may have lain within the old database.

Also all patch (jobs) will have to be redownloaded and reapplied to a distribution task (TEDIOUS).

My final tip is that you should use a (free) tool called 'My Uninstaller' to completely remove all portions of Altiris.  You can google this.  I was referred to this tool by Symantec, as no matter how hard I tried, not all portions of Altiris were removed by the SIM [OR] via 'Add/Remove Programs'

 

--Hope this helps, good luck--

TeleFragger's picture

on an uninstall or trying to install I am getting an error.. it cant upgrade SIM....

is the .814 still the version or is there a newer one?

im on the phone with altiris on hold.. 4 minutes now and havent even got my first part of call opening the case done yet!!!!!

Did we help you? Please Mark As Solution those posts which resolve your problem,

xalamu005's picture

I am assuming you have the right version now according to your last post?