Video Screencast Help

CMS 7.5 - System Packages not downloading

Created: 24 Oct 2013 • Updated: 02 Nov 2013 | 2 comments
Mistral's picture
This issue has been solved. See solution.

Hi there,

I did a fresh install of CMS 7.5 requiring SSL/HTTPS using a self signed certificate.

No errors, didn't touch anything, everything looks fine so far.

 

The agent on the server has two policies assigned:

- Deployment Task Server Components (x64) - Install

- Extract SSL Certificate(x64) - Install

Both are still waiting for the download, because the NS didn't give the agent a valid download location so far.

I found both packages in the console and the physical files are where they should be.

So i tried to update the distribution points ... of both packages and of all packages.

 

Here is what happens:

- I get 78 snapshot.xmls in "C:\ProgramData\Symantec\SMP\Snapshots" ... fine

- I get 78 errors in the log (the GUID is different for every error of course):

Unable to generate a signature for package snapshot of package ba31076c-5379-4c1b-87a6-5d603e4f23c8
Altiris.NS.Security.Cryptography.KeyNotFoundException (Altiris.NS): The key 'NS.PackageSigning' does not exist.

 

Didn't find anything about this error (connect/KB/Google).

- Did i miss anything?

- Can this error be ignored, or is it the reason for the missing package download?

- Am i the only one having this error? Did my installation fail miserably?

- Any ideas?

 

Kind regards,

  Mistral

Operating Systems:

Comments 2 CommentsJump to latest comment

burndtjammer's picture

Does "publish HTTPS codebase" have to be selected in the package server settings?

Context help doesnt give clear guidance on what these settings do.

package_server_settings.PNG

Mistral's picture

I didn't install any Site Server yet :)

 

I finally was able to track down the error and solved it. It was some strange behavior of the installation and a Microsoft bug.

1.) Comparing "C:\ProgramData\Symantec\SMP\Snapshots" with another (running) server i had all the snapshots, but were missing all .sig files.

2.) I used Process Monitor to track down the fail NS.PackagSigning error. I found out i was missing "C:\ProgramData\Symantec\SMP\KMS\NS.PackageSigning.kms" (funny, as all the other kms-files were present).

3) Finally i found a line in the logs, that the file could not be created because i was logged in with a temporary profile (Windows didn't tell me, SIM didn't tell me, all other kms-files were created successfully).

4) I failed getting logged in with my "real" profile until I finally found some MS-KB to delete a registry-key from "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList": http://support.microsoft.com/?kbid=947242

5) I finally was able to have a good windows profile and the installations succeeded in creating the NS.PackageSigning.kms file.

 

I still wonder why SIM ignores this "error" and was able to create all kms-files ... but this (essential) one.

 

SOLUTION