Video Screencast Help

Compliance Accelerator Client via Citrix issue opening .pdf files

Created: 09 Dec 2013 • Updated: 11 Mar 2014 | 9 comments
This issue has been solved. See solution.

We are trying to get our remote email reviewers to review emails by using the compliance accelerator client via Citrix.  All in all it seems to work fine with the exception of opening .pdf files.  When opening a .pdf file we get the following error

There is a problem with Adobe Acrobat/Reader. If it is running, please exit and try again.(103:103)

When the CA client is local with Adobe local we do not see this issue.

We are running Adobe reader 10.1.7. and where others have seen this error but not related to CA the issue has either been due to opening documents in a browser or protected mode.  I have tried what has been suggested without any luck.

Does anyone have any thoughts out there?

 

Teddy

Operating Systems:

Comments 9 CommentsJump to latest comment

EV_Ajay's picture

Hi,

To open file it is require to install Adobe on client machine where we try to open the file.

 

Thanks,

Ajay

TonySterling's picture

Sounds like a similar problem here: http://www-01.ibm.com/support/docview.wss?uid=swg2...

Symptom

There is a problem with Adobe Acrobat/Reader. If it is running, please exit and try again.(103:103)"


Cause

Adobe Acrobat Reader setting blocking function/feature required by Controller.

Environment

Issue could potentially affect any environment, but it has been specifically seen when customers deploying Controller via Citrix.

Resolving the problem

Disable the Adobe Reader setting "Enable Protected Mode at startup".

nirender's picture

Hi Tony.

Have not spoken to you forever!!

I did see this article before we have "Enable Protected Mode at startup" disabled by default.  So I enabled and tested, document did not open as expected, then disabled and tested. Still did not work.

Adobe is installed locally, so I am not sure what to do.  We are thinking about publishing adobe in the same workspace but we are unsure if it will work.

 

Teddy

Kenneth Adams's picture

Hello, nirender;

I've not seen any update since your last one to Tony on 10 Dec 2013.  Did you find a way to fix the issue?  If not, I recommend installing Adobe Acrobat Reader in the same manner as you installed the CA Client.  CA needs to have access to the registry of the machine on which it is launched in order to 'see' if Acrobat Reader has been installed.  As you are using a locally installed Acrobat version with a Citrix published CA Client, the CA Client is unable to access the locally installed Acrobat Reader.  Having both the CA Client and Acrobat Reader installed in the same manner may allow you to get the results you want.

We don't have Citrix installed in any of our labs, so I can't test this myself.  I'm hoping you will let us knonw if publishing Acrobat Reader in the same manner as you've published the CA Client resolves the issue.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

nirender's picture

Hi Kenneth.

I did not find a fix, however your comments are very helpful.  One of our thoughts was to make Adobe available via the same workspace as the CA client in citrix which is along the lines of what you have suggested.

I will also ask about access to the registry.  If you are able to provide more info such how CA accesses the registry or is it a service account that it requires that would be useful as well.

Kenneth Adams's picture

The account used to run the CA Client only needs to search the registry for program associations with the file extension of the attachment.  As such, it works just like Outlook when double clicking on an attachment to have it open in its 'native' program.

I would recommend just installing the Acrobat Reader and publishing it as you did with the CA Client.  If that does not work to provide the solution you need, you may need to run something like Process Monitor or another tool from SysInternals to see what registry paths / values are attempting to be read and are failing on the Citrix server.  I don't think you'll have any problem, but using the appropriate tool to troubleshoot should help lead you to the solution.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

nirender's picture

Finally got around to doing more testing.  When we ran procman we were seeing that Adobe was being found in the registry paths.  We then went and tried other versions of Adobe, versions 8 and 9 worked fine but there were issues with versions 10 and 11.  We have been able to bundle Adobe 9.3.3 and Compliance Accelerator client 10.0.4 together in a single virtual package and this appears to have resolved the issue.

SOLUTION
Kenneth Adams's picture

Thank you for the update.  We've seen issues with the Acrobat Reader version in the past, but not lately and not with the CA 10.0.4 Client.  This is very good information to have.  Thank you, again, for the update.

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region