Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

The configuration of the AdminConnection\TCP protocol in the SQL instance BKUPEXEC is not valid.

Created: 11 Oct 2010 • Updated: 12 Nov 2010 | 2 comments
This issue has been solved. See solution.

Hello all,

I am recieving the following error in my logs "The configuration of the AdminConnection\TCP protocol in the SQL instance BKUPEXEC is not valid." I am running Server 2008 R2 x64, this was a clean install along with a new install of BE 2010. I found 2 articles on the Symantec site, this one:

https://www-secure.symantec.com/connect/forums/sql-instance-bkupexec-not-valid which links to a tech article ( http://support.veritas.com/docs/283949 ) that basically says it is not Symantecs issue in more words but offers no suggestions on fixing the error. The Below article which referrs to some registry settings that are non existant on my machine, I do not want to go adding stuff randomly not knowing how much work this will generate for me if it doesn't work.

I do not know why if it is a common issue that Symantec does not have a TechArticle that explains how to fix this issue (If it really is an issue).

Appears thatsince this is SQLEXPRESS this may be the cause of a feature that is not enabled or an option with SQL Express.

But it would be nice to know one way or another.

(ERROR MESSAGE)

Log Name:      Application
Source:        SQLBrowser
Date:          10/10/2010 11:04:42 AM
Event ID:      3
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      NWMEDIA.oly.esri.com
Description:
The configuration of the AdminConnection\TCP protocol in the SQL instance BKUPEXEC is not valid.
Event Xml:

 
"""""""""
Hello, This warning "The
Hello,
This warning "The configuration of the AdminConnection\TCP protocol in the SQL insrtance BKUPEXEC ist not valid" is not generated by the Backup Exec installer, but rather the SQL installer. The warning does not have any effect on remote connections to the BKUPEXEC instance.
This message appears because the TCP/IP Protocol for the instance is disabled. If desired, you can enable the TCP/IP Protocol for the instance and then configure the IP addresses you want the instance to listen on.
You can try changing the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp\TcpDynamicPorts
The default value is 0 change it to 1434. Restart the SQL service and the error from the SQL Browser stop being recorded at every startup.
 
""""""""""
 
Any help on this would be appreciated

Comments 2 CommentsJump to latest comment

BEsymc's picture

The issue can arise because of various reasons:

1. TCP/IP is not enabled for the instance. Use SQL server configuration manager to enable the same.

2. There is a port conflict between multiple instances of SQL on the same machine. Allocate different ports to different instances using SQL server configuration manager or registry as mentioned in your post.

Please mark it a solution, if this is useful.
Thanks

RSOLY777's picture

There is only one instance of SQL installed by BE as that is the only thing on this machine. TCP/IP was enabled for the SQL Instance.

In the registry I did find Since it is a x64 Machine,  HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp\TcpDynamicPorts

I changed the default from 0 to 1433

I found reference to this on another board but forgot to get the web address

We will see if this fixed the issue.

Thanks for trying

SOLUTION