Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Configure MSDP on a Media Server

Created: 22 Dec 2012 • Updated: 26 Dec 2012 | 11 comments
jawad_butt's picture
This issue has been solved. See solution.

I am new to NetBackup and would like some support on MSDP. I have a 7.5.0.4 environment with one Master and one Media on Server 2008 r2. Everything is working fine, but i am not sure how to configure the MSDP. I have all the licenses but when i configure the MSDP on a Windows Server (Enterprise) 2008 R2 with 1.5 TB disk, i get the error: invalid command parameter. I looked around but didnt find any specific reasoning about it.

I have never configured it before, so not sure what i need to have the MSDP functionality enabled on Media server. I did uncheck the box on the drive to make sure it is not indexed. But other than that, i am not sure what command to run or what/how to install feature. Thank you for any help.

PS: This is on a Virtual environment and i do not have any appliances in place.

Comments 11 CommentsJump to latest comment

RamNagalla's picture

hi,

please follow the steps listed in below tech note.

http://www.symantec.com/business/support/index?pag...

Make sure you are validating each step before moving forwared to next step..

hope this helps..

Marianne's picture

Planning and preparation is key with MSDP.

Please take your time and read through the Dedupe Guide: http://www.symantec.com/docs/DOC5187 
as well as NBU Deduplication: Additional Info: http://www.symantec.com/docs/TECH77575

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
jawad_butt's picture

can you guys share with me the name that is supposed to be listed under licenses for the MSDP?

captain jack sparrow's picture

With your license certificate it should be DeDupe Front end  or Data Protection Optimization

Under NBU licenses it would be PureDisk Option

 Cheers !!!

CJS

jawad_butt's picture

the attached picture... does that mean i dont have license for dedupe or MSDP?

thanks,

licvense.png
Marianne's picture

Not sure what GUI output means.

You do have Dedupe license. The fact you could start with config means that MSDP license (Puredisk) is valid. 

You need to go through Dedupe Guide to ensure that all config steps are executed correctly.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Yasuhisa Ishikawa's picture

Have you already tried restarting both master and media server?
Server name and its IP address is identical?
Do these servers have multiple networks? if so, please ell us more detail about your configuration.

Can you post output of following commands on both hosts?
nbemmcmd -listhosts -verbose
bpclntcmd -self
bpclntcmd -pn
bpclntcmd -ip ip_address_of_peer_host
bpclntcmd -hn hostname_address_of_peer_host
reg query HKLM\Software\Veritas\NetBackup\CurrentVersion\Config /V Server

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

captain jack sparrow's picture

Not sure it it's catch, but could you verify if IPv6 is enabled or not, Disable IPv6 and try MSDP storage server config . Let us know how it goes

 Cheers !!!

CJS

jawad_butt's picture

Well, IPv6 has been disabled from the start... servers have been rebooted ever since and just rebooted again but to no avail. Disk has been formatted with 64K allocation size... but stil the same error.

Marianne's picture

Please go through the TN in Nagalla's post. Take screenshots of each step and post all of them.

Problem is that we don't know where you have gone wrong and that some NBU config may have been done already and will first have to be removed before  you can restart.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

jawad_butt's picture

Ok. Got it to work.

When i was configuring MSDP, i was using F:\ instead of F:\DedupFolder. When i used F:\DedupFolder, it went through. Thank you for the help.

Jawad