Video Screencast Help

Conflicting job rules created by policy not being followed

Created: 03 Apr 2006 • Updated: 22 May 2010 | 13 comments

I just started using Backup Exec last month.

I created a grandfather-father-son backup policy using the policy wizard. My daily backups are scheduled for M, T, W, R. Weekly backups are scheduled for Friday. Monthy backups are scheduled for the last day of the month. Rules to handle conflicting jobs specify that a weekly job will supercede a daily job, and monthly job will supercede both daily and weekly jobs.

When I looked in the calendar view of Job Monitor for last week's jobs, I noticed that for Friday, March 31, it showed both the weekly and monthly jobs, but with the weekly job in blue (meaning it is the scheduled job) and the monthly job in purple. Sure enough, when I checked today, the weekly rather than the monthly job ran on 3/31/06. Why did Backup Exec do exactly the opposite of what the policy said to do for these conflicting jobs?

Comments 13 CommentsJump to latest comment

Amruta Bhide's picture

Hello David,

can you try if excluding Dates from under Planning helps.
Please let us know what happens.

******************************************************************
*****************************************************************

Note : If we do not receive your reply within two business days, this post would be marked �assumed answered� and would be moved to �answered questions� pool.


Thanks.

David Patterson 2's picture

Are you asking me to not rely on the policy to resolve job conflicts and instead to manually enter exclusions in the job schedule to avoid conflicts? If so, what's the point of the conflict resolution in the policy?

The next conflict between jobs won't occur until 5/31/06 when both a monthly and a daily job would be scheduled to run. The next conflict between a monthly and a weekly job won't occur until 6/30/06. So, I will not be able to reply in two business days.

Overall, I am disappointed/concerned about the automatic scheduling in Backup Exec. The Daylight Saving Time change messed up the start time of all my jobs (I see this is a previously reported issue that still isn't resolved), and my scheduled jobs weren't scheduled for the right dates (e.g., daily job was scheduled to run next on 4/4 instead of 4/3, weekly job was scheduled to run next on 4/14 instead of 4/7) which perhaps relates to the issue reported in doc ID 282059 although that only reports an issue with monthly scheduling. Although I haven't been 100% satisfied with Computer Associates ARCserve either, it doesn't seem to have fundamental problems like I'm seeing in Backup Exec.

Shilpa pawar 2's picture

Hi,

Are you running BE v10.0 Rev 5484?

Try running repair database:
http://seer.support.veritas.com/docs/265180.htm

You may also upgrade to 10d. Refer:
http://seer.support.veritas.com/docs/279332.htm
http://support.veritas.com/docs/281044

NOTE : If we do not receive your reply within two business days, this post would be marked "assumed answered" and would be moved to "answered questions" pool.

David Patterson 2's picture

I am running 10d (Version 10.1 Rev. 5629, with installed updates Hotfix 9 and Hotfix 10).

I will review the information about repairing the database and try that.

David Patterson 2's picture

I ran the Repair Database function. I don't notice any changes in Backup Exec. Should I?

When I filter on "Scheduled jobs" in the Calendar view of Job Monitor, I only see three jobs: my weekly scheduled for 4/7, my daily scheduled for 4/10, and my monthly scheduled for 4/30. I won't be able to observe behavior for conflicts until I get to 5/31/06 when my daily and monthly jobs would both be scheduled.

I had hoped maybe the Repair Database would correct my job execution times. With the change to Daylight Saving Time, all three changed from 11:10pm to 10:10pm. According to Document ID 267203 (http://support.veritas.com/docs/267203), this was only supposed to "occur once until the scheduled job normalizes to accomodate daylight savings time," but my daily job continues to reschedule itself for 10:10 each night. Even after running the Repair Database, Job Monitor still shows the jobs scheduled for 10:10pm.

Gauri Ketkar's picture

Hi,

-You wont notice any changes after running repair database.

-In this situation we have to wait till 5/31/06 when daily and monthly jobs would both be scheduled and to check whether conflicts rules function in a correct manner.

-You can also run SGMON on 31st before backup starts.
http://www.seer.support.veritas.com/docs/190979.htm

-Also are the scheduled jobs running twice ?


Update us on the same and revert for any further Query
Hope this will help you


Thank you
Gauri

NOTE : If we do not receive your reply within two business days, this post would be marked "assumed answered" and would be moved to "answered questions" pool.

David Patterson 2's picture

I have some new information!

Besides normal daily database maintenance, the only job that has run since I last checked status was my weekly backup job on 4/7 at 11:10pm (recall from my first post that after the change to DST, it had been scheduled for 4/14 at 10:10pm, so I had to manually Edit Next Run in Job Monitor and set it for 4/7 at 11:10pm). When I check backup job status this morning, I found the following changes:
- all 3 of my jobs (daily, weekly, and monthly) now show a scheduled time of 11:10pm rather than 10:10pm!
- my monthly job, which had been scheduled for 4/30/06 10:10pm now shows as scheduled for 5/31/06 11:10pm!

To answer your question about scheduled jobs running twice: No, none of my scheduled jobs ever ran twice, contrary to what document ID 267203 led me to expect.

I don't understand what you mean by "Update us on the same and revert for any further Query." Would you please clarify?

I have not made any change to the monthly job in case there's something you can tell me to check. Should I go ahead and do an Edit Next Run to set it to 4/30/06 again, or is there something I can check before doing that?

shweta rege's picture

Hello,


- Did you run the sgmon?

- Could you paste the Sgmon here...



NOTE : If we do not receive your reply within two business days, this post would be marked assumed answered
and would be moved to answered questions pool.

*************************************************
************************************************

David Patterson 2's picture

I did not run SGMON yet. Per your earlier post, it would need to be run on 5/31/06 when there is actually a conflict between the monthly job and another job that the policy is supposed to resolve.

I have been meaning to follow up on this job issue, though, because of further problems, but just haven't had time.

I have noticed that every time my weekly job runs, the scheduled date for my monthly job keeps getting pushed out one month later. It is now scheduled to next run on 7/31/06. I had been right-clicking on the job in the Job Monitor Job List and selecting Edit Next Run, but since it keeps getting changed, this is not a good solution.

If the basic grandfather-father-son policy can't be made to work properly, I think I will just manually set up three different jobs and manually create schedules for them that don't conflict.

Are other users having problems with policy-based jobs? Are there any updates planned that will address these issues?

Please describe in detail what action would you like me to take in regards to this issue since the monthly job is currently not scheduled to run until 7/31/06.

David Patterson 2's picture

I didn't hear back from anybody by 5/31/06, so I took a chance and did the following:

- On 5/31/06 at 4:30pm, in Job Monitor, I right-clicked the monthly job that showed as scheduled for 7/31/06 11:10pm (see my other post about how that date keeps changing) and clicked "Edit next run." I changed the schedule for that job to 5/31/06 11:10pm.
- The Job Monitor calendar now showed both the daily and monthly jobs scheduled to run on 5/31/06.
- I started SGMON, checking all of the boxes, and left it running
- on 6/1/06, I stopped SGMON & checked job status: Backup Exec seems to have correctly run the monthly job instead of the daily job and even rescheduled the monthly job for 6/30/06 which should be the next monthly job run date! I do see an entry in Active Alerts showing that the daily job was cancelled because it exceeded the maximum configured runtime, but perhaps this is the normal way the Backup Exec policies handle job conflicts as I don't see anything indicating that the daily job actually attempted to run.
- I could post the SGMON log file here, but I will not do so, unless you specifically request it, for two reasons: 1) The policy seemed to handle the daily vs. monthly job conflict correctly, and 2) the log file is 2.7MB, so it's going to be REALLY long if I post it here!

Going back to my original post, then, it seems that the problem is between weekly and monthly jobs, which will next conflict on 6/30/06. Also, as I've noted in a previous post, when my weekly job runs it seems to change the scheduled date of the monthly job. I'll see what happens when tonight's weekly job runs, if it changes the scheduled date of my monthly job (currently 6/30/06) to 7/31/06 or some even later date.

Is there any action I should take to help resolve the weekly/monthly issue? Should I run SGMON during a weekly job? Would that give any indication why the weekly job run is changing the monthly job schedule date? If I run SGMON again, are there any boxes I can leave unchecked that will reduce the log size but still provide sufficient information to troubleshoot the problem?

shweta rege's picture

Hello,



--- Did you try recreating the policies?


NOTE : If we do not receive your reply within two business days, this post would be marked assumed answered
and would be moved to answered questions pool.

*************************************************
**********************************************

David Patterson 2's picture

I have not yet tried recreating the policy. I will try that and post the results here.

Gauri Ketkar's picture

Hi,

Please do give update if recreating policies help..



Thank you
Gauri