Video Screencast Help

Confused with SWV registry management

Created: 04 Jun 2013 | 8 comments

SO: Windows 7 x86

SWV version: 6.1 SP7 MP2 (6.4.1550.0)

Hello everyone,

I have a problem with SWV and registry entries manually added. I have been doing some tests with this.

Test 1.- I load the fslreg1 at registry (REG LOAD) and add entries with REG ADD command. When the layer is activated and I query the values (REG QUERY or regedit.exe) this entries have the error "The system cannot find the file specified".

Test 2.- I add the registry entries when SWV is capturing a layer (for example, capturing cmd.exe and use REG ADD command). When the layer is activated I can query the values (REG QUERY or regedit.exe) with no error, but the application installed can't see this.

At both tests when I open the layer GUI editor on SWV and close the window (doing nothing) the registry is repaired and in test 1 I can query the values and test 2 the application can see the registry values and use it.

My questions are:

- How SWV manage the registry entries?

- How SWV repair the registry automatically?

- How can I add registry entries with no errors?

Thanks for the help! 

Operating Systems:

Comments 8 CommentsJump to latest comment

EdT's picture

Please specify the exact registry keys involved as this may have a bearing on the answer(s)

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

z0beat's picture

Any key under HKLM gives this issues (tested creating empty layer and applying the post tests) but the keys under HKU are working properly.

I detected this issue capturing Google Chromes Bussiness edition and trying to modify the registry to add extensions. (http://support.google.com/chrome/a/bin/answer.py?hl=es&answer=188453&topic=2936229&ctx=topic)

When I import a .reg file when SWV is capturing Chrome [I install it with a .bat with two lines, install and import .reg] (test 2), the registry is correct but Chrome doesn't see the keys.

AngelD's picture

I've never seen that problem

how exactly are you adding the registry; launching regedit, reg.exe or import .reg file?

and what tool; admin tool, composer?

EdT's picture

Software virtualisation does not get around the security of NTFS, so you need to check permissions on the keys in HKLM to make sure their permissions are appropriate for the ultimate user. Chrome user settings should be in HKCU as Chrome should update correctly even for locked down users.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

z0beat's picture

I tried to look at the permissions with subinacl and shows me the same before and after SVSAdmin fix the registry. Also I'm testing with the Administrator user is who creates the layer. If I capture the added keys with SWV the permissions are the same that the application default keys?

For Chrome Bussiness edition I need add keys at HKLM because the application search at HKLM\Software\Google\Chrome\Extensions information to install extensions.

Thank you for the reply

AngelD's picture

hmm I should have read a bit more as you state what I questioned, oops

However; why are you loading the reg-hive from the layer?
Test 1.- I load the fslreg1 at registry

If you want to add something after you finished the capture then activate the layer and modify the registry in the RO sub-layer or just add it through the admin tool.

If you run ex. regedit from cmd.exe during capture then the changes should stick to the RO sub-layer.

 

z0beat's picture

Thanks for the advice.

I activated the layer and I modified the registry at RO sub-layer. When I activate layer and navigate with regedit.exe this is the result https://www.dropbox.com/s/k7ubpuw3vyrcj95/example.PNG.

The traduction is:

Can't open Chrome
An error prevents opening the key
Details: System can't open the specified file

That's the same problem described when I load fslreg1 to add keys. Tests has been made with reg.exe and regedit with the same result.

Thank you for the reply

AngelD's picture

Is this a terminal server or citrix environment?