Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

connecting client from old master to new master

Created: 15 Dec 2012 • Updated: 16 Dec 2012 | 4 comments
This issue has been solved. See solution.

Hello. Setting up a new Master server with multiple media servers. Created my first SLP, threw an error, so per Symantec, I took SLP out of the equation and tried pointing a regular policy towads the media server storage unit that it should go to. Still, no go, status 24.

The client is Red Hat 6.2, and has been successfully backing up to another Master running 7.0 (windows server 2003) with no issues. For this client, I edited the bp.conf file to point to the new Master, and edited the iptables to allow both Master / Media server access to the 13724 / 1556 ports, and restarted the service. Also, I disabled the policy for this client in old Master.

On both Master / Media servers (both running Win server 2008 Enterprise - both firewalls are turned off).

I can connect to the client from the Master admin console under 'Host Propterties' -> 'Clients'.

But when I kick off manual backup of this client for initial test, I am getting errors:

status 59 - access to the client was not allowed.

:54:40 PM - Info nbjm(pid=3632) starting backup job (jobid=21) for client myclient.edu, policy flfs1-noslp, schedule Full  
12/15/2012 5:54:40 PM - Info nbjm(pid=3632) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=21, request id:{D90518B5-10AC-4A16-ACD6-FA1B848CD31E})  
12/15/2012 5:54:40 PM - requesting resource myclientsu1
12/15/2012 5:54:40 PM - requesting resource nbflmaster.NBU_CLIENT.MAXJOBS.myclient.edu
12/15/2012 5:54:40 PM - requesting resource nbflmaster.NBU_POLICY.MAXJOBS.myclient-noslp
12/15/2012 5:54:41 PM - granted resource nbflmaster.NBU_CLIENT.MAXJOBS.myclient.edu
12/15/2012 5:54:41 PM - granted resource nbflmaster.NBU_POLICY.MAXJOBS.flfs1-noslp
12/15/2012 5:54:41 PM - granted resource MediaID=@aaaan;DiskVolume=PureDiskVolume;DiskPool=flintdp1;Path=PureDiskVolume;StorageServer=myclientmedia;MediaServer=myclientmedia
12/15/2012 5:54:41 PM - granted resource myclientsu1
12/15/2012 5:54:41 PM - estimated 0 Kbytes needed
12/15/2012 5:54:41 PM - Info nbjm(pid=3632) started backup (backupid=myclient.edu_1355622881) job for client myclient.edu, policy flfs1-noslp, schedule Full on storage unit myclientsu1
12/15/2012 5:54:42 PM - started process bpbrm (2832)
12/15/2012 5:54:43 PM - end writing
12/15/2012 5:55:15 PM - Error bpbrm(pid=2832) bpcd on myclient.edu exited with status 59: access to the client was not allowed
access to the client was not allowed(59)

____________

Am I overlooking something? Any help is appreciated.

Discussion Filed Under:

Comments 4 CommentsJump to latest comment

revaroo's picture

Check the bpcd log on the client for the error. Check the ip address and double check what hostname that ip resolves to on the client, then add it into the bp.conf as a SERVER entry.

revaroo's picture

That's check the inbound ip address in the bpcd log. Log can be created by creating the directory /usr/openv/netbackup/logs/bpcd/

You'll need to either re-run the backup or run: bptestbpcd -client -verbose from the media server that is configured with the storage unit to get the newly created bpcd directory to log.

RLeon's picture

I edited the bp.conf file to point to the new Master

You should add the media servers too.
In the client's bp.conf:

SERVER = Master (replace with your own real host names of course)
SERVER = MediaServer1
SERVER = MediaServer2
SERVER = MediaServer3
SERVER = MediaServer4

...and so on.

Also:
1. The space to the left and right to the "=" matters.
2. Upper and lower case matters.
3. A short hostname and a FQDN of the same host are (by default) treated as different clients by NetBackup. If possible, try troubleshooting with every possible setting using the short name (upper/lower case still matters).
4. Make sure both forward and reverse DNS lookups can be resolved from all directions between all combinations of master * media * client paths.

Edit:
As an alternative to point 3, you could also try the following to include and test all possible combinations in the client's bp.conf:
SERVER = Master
SERVER = Master.yourdomain.com
SERVER = MediaServer1
SERVER = MediaServer1.yourdomain.com
SERVER = MediaServer2
SERVER = MediaServer2.yourdomain.com
SERVER = MediaServer3
SERVER = MediaServer3.yourdomain.com
SERVER = MediaServer4
SERVER = MediaServer4.yourdomain.com
 

SOLUTION
Marianne's picture

Setting up a new Master server with multiple media servers...  I edited the bp.conf file to point to the new Master....   I can connect to the client from the Master......

You did good - Connectivity from Master to Client is workin fine.

Now you need to test and fix connectivity from all media servers to client.
Check hosts entries on client, check bp.conf entries for media servers as pointed out above. 

Ensure bpcd log folder exists on client under /usr/openv/netbackup/logs.
This log will show you IP address of media server trying to connect, then how client is resolving IP to hostname and then comparing hostname with SERVER entries.

If client cannot resolve media server's IP address that appears in SERVER list, you will see status 59.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links