Video Screencast Help

Connection error while connecting to SEP 12 embedded Database using powershell

Created: 10 Jan 2013 • Updated: 10 Jan 2013 | 7 comments

 

Hello,

I am trying to pull a report connecting to embedded databases of several SEPMs. This worked fine with SEPM 11. The issue started once we upgraded to SEPM 12. I am able to to connect using odbc to all the embedded databases and run the query..no issues even after upgrading. The issue is when trying to connect using powershell script.

 I am getting this error

      Exception calling "Open" with "0" argument(s): "The 'ASAProv.90' provider is not registered on the local machine."

    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : DotNetMethodException
 
Following is the way I am trying to connect:
 
$conn = New-Object System.Data.OleDb.OleDbConnection("Provider=ASAProv.90;Data Source=SymantecEndpointSecurityDSN;User
Id=DBA;Password=*************");
$ds = New-Object "System.Data.DataSet" "SEMData"
$query = ***************
$da = New-Object System.Data.OleDb.OleDbDataAdapter($query,$conn);
#$dc = New-Object System.Data.OleDb.OleDbDataAdapter($count,$conn);
$conn.Open();

Do anyone has the same issue? I read a post with the same issue, but that is not helping.

If anyone can point me to the right direction, that would be helpful. Thanks in advance.

Comments 7 CommentsJump to latest comment

pete_4u2002's picture

i assume the script uses asa version 9, with SEPM 12. the asa version is 11, hence you may need to change it accordingly.

HalloKota's picture

 

Hi Pete, Thanks for your reply.

 

For you first post, Can you please let me know the syntax for asa version 11 like ASAProv.90?

and for you second post, I am not using any dbsrv in my script.

Ambesh_444's picture

Hi,

Please check with this.

https://www-secure.symantec.com/connect/forums/pow...

https://www-secure.symantec.com/connect/forums/pow...

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."