Video Screencast Help

Connection timed out with GhostCode 19945

Created: 25 Oct 2013 | 19 comments

I am running into the above error.

I am using GhostCast Server version, running on Win Server 2003.

Previously, this GhostCast server has not given me any problems, but lately I am seeing this error with various clients.

The only difference is recent Windows updates to the server (our IT department is big on those), otherwise no changes to the server.

I used to have no problems even going through several switches/routers our IT department has in place.

To eliminate these switches/routers from the equation, I configured a second NIC in the server, and have plugged my server and client either into a simple switch (Netgear GS108), or directly connected the client to the server NIC.

I have seen timeouts on Dell Latitude E6420 laptops, Dell 7010 desktops, and old Dell Dimension 5400 desktops.

I am using either a NetBoot, PC DOS 8.0 boot disk, or a Win PE 512 boot disk created by the Ghost Boot wizard, both show the same error.

I switched to using the Win PE after reading that PC DOS might not be able to handle the size of disk in these systems.

Attached is a sample of the error file.

I would appreciate any suggestions.

Operating Systems:

Comments 19 CommentsJump to latest comment

EdT's picture

If I recall correctly, Ghost cannot handle multiple NICs in the server. Go back to one NIC.

If you are multicasting, you need to have IGMP snooping enabled on the switches otherwise you will get timeout errors after typically 4-5 minutes.

You could of course create a current restore point on the server, then take it back to an earlier restore point before all the updates were installed, and see if that restores correct operation. If it does, you can then reinstall updates one by one until the culprit is identified and thereafter ensure it is not installed.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dpak D's picture

Below is the check list for 19945 error,

=>Check for enough space on the location where the image is stored

=>If the image is stored on a network drive,try the local drive on the server as storage

=>Update NIC drivers for WINPE

=>Run chkdsk /F on the client and then try to image.

CISR Admin's picture

EdT, Maneesh, thanks for your replies

EdT, do you have a reference for the 'cannot handle multiple NICs' statement?

It would seem to me that the client wouldn't even be able to connect, but my client can connect, transfer some amount of data then timeout.

For now I am using unicast, to create an image, so I don't think IGMP is the problem, but eventually I'll need to restore the image to 25 laptops, 6+ at a time. If my switch is not IGMP capable will the multicasting fail?

It is my understanding that it will not, but the multicast will not be directed at specific switch ports, so all will get the traffic, is this understanding correct?

I will consider the 'rollback updates approach' after all other avenues have been tried.

Maneesh, I checked everything you mentioned. It is a local disk, I tried 2 different ones, each with plenty of empty space. Does the server need 'temp' space on the 'C:' drive? My 'C:' drive only has about 8 GB free.

The WinPE boot disk has the latest NIC driver, see my post ''.

I also ran chkdsk on both the client and the server just for good measure.

Will my choice of compression 'no / fast / high' have any effect on this timeout? I have tried all 3, all timeout after varying amounts of time.

Attached are two more error files, do these help at all?

Thanks for your help.

GHOSTERR_10_31_2.txt 26.13 KB
GHOSTERR_10_31_4.txt 63.71 KB
EdT's picture

>EdT, do you have a reference for the 'cannot handle multiple NICs' statement?

Just enter "multiple nic" in the search engine at the top of this forum and you can read about the various problems users have experienced with multiple NIC cards and links to some workarounds.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dpak D's picture

Looks like its failing randomly.Try the following,

=> On Ghost Cast Server,navigate to File ->Options->Set throughput limit to 400 or 500 MB/Min to maintain a steady connection throughout the image creation process.Else Ghost would try to use the maximum available bandwidth which cannot be steady and that coudl blow away the session.

If this doesn't work,with the throughput setting 500MB,do the following on the client side 

=>Boot the machine and when Ghost32 launches ,Quit from ghost32,to enter command prompt

=>Navigate to X:\Ghost and run ghost32 -split=0 to create single image file without splits.Sometimes connection might reset while creating the span file.

CISR Admin's picture

EdT, I disabled and disconnected one of the NICs in the server. I am still getting the same results.

I have been trying this with Dell Latitude E6420 laptops, I also just tried it with a Dell Dimension 7010 desktop. Both are giving me the timeout error.

Curiously, both have Intel 82579LM NICs. Could this be the real problem?

My server is Win 2003 Server with an Intel Pro/1000 MT Dual port NIC. Could this be the problem? A search of the forum didn't bring up ant timeout related posts for the 1000 MT.

Thanks for any help you can provide.

EdT's picture

The Intel 82579 chipset creates more problems for Ghost users than all others put together. I recommend you enter 82579 into the search engine on this forum and check the various postings with links to known good Vista 32 bit drivers for this chipset, which have been tested with WinPE V2.  Not all drivers for this chipset work with WinPE, so getting the right ones is the key to getting everything working well.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dpak D's picture

If you have imaged machines successfully in the past lets not concentrate on the NICs on the server and focus only on the clients,by updating the WINPE drivers.Before that ,try the above mentioned steps.Throughput reduction and -splut=0

CISR Admin's picture


I think the throughput reduction may have solved the problem.

I am currently running a create operation, using a 10/100 MB switch, so I set the server to limit to 80MB.

So far it has been running for ~50 minutes, and is just over 50% complete.

Next I plan to use a Gig switch with a limit of 500 MB.

Thanks for the suggestion.

CISR Admin's picture


One test was successful, limit of 80 Mb, with a 10/100 switch.

Since I have tried a 1 Gig switch, with limits of 500, 400, 300, 200 Mb without success.

Currently a create session is running with a limit of 100 Mb, is proceeding after 1 hour plus, and seems likely to complete.

I haven't tried the split=0 option as most timeouts occur quickly with the split nowhere close to happening.

How can I gather more info on the cause of the timeout?

Would a packet capture provide any clues?

What would I look for?

EdT's picture

Have you tried a different driver for the 82579 ?  Your problem could be caused by something like buffer overflow in the NIC at the higher speeds, and my personal feeling would not be to ignore the NIC driver in the knowledge that this chipset has been so troublesome to many ghost users.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

CISR Admin's picture

EdT, I understand your concern about the NIC driver.

I am using the E1C\VISTA-x86 driver Maneesh described in this post:

I could also try with the Win32/NDIS61 that I found allowed the laptop to boot, but I don't recall if I have actually tried it to create/restore an image.

Do you have a suggestion for another, possibly more up-to-date, driver?

CISR Admin's picture

Today I was able to restore 1 laptop with the GC server set to a max of 500 MB/min.

I am now in the process of restoring 6 laptops concurrently with the same max of 500 MB/min. I noticed that all 6 hung/paused at about 17 mins 45 seconds, then all 6 resumed. This hang/pause was repeated at 21:49, then all 6 resumed.

Any ideas on the cause of the pause?

Dpak D's picture

The 19945 issue should be with image creation most of the times and the image restore should not be a problem(alteast thats what I have seen).Create a shared folder on the ghost server and map to the share using net use command under WINPE.Store the image directly under the share instead of using Ghost Cast Server to workaround this issue.While restoring you could use Ghost Cast Server ,

=>Use the existing boot media and boot to WINPE

=>Quit GHost32 when it launches and navigate to X:\Ghost under command

=>Run net use command to map the drive

Syntax: net use driveletter: \\ServerName\ShareName /user:Domain\User Password 

Replace all in bold with appropriate values

=>Launch ghost32 again and Choose Local->Disk->To Image and store the image under network share

Tim T.'s picture

Maneesh, your last comment looks quite interesting as I am having practically the exact same issue as CISR Admin with one notable exception. I am trying to use the Ghost Console and not Ghost Cast Server directly.

do you have any thoughts regarding this issue from the console?

Tim T.'s picture

Maneesh, I am getting the identical error. The only difference is that I am using Ghost Console. Your last suggestion, how might I apply it?

EdT's picture

Have you entered 19945 into the forum search engine at the top and checked whether any of the past postings contain any solutions that might work for you?

In general it is also useful to include a detailed description of your Ghost environment and target machine hardware and software.  Please also confirm your version of Ghost.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Dpak D's picture


Sorry about the delay.If you are using Console ,check whether there is enough space on the destination ,where you save the image.If yes, go to the network tab of the image creation task and set throughput value for creation to 400 MB/Min or a value which would be ideal for your network speed.