Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Converting indexes to 64bit and vault server performance

Created: 30 Dec 2013 • Updated: 25 Feb 2014 | 3 comments
This issue has been solved. See solution.

Hi All,

 

I upgraded our vault server to 10.x earlier in the year, and have been slowly converting indexes to 64bit over the year. Slowly because it strongly impacts the performance of vault while its performing the conversion, and so I have had to tiptoe around it. When a conversion is running, recalling archived messages slows to a crawl (and sometimes stops responding or times out). Is there anything I can do to help alleviate this? If I dump more mem/cpu resources on it would that help? Is it possible to run this at a time of day outside of business hours?

I have also noticed that when I kick off a conversion, it will only run during certain hours of the day (seems to be 10am to 4pm) is that controlled by a setting somewhere(I couldnt find it)?

My primary concern is when it comes to converting the journal archive. The others have not been too bad, but I can tell that one will be massive and take quite a while.

 

 

Operating Systems:

Comments 3 CommentsJump to latest comment

TonySterling's picture

How much RAM and CPU do you have?  The more the merrier when it comes to RAM for Indexing.

You can check this for the schedule:

Why would an indexing task not run?

Article:HOWTO56282  |  Created: 2011-07-27  |  Updated: 2011-07-31  |  Article URL http://www.symantec.com/docs/HOWTO56282

 

SOLUTION
GertjanA's picture

Hello Nate.

There should be an indexing administration task, which you can change the schedule on.

I also experienced the performance hit. Especially because the old indexes are medium, and the new will be full. I am gradually doing it based on lastname (starts with A, B etc.) I also 'tweaked' the number of concurrent processes. If you go to the properties of the EV-server (in the left pane of the VAC, rightclick EV-server, properties), go to tab Advanced.

There you see 'Maximum concurrent indexing capacity'. I have set that to 5 on the EV-servers I have for now. I believe the default is 30. When converting is done, I will change this back, so functionality is being restored to the max. My servers have 32GB RAM, and 16 cores, and having this setting, they run at approximately 70% of their capacity. I have the task scheduled to run from 07:00 to 17:00, so I can monitor.

I also changed the TMP/TEMP location for the VSA account. This seemed to have helped also a little.

In addition to that, when I start converting a new set of indexes, I first run a query, which gives the number of items in the index of a user. (attached). I first do the small ones (up to 10000 items), then let the large ones run. The extremely large ones (>500.000 items) I do over the weekend.

We do not allow manual archiving anymore, the archiving schedule is now from 20:00 to 00:00, which is enough. I love the new archiving reports!.

I hope this helps you.

AttachmentSize
IndexQuery.txt 315 bytes

Thank you, Gertjan, MCSE, MCITP,MCTS, SCS, STS
Company: www.t2.nl

www.quadrotech-it.com

www.symantec.com/vision

Nate.D's picture

Hey all, this is a bit of a late response to this but I should be able to resolve it here soon:

I was able to get this finished, but it it completed with status "Warnings"

 

2715 items with errors

6487 items missing content

 

Will that throw an error? I looked through the log and didnt see anything else jumping out at me, I guess I am not sure what I am looking at/for.

 

Any thoughts on that?

 

Thank you!

If I was helpful in solving your issue please mark my post with a thumbs up or a solution!  Have a great day :)