Video Screencast Help

Corrupted names on Solaris 10 x86

Created: 31 Oct 2011 • Updated: 01 Dec 2011 | 16 comments
This issue has been solved. See solution.

While waiting ridiculously for my technical support status to be actually able to make a case, I might as well ask here.

Media server / Agent: BE2010 R3 (all possible hotfixes applied)

Server I'm trying to back up: Solaris 10 x86 on HP Blade

I can browse resource ok, everything looks good.

When trying to RESTORE, everything looks garbled - see image. (Directories bott, hmee etc obviously don't exist)

My Solaris 10 Sparc servers work fine, they have pretty much identical ZFS and zone setups etc, it seems there is some silly bug on x86. There are no special characters or long names or such that I can find, I've already read all those bug descriptions.

Comments 16 CommentsJump to latest comment

AmolB's picture

Do you see the same list of directories in the backup selection list ?

HenrikK's picture

As said I can browse resources ok. Backup selection list looks fine.

VJware's picture

Two common reasons found out for this issue is when the remote server OS is not supported/listed in the SCL, or the remote agent is not updated & at the same level of the BE media server...

pkh's picture

Did you patch the RALUS with all the hotfixes?  See my blog below

https://www-secure.symantec.com/connect/blogs/how-...

HenrikK's picture

There are no hotfixes that apply to Solaris over the standard BE2010 R3 agent. There are only some Linux/Mac fixes.

To answer the other reply, server and agent are as new as they can get and same level. Solaris 10 x86-64 is SCL, this is not like Linux where you have different distributions, Solaris is Solaris.

HenrikK's picture

I'm pretty sure it's the agent code that is bugging. I debugged it while it's running and it really does try to read directories like "/hmee" which obviously doesn't exist. I can't make a case yet since I don't have my support status..

pkh's picture

If you see any RALUS patches in the Agents directory you should apply them so that the RALUS is the same version as the media server.  This is regardless of which Unix/Linux variant that you are using.

HenrikK's picture

I don't think you've ever tried to install Solaris-patches yourself. It does not work if there is nothing to install.

./installraluspatch.sh: ./SunOSx86: does not exist

VJware's picture

Btw, ZFS filesystem is not completely supported...Does this restore selection issue occur with any other Solaris clients (non ZFS) ?

HenrikK's picture

Unfortunately I don't have any non-ZFS servers to test and this is the only x86 server right now.

It's pretty sad that Symantec still can't "officially" support a 5-year old filesystem that has been pretty much standard on Solaris-servers for years. Anyway, browsing through all those old ralus bugs means the cause could be pretty much anything. I tried installing R2 agent for fun, but same bug there. I don't know enough internals to rule out the media server itself either.

HenrikK's picture

For the record.. this was fixed with the following hotfix:

http://www.symantec.com/docs/TECH168893

Unfortunately LiveUpdate didn't show the hotfix and sadly I didn't find it by googling. It took quite a while for support to find it also..

SOLUTION
714691's picture

There is the same issue here with Ubuntu 10.2 ! The link to the solution is down.

AmolB's picture

I am able to access the link. Run live update twice, 1st install SP1 for R3 and then

the other updates which includes the above Hotfix too.

Note: Ubuntu 10.2 is not compatible with Backup Exec

714691's picture

i am not able to access the link. The following Hotfixes are installed

SP1

Hotfix 167567

Hotfix 171073

Hotfix 164659

Hotfix 170962

Hotfix 172625

Hotfix 167791

There are no more updates from live update

Is TECH168893 included in the list above?

If not can you send me the Hotfix via email?

 

AmolB's picture

What version of Backup Exec you are using, this hotfix is for BE2010 R3.

If its R3 then let me know if the server is 32bit or 64 bit

714691's picture

Now i am able to access the link. The Hotfix solved the problem.

Thank you