Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

could not find the boot drive(in to virtual partition)

Created: 19 Dec 2012 • Updated: 17 Jan 2013 | 7 comments
This issue has been solved. See solution.

Hello,

I'm trying to pull an image of a HP6300 with Intel 82579LM gigabit adapter. Windows7 enterprise installed. I changed AHCI into IDE before installing.When trying to pull an image with Ghost Console (GSS 11.5.1.2266) an error occurs: to virtual partition could not find the boot drive. Last year I imaged the HP6200(same Intel 82579) with universal driver because of not succeeding in WINPE.

I can get an image with ghostcast, no problem. But restoring the image again with Ghost Console, it failes with same error as described. For reasons of managing great amount of pc's I need the console.

What am I doing wrong in the console?

Comments 7 CommentsJump to latest comment

bertK's picture

Even with W7 enterprise installed on HP6300 with AHCI enabled fails. Added from this site the 82579 driver and even found on the Intel site the vista storage driver 11.0.0.1032. Added them in WinPE. Still fails with same error: Details for: to virtual partition, Could not find the boot device.

I hope someone can opoint out a solution,

thanks,

EdT's picture

The error you are reporting points directly to an inability to "see" the hard disk.

Forget DOS - there are limitations other than just the inability to read SATA devices.

If using WinPE from GSS 2.5.1 build 2266, you need Vista 32 bit drivers for both the NIC and SATA devices.

Check out this article for a method of validating the drivers are compatible with your version of WinPE:

https://www-secure.symantec.com/connect/articles/d...

From the WinPE command prompt you should be able to see the entire volume of each hard disk you need to image.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bertK's picture

Hello EdT,

Back on my work again;)

I have read the article. I have a bootable usb with unidriver from the winpe package. These settings work with ghostcast!

Why is it impossible to image by using Ghostconsole with winpe and unidriver selected?

EdT's picture

You would need to speak with Support about that - it may well be that one of the four patches released after build 2266 has some bearing on your particular hardware.

Information about the patches and how to contact support (if you have a support agreement) are in a sticky posting at the top of this forum.

(This assumes that you have tried using the boot.wim from your bootable USB in the Ghost Console to provide your boot environment)

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bertK's picture

Hello EdT

I have tried as the article described: testing the driver in Winpe. The intel driver 82579LM from this site was indeed a correct driver. An ip addres was assigned and after startin ghost by using x:\ghost32\ghost32.exe the ghostcast session showed the drive! and an image could be created with winpe.

Then I added again this driver in the console- as described in one of the articles that can be found on this site- but still the same error with gostconsole; to virtual partition: could not find the boot drive.

I don't understand the boot.wim.

thanks for helping,

EdT's picture

OK, when you add a driver to Ghost Console, have you made sure you have SELECTED it before recompiling the boot image?

I wrote an article (https://www-secure.symantec.com/connect/articles/r...) about building your own WinPE boot environments to help familiarise users with how WinPE works and how it is put together.

Think of WinPE as being a cut down version of Windows that provides a command line interface only, and which runs from a RAMDRIVE created as the X: drive (by default). The boot.wim file is a compressed archive that is loaded into the ramdrive and then run as the WinPE kernel.  If you look into the WinPE documentation, you will find reference to an imaging utility called imagex.exe which is similar to Ghost in the way it works, but creates WIM files instead of GHO files.  WIM files can be mounted, and if mounted in read/write mode, can be edited and then committed as a modified image file.

Ghost boot wizard basically automates this for you.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bertK's picture

Found a solution by contacting support,

Ghost is unable to image with EFI booot resources enabled. (Efi or UEFI)

Succeeded in pulling and restoring images by choosing legacy boot resources. In the bios of this HP6300 EFI boot resources can be disbled. Then installed W7 enterprise. The 100MB partition must be deleted, still stays visible as unallocated partition in diskmanagement.

thanks

SOLUTION