Video Screencast Help

Create HPUX SRT

Created: 31 Jan 2012 • Updated: 02 Feb 2012 | 7 comments
ShahbazW's picture
This issue has been solved. See solution.

Hi Everyone,

I am getting errors installing the NBU client on the SRT for HP UX. Please find below the procedure followed:

# ./bmrsrtadm

Select one of the following options:

    1.  Create a new Shared Resource Tree.
    2.  Create a new CD image based Shared Resource Tree.
    3.  Copy an existing Shared Resource Tree to a new location.
    4.  Import a Shared Resource Tree.
    5.  Modify an existing Shared Resource Tree.
    6.  Delete an existing Shared Resource Tree.
    7.  List Shared Resource Trees available on this server.
    8.  Quit.

Enter your selection (1-8) [1] :
Enter the name of the SRT to create : HPUXSRT
Enter the description of the new SRT : HPUXSRT
SRT OS level (11.31) [11.31] :
Enter the directory in which to place the new SRT [/export/srt] : /opt/srt
Enter the location (device or directory path) of the HP-UX install media that contains Ignite.
Location  [/dev/dsk/c4t0d0] : /cdrom
Executing commands to establish an HP-UX 11.31 SRT.
Completed.
Enter the location (device or directory path) of the HP-UX 11.31 install media.
Location  [/dev/dsk/c4t0d0] : /cdrom
Installing OS-Core.CORE-SHLIBS...
Installing Streams.STREAMS-MIN...
Installing OS-Core.UX-CORE...
Installing OS-Core.CMDS-MIN...
Installing OS-Core.CMDS-AUX...
Installing OS-Core.KERN-RUN...
Installing SW-DIST.GZIP...
Installing SW-DIST.SD-CMDS...
Installing SW-DIST.SD-AGENT...
Installing SystemAdmin.OBAM-RUN...
Installing DCE-Core.DCE-CORE-SHLIB...
Installing LVM.LVM-RUN...
Installing NFS.NFS-SHLIBS...
Installing JFS.VXFS-BASE-RUN...
Installing NFS.NFS-64SLIB...
Installing OS-Core.CORE-64SLIB...
Installing OS-Core.CMDS-MN-64SLIB...
Installing OS-Core.CMDS-AX-64SLIB...
Installing OS-Core.KERN2-RUN...
Installing Streams.STREAMS-64SLIB...
Installing COMPLIBS.LIBIO77-IS64...
Installing DCE-Core.DCE-IA64-SHLIB...
Installing OS-Core.SYS2-ADMIN...
Installing OS-Core.CORE2-SHLIBS...
Installing OS-Core.CORE2-64SLIB...
Installing OS-Core.UX2-CORE...
Installing OS-Core.CMDS2-MIN...
Installing OS-Core.CMDS2-AUX...
Installing SW-DIST.GZIP2...
Installing SW-DIST.SD2-CMDS...
Installing SW-DIST.SD2-AGENT...
Installing SystemAdmin.OBAM-RUN-IA...

Completed.
Preparing boot files - please stand by...
Location (device or path) of the Symantec NetBackup install media [/dev/dsk/c4t0d0] : /u01/NBU7.1/NetBackup_7.1_CLIENTS/
Failed to setup pre-requisites for swlist in the srt.
Do you want to retry install of Symantec NetBackup Client? (y/n) [y] :
Location (device or path) of the Symantec NetBackup install media [/dev/dsk/c4t0d0] : /u01/NBU7.1/NetBackup_7.1_CLIENTS
mount: /u01/NBU7.1/NetBackup_7.1_CLIENTS is already mounted on /opt/srt/HPUXSRT/mnt
Do you want to retry install of Symantec NetBackup Client? (y/n) [y] :
 

Comments 7 CommentsJump to latest comment

Marianne's picture

Have you verified that the Client software was correctly joined and extracted using gtar?

See :

Extraction or installation errors from downloaded NetBackup 7.1 software extracted using Solaris, Linux, HP-UX and AIX servers.

 http://www.symantec.com/docs/TECH154080

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

ShahbazW's picture

Hi Marianne,

I installed the client from this same extracted tar and it installed correctly. I used the new GNU tar to extract everything.

Additionally, I found out that uname -a was reporting one character less in the hostname since HPUX has a 8 character limit.

I added the same name withone digit less to the hosts file and the installation of client on SRT started but failed later. I then thought that maybe its the name which is causing the issue.

I then changed the system parameters to allow the name to be of 9 characters. Still getting the same issue.

vxlogview -i 125 shows the same error in both cases:

02/01/12 15:00:17.795 [srtPlat.cpp:PrepareSwlistRequisites()] Failed to figure out hostName ip-address of this host.

mph999's picture

Hmm, I recall an issue with HP hostnames and BMR ...   see what I can find ...

 

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
ShahbazW's picture

Since the name has changed, the backups are partially successful. :S

ShahbazW's picture

how do I delete the entry in the EMM database and re-add the client?

mph999's picture

Delete exactly what in the EMM database ?

To readd a client, just delete it from the policy  and readd it into th epolicy with the new name ...

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
ShahbazW's picture

Figured it out. Went back to the old settings (changed kernel parameters back to normal - disable long names support on OS).

NBU started communicating and client backups were sucessfull. De-registered the client as boot server. Uninstalled the client/patch.

Changed node name to less than 8 characters. Re-installed NBU client/patch. Re-added client with new name. Backups successfull.

SOLUTION