Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Create Resource for SMP

Created: 06 Jun 2013 | 9 comments

I'm trying to create a resource in workflow using the create resource for smp component, but I keep getting the error "Exception has been thrown by the target of invocation".  I've tried unsuccessfully to create a few different resource type (computer, software purchase, or asset).  It is a simply workflow to demonstrate funcationality.  I'm setting the name and description of the resource.  I'm certain I have access to create the the resource.  Within the workflow I'm able to get resources and read their values which means I'm getting connected.

Any guidance or help would be appreciated.  If you can share an example workflow using Create Resource for SMP, I'd appreciate it.

Operating Systems:

Comments 9 CommentsJump to latest comment

b3tts32's picture

I would like to know about this too, especially creating a computer. We're looking at prestaging computers during our procurement process and adding machines to filters. Ideally we'd pass the mac address, serial number, and a computer name to create the resource. I'll keep an eye on the thread.

reecardo's picture

Do you have a Create SMP Credentials component in the stream before the call to the Create Resource component?

EathenR's picture

Yes, the first action is Create SMP Credentials.  I've successfully used the Get and Delete Resource for SMP.

reecardo's picture

Sometimes a certain DataClass is required to be created (and associated) with the resource before it can be created in the SMP... that may be the issue. Unfortunately, none of the resource components can detect and enforce such dependencies.

If possible, I'd check the Altiris Log on the SMP to see if the NSWebService is throwing an error on this by any chance. If it doesn, it can possible point you in the right direction.

EathenR's picture

 Here is a snippet of the error.  I've tried TECH156568 which mentions granting the app pool access to the redirection.config without any luck.  I gave every app pool full access and went as far as giving everyone full control.

"6/7/2013 8:45:11 AM","Failed to create resource
**CEDUrlStart** :http://entced.symantec.com/entt?product=SMP&version=7.1.8400.0&language=en&module=Luc2Khi2xEnWaGMsAucOSphF79bx9eWnHHVePlriGQE=&error=-856670336&build=**CEDUrlEnd**

( Exception Details: Altiris.NS.Exceptions.AeXException: Failure in save for Resource item. [The type initializer for 'Svr' threw an exception.] ---> System.TypeInitializationException: The type initializer for 'Svr' threw an exception. ---> System.UnauthorizedAccessException: Filename: redirection.config
Error: Cannot read configuration file due to insufficient permissions

EathenR's picture

Sorry, I no longer see an error message in the SMP server logs, but I'm still receiving the Exception has been thrown by the target of invocation error in the workflow designer.

EathenR's picture

I switched the application pool identitify from ApplicationPoolIdentity to LocalSystem and it worked.  I don't think that is the proper solution.

toomas's picture

The detailed error is what will usually help you along. That "System.UnauthorizedAccessException" gave a pretty good idea about what is going on.

While Workflow does not require any specific account configuration, when you are running into authentication issues of any kind, you might want to follow the ServiceDesk way - having Application Pools and Workflow Service run with a service account. Especially when it comes to SMP connectivity, preferably the same one you have the SMP Connection Profile with (that should ideally be in Symantec Administrators in SMP).

EathenR's picture

Is there a doc on proper app pool setup for ServiceDesk which I can follow for workflow?  I have an idea on how it should be done and what you are suggesting, but I'd like to follow a doc (if possible).