Video Screencast Help

CSV Asset Import Error - [Field] not found: [Wnt.Machine.VMWAREVCENTERSERVERVERSION]

Created: 17 Jan 2013 • Updated: 17 Jan 2013 | 5 comments
TheMagician's picture
This issue has been solved. See solution.

Greetings,

 

This is my first post on the community and I really hope someone can help me quickly.

 

I am trying to import Windows assets from a CSV file using CCS 11.0.  I have created the CSV data location with the correct credentials, the correct format, etc, and it has work previously.  The only thing that has changed is the installation of PU 2012-1 and then SCU 2012-3.  There were also a few quickfixes (10005, 10006 and 10111) but these were applied before the PU and SCU and it worked.

I am blue in the face from googling and I am fairly sure that there is no information about this issue on the internet yet.

 

I cannot seem to find any other information about this error in the logs either.

 

Your urgent assistance is appreciated.

 

TheMagician

Comments 5 CommentsJump to latest comment

TheMagician's picture

After much scratching around, I found the following error in C:\ProgramData\Symantec.CSM\Logs\CCSManager\DPS.WorkerProcess.DATE.NUMBER.csv

***************************************************************************************************************

2013-01-17 09:27:36.020,2013-01-17 11:27:36.020,SERVER01,Warning,DispatchProtocol.Common,Blade.WorkerProcess,5544,,49,HandleError,,0,0,"FaultErrorHandler - Unhandled Exception: System.ServiceModel.CommunicationException: There was an error reading from the pipe: Unrecognized error 109 (0x6d). ---> System.IO.IOException: The write operation failed, see inner exception. ---> System.ServiceModel.CommunicationException: There was an error reading from the pipe: Unrecognized error 109 (0x6d). ---> System.IO.PipeException: There was an error reading from the pipe: Unrecognized error 109 (0x6d).
   at System.ServiceModel.Channels.PipeConnection.OnAsyncReadComplete(Boolean haveResult, Int32 error, Int32 numBytes)
   --- End of inner exception stack trace ---
   at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at System.ServiceModel.Channels.ConnectionStream.ReadAsyncResult.End(IAsyncResult result)
   at System.Net.FixedSizeReader.ReadCallback(IAsyncResult transportResult)
   --- End of inner exception stack trace ---
   at System.Net.Security.NegotiateStream.EndRead(IAsyncResult asyncResult)
   at System.ServiceModel.Channels.StreamConnection.EndRead()
   --- End of inner exception stack trace ---
   at System.Runtime.AsyncResult.End[TAsyncResult](IAsyncResult result)
   at System.ServiceModel.Channels.FramingDuplexSessionChannel.TryReceiveAsyncResult.End(IAsyncResult result, Message& message)
   at System.ServiceModel.Dispatcher.DuplexChannelBinder.EndTryReceive(IAsyncResult result, RequestContext& requestContext)
   at System.ServiceModel.Dispatcher.ErrorHandlingReceiver.EndTryReceive(IAsyncResult result, RequestContext& requestContext)"***************************************************************************************************************

The error that I have highlighted above seems to be a visual basic error but all the information I can find is very technical talking about VB Contract Providers, etc....

 

Hope this helps.

 

cmccoy2's picture

Are the Assets being imported into the system?  If the Assets show up in the system, then you will need to do an additional Asset Import job and use the "Network" as the source and then select all of the Windows Assets that you had created.     If that doesn't work, then you may want to scratch the CSV and use the LDAP as the source, point to your AD Domain controller and make sure you filter out workstation or any other machines that you don't want to be imported.   After you get the asset in, then you will need to do the additional Asset Import using the "Network" source because this will collect the other asset information about each server such as IIS version, Share Point version, vCenter version if they exist.   I have found that if I don't to the 2nd Asset import, then I get a ton of errors that refer to the VMWAREVCENTERVERSION not being found.

Hope this helps

TheMagician's picture

The assets do not import when receiving that error.  The error appears just after selecting "Run job now" from the context menu.

I have found the solution.  It seems that the installation of SCU 2012-3 corrupted something in the scema.  After installing (and monitoring VERY closely) SCU 2012-4 this afternoon, I was able to import the assets successfully.

Thanks for the suggestions though.

P.S. I have a new problem, I closed the Jobs Properties pane in the Monitor > Jobs view and now I can't seem to get it back.  Any suggestions?  I am going to post about it now too.

SOLUTION
cmccoy2's picture

Did you use the "Hide" option where the "push-pin" icons are in the panels?   If you have hidden a panel, I haven't found any way to get it back other than to do the following: close your CCS console, then go to the C:\users\<username>\AppData\Local\Symantec\CCS\Preferences  and there will be a folder underneath that called url........(big long GUID type of name).   You can delete this folder and then launch the CCS Console again.  This should restore all of the panels and views back to the default.   it seems that when you "hide" a panel there is no way to Un-hide it. 

TheMagician's picture

Thanks for the advice!

 

I have been looking around and found a DockingLayout file that seem to store the settings for the grids and panes in the CCS 11.0 console.