Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

"The custom form cannot be opened" when opening Enterprise Vault items.

Created: 24 Oct 2011 • Updated: 22 Nov 2011 | 10 comments
Sani B's picture
This issue has been solved. See solution.

Hi,

I'm having a problem with just a few users who cannot open archived items 'cause this error message is preventing it "The custom form cannot be opened"... etc

I found this

Article ID: TECH56326

and there is

Resolution:
Add the user with Full Control to the HKEY_USERS registry key. (All the users are automatically given this)

Or

Add the user to the Local Administrator group for the computer (This is forbidden and cannot be the solution)

 

The EV environment is:

Enterprise Vault: 8.0.4.1991

Outlook 2010 (this update from Outlook2007 was done without consulting us so there were naturally a lot of users who had problems to use the vault but most of them got fixed when installing the EV Outlook Add in 9.0.2)

 EV Outlook Add in 9.0.2

 

Now I have 2 users whose archived items won't open because of the form error. It was tested that with those computers that these two use, the test account was working just fine so the problem is user account related...

 

Any suggestions what might be wrong or what should I try to do to fix the problem...?

 

BR. Sani B.

 

 

Comments 10 CommentsJump to latest comment

RahulG's picture

Did you tried running resetevclient.exe ? or did you created a new outlook profile for those users on the same computer ? did following technote TECH56326  helped ?

You might also try reinstalling the Ev client .

JesusWept3's picture

As RahulG suggested, Best thing to do would be uninstalling the existing client and installing the ev9 HTTP Only Client

If that still doesnt work, you may need to look at the client trace to see exactly what the error is when attempting to start outlook, the above technote came from an error where it says that the registry cannot be written to after some companies decided to lock down the registry

So if the reinstallation and resetevclient do not help, try running a procmon to try and see where any denies might be coming from

Sani B's picture

Yes, we first tried running resetevclient.exe  = no effect

And then first uninstalled the client and then completely new installation of the add in 9.0.2 = this solved most of the users problems (I had plenty of problematic users but this worked most of them, now I got 2 users left where it did not help)

And no, the technote TECH56326  didn't help because I cannot authorise the local administration privileges and the other suggested (HKEY_USERS key) solution is already "in use"... 

And we only use that HTTP Only Client  version any way...

 

I'll try to see if running a procmon would tell me anything useful...

Thanks for your help, appreciate it!

Sani B.

pleonard83's picture

Delete FRMCACHE.DAT from the below location,

C:\Documents and Settings\dhqwpleonard\Local Settings\Application Data\Microsoft\FORMS

If you use windows 7 search for the same file.

JesusWept3's picture

Fwiw the frmcache should be deleted by resetevclient

RahulG's picture

hope you have the following hotfixes installed

http://www.symantec.com/docs/TECH138939

http://www.symantec.com/docs/TECH141669

you can install the form manually by going to mange forms and installing the forms from program files/Enterprise vault/Evclient/Language/En folder  . check if this helps?

I remember there was some issue with 64-bit Outlook client cannot publish EV forms to Personal Forms Library which was suppose to fixed in Ev 9.0 sp3.

Are the users having issue running on 64bit outlook?

 

Sani B's picture

Thaks RahulG but the ev version is 8 SP4 not 9 so neither of those technotes help in this case.

We have now installed the forms manually using outlooks own form tools and deleted the FRMCACHE.DAT but it only gives the note loading forms and still the shortcuts won't work...

 

User has only x86 version XP pro SP3 and outlook naturally is also x86

 

Here is some part of the log and I have bolded the parts that are strange:

22/11/2011 11:45:41.047[4272]: DesktopCommonConfig::GetSetting: 0x0
22/11/2011 11:45:41.048[3228]: IPM.Note.EnterpriseVault.Shortcut.RestoreMe: Form in Personal Form Library is the same as the FDM file (V9.0.2-001)
22/11/2011 11:45:41.049[4272]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
22/11/2011 11:45:41.051[3228]: Successfully loaded form file: C:\Program Files\Enterprise Vault\EVClient\Languages\Forms\en\EVShortcut.fdm
22/11/2011 11:45:41.051[4272]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
22/11/2011 11:45:41.054[4272]:     Desktop Setting: CheckURLPerRequest
22/11/2011 11:45:41.055[4272]:     No Value
22/11/2011 11:45:41.055[4272]: ~DesktopCommonConfig::GetSetting: 0x1
22/11/2011 11:45:41.055[3888]: CoClassIDispatchBase::Invoke: 0x0
22/11/2011 11:45:41.056[4272]:  CheckURLPerRequest = 0 [default]
22/11/2011 11:45:41.056[3888]: ~CoClassIDispatchBase::Invoke: 0x80020003
22/11/2011 11:45:41.057[4272]: ~DesktopCommonConfig::GetConfigValue: 0x1
22/11/2011 11:45:41.059[4272]: DesktopCommonConfig::GetSetting: 0x0
22/11/2011 11:45:41.060[4272]: DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
22/11/2011 11:45:41.060[4272]: ~DesktopCommonConfig::LoadSettingsFromHiddenMessage: 0x0
22/11/2011 11:45:41.062[4272]:     Desktop Setting: DefaultWebAppURL
22/11/2011 11:45:41.062[4272]:     Value: http://servername.domain/EnterpriseVault
22/11/2011 11:45:41.063[4272]: ~DesktopCommonConfig::GetSetting: 0x0
22/11/2011 11:45:41.064[4272]: DesktopCommon::GetIELanguageHeader: 0x0
22/11/2011 11:45:41.065[4272]: Failed to get IE language from Registry; error: 0x80070002
22/11/2011 11:45:41.066[4272]: Using same language as resource DLL: en
22/11/2011 11:45:41.067[4272]: Setting the static header string for the first and only time.
22/11/2011 11:45:41.068[4272]: sHeader = [Accept-Language:en]

 

The log shows that it's getting the form from the correct location but still the error comes... now what?

User don't have any kind of cache in function...

 

-Sani-

Sani B's picture

Remade the winprofile for the user and that did the trick... It works.. hallelujah...

Thanks all!

 

-Sani-

SOLUTION
LCT's picture

Hi Sani,

It's going to be a long shot but, have you tried cleanly removing the EV client and then reinstalling it on the affected machines? I know you mentioned you had uninstalled and reinstalled already.

1. Uninstall the client (with Outlook closed of course)

2. Remove the Enterprise Vault folder in C:\Program Files\ (if not removed by the uninstall process)

3. Remove the KVS reg key for both machine and user (if not removed by the uninstall process, most likely not)

4. Restart machine

5. Reinstall EV client

I had a similar issue a few weeks ago with Outlook 2010 (EV9 SP2 client) and EV8 SP4 server and this resolved my issue.

I was going to cleanly reinstall Office if the above did not work, but I didn't have to because the above worked for me. And next step was to recreate profile as last final straw!!!