Video Screencast Help

DA 9 - Error When Starting the Accelerator Service.

Created: 04 Jun 2012 | 9 comments

I have tried the following to correct this problem:

 

1. Changing the port in the web.config files.  Did not work.

2. Did a repair install.  Did not work.

3. Uninstalled it, reinstalled it.  Still does not work.

 

Server details:

SQL Server is unstalled on another server.

This server DA is installed on is running the following services/programs:

File Services 

Print Services

Web Server

Windows Deployment (not really using this, but was testing it out)

Windows Server Update Services

ESET Remote Administrator Server and Console (AV is not installed)

APC PowerChute Business Edition

DELL OpenManage

Enterprise Vault

OS is Windows Server Standard 2008 SP2.

Here is the error in the event log:

 

APP AS - Customer ID: -1 - Error When Starting the Accelerator Service. System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted
   at KVS.Accelerator.Server.CommonStarter.InitRemoting()
   at KVS.Accelerator.Server.CommonStarter.Start()
   at KVS.Accelerator.Server.AcceleratorServiceProcessor.MainThread()
 
I beleive I have tried everything in the forums and by doing Google searches for the error, so if anyone posts any links I'll make sure and let you if I have read/tried those.
 
I'm tired and going home.
 
Thanks,
Dan

Comments 9 CommentsJump to latest comment

TonySterling's picture

Did this ever work?

can you dtrace the accelerator manager service whilst trying to start it up?

DanCADMan's picture

Not sure if anyone read the first version of this post, but it was an old dtrace.  This is the current one.

Error in dtrace log:

 70 10:29:04.989 [16624] (AcceleratorService) <Accelerator Service for AS:13860> EV-H {-} Exception: Error Service_CommonStarter_FailedInitRemoting Info:{AcceleratorEvent} {C} Remoting: Failed to initiliase remoting. System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted|   at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)|   at System.Net.Sockets.Socket.Bind(EndPoint localEP)|   at System.Net.Sockets.TcpListener.Start(Int32 backlog)|   at System.Net.Sockets.TcpListener.Start()|   at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)|   at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)|   at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()|   at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel..ctor(IDictionary properties, IServerChannelSinkProvider sinkProvider, IAuthorizeRemotingConnection authorizeCallback)|   at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel..ctor(IDictionary properties, IServerChannelSinkProvider sinkProvider)|   at KVS.Accelerator.Server.CommonStarter.InitRemoting() Diag: Type:System.Exception ST:

71 10:29:04.991 [16624] (AcceleratorService) <Accelerator Service for AS:13860> EV-H {-} Exception: Error Service_ServiceProcessor_StartingService Info:{AcceleratorEvent} {C} Error When Starting the Accelerator Service. System.Net.Sockets.SocketException: Only one usage of each socket address (protocol/network address/port) is normally permitted|   at KVS.Accelerator.Server.CommonStarter.InitRemoting()|   at KVS.Accelerator.Server.CommonStarter.Start()|   at KVS.Accelerator.Server.AcceleratorServiceProcessor.MainThread() Diag: Type:System.Exception ST:
 
Any ideas?
 
idaman22's picture

Also ensure the DisableLoopbackCheck and DisableStrictNameChecking are set to 1 per  - Enterprise Vault Best Practice Registry Keys and Boot.ini Settings - http://www.symantec.com/docs/TECH71173

DanCADMan's picture

Ok, checked the previous links and the license files and all seems to check out.  Here is the full trace:

 

AttachmentSize
dtrace.txt 36.14 KB
TonySterling's picture

you said you change ports in the config file, which one did you change?

Also, what port is the default website set to use in in IIS?

One last thing, it is easier to read if you attach the dtrace to the post instead of pasting it in the body of the post. 

Regards,

 

DanCADMan's picture

<add key="RemotePort" value="8085"/> is the port portion of the config file I had tried changing.

 

As far as I can tell, the IIS main page is using port 80.  I don't see anything other port settings for IIS.

I've attached a netstat -b log file.  Port 8085 is not in use anywhere.  I know it's a little risky posting this file, but this server is not exposed to the internet.

AttachmentSize
netstat.txt 19.4 KB
TonySterling's picture

So did it every work?  I can tell the EV binaries are installed on here, but is this the EV Server?

ramann's picture

Suggest you review and implement the resolution detailed in:

http://www.symantec.com/docs/TECH61153

And yes, this TechNote will apply to versions through 9.0.3.

Please let us know if this resolves your issue.

Regards,

 

 

DanCADMan's picture

I did try this one already, in fact it was the first one that I tried and it didn't fix the problem.  I have checked the open ports using netstat -b and port 8085 is not in use at all.  It really does not make any sense to me.  A friend mentioned that I should change the binding order of the Ethernet ports, and that didn't seem to work either.  My subscription has run out, although I had planned to renew it.  Guess I need to go ahead and do that.