Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DA DB maintenance

Created: 23 Aug 2013 • Updated: 02 Oct 2013 | 6 comments
This issue has been solved. See solution.

We have the sql 11.0.2 database for DA 9.0 mounted on a windows server 2008 R2 box and our DBAs run the following maintenance:

Index Maintenance and Update Statistics  - Nightly

Full Backups  - Nightly

Log Backups  - Every 15 Minutes

I'm assuming that I need to shut down both Enterprise Vault Admin Service and Enterprise Vault Accelerator Manager Service which we are going to start doing.  However we are still recieving the following error:

Log Name:      Symantec Enterprise Vault
Source:        Accelerator Service Processor
Date:          8/23/2013 8:47:38 AM
Event ID:      42086
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      SDCSEVDISAPPW01.AD.CHPNET.ORG
Description:
APP AT - Customer ID: 2 - Warning:
Some items could not be searched:
Archive: 'David Engel'
ID: 149C90F5A6F97BF4E960CA67F4B06E5711110000EVSERVER01
Index Volume: 20322
Search ID: 122

Description:
Items or content missing from the index
Reason: Items or content missing from the index
Stack:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Accelerator Service Processor " />
    <EventID Qualifiers="0">42086</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2013-08-23T12:47:38.000000000Z" />
    <EventRecordID>1465705</EventRecordID>
    <Channel>Symantec Enterprise Vault</Channel>
    <Computer>SDCSEVDISAPPW01.AD.CHPNET.ORG</Computer>
    <Security />
  </System>
  <EventData>
    <Data>APP AT - Customer ID: 2 - Warning:
Some items could not be searched:
Archive: 'David Engel'
ID: 149C90F5A6F97BF4E960CA67F4B06E5711110000EVSERVER01
Index Volume: 20322
Search ID: 122

Description:
Items or content missing from the index
Reason: Items or content missing from the index
Stack: </Data>
  </EventData>
</Event>

 

Operating Systems:

Comments 6 CommentsJump to latest comment

Kenneth Adams's picture

Hello, Ariphaneus;

That error has nothing to do with database maintenance of the DA databases.  That error is telling you that Index Volume: 20322 that belongs to the archive of David Engle, and having VaultID (ArchiveID) 149C90F5A6F97BF4E960CA67F4B06E5711110000EVSERVER01 has at least one item that failed to be indexed.  That failure could have been temporary in that we could not retrieve the item from storage in the 5 attempts we make by default when attempting to index items, or part of the item (such as an attachment) could not be indexed.

The fix for this is to
- go into the Vault Admin Console,
- expand the Archives folder,
- locate the archive (likely in the Exchange Mailbox archives folder),
- right click on the archive,
- select the Properties option,
- click on the Index Volumes tab,
- scroll to the right in the listing of Index Volumes to locate the volume with the Failed column showing a number other than 0 or blank - if there are multiple index volumes for that archive, that is
- right click on the index volume with one or more failed items,
- select the 'Repair Index Volume' option,
- monitor the repair operation through the events that will be thrown into the Symantec Enterprise Vault Event Log on the EV indexing server hosting that archive's index.

Now, if you don't see any index volume reporting one or more failed items, there is likely a file named 'IndexMissing.log' in the index volume's physical folder on disk.  You'll need to rename that file.

Once you've repaired the index volume or renamed the 'IndexMissing.log' file, you should be able to run your search and have it succeed without that error.

FYI, the search you ran already will have returned any hits that we could find in that index volume based on the search criteria.  That error is an alert to you that there may be some additional hits in that volume if the item or items that could not be indexed happen to contain something that matches the search criteria.

If you see the index volume is reporting one or more failed items and the repair operation does not succeed in indexing that or those items, please open a support ticket so we can help you determine why the repair did not succeed.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

SOLUTION
Kenneth Adams's picture

Oh, a couple of notes on your maintenance plan:

1) You don't need to stop the Enterprise Vault Accelerator Manager Service (EVAMS) every time you run the maintenance plan, but having it stopped will allow for a more complete processing of the maintenance.  This is because our recommended maintenance operations of rebuilding table indexes and updating statistics will bypass any table that is locked by a background process - and we have lots of background processes running as long as EVAMS is running.  If you stop EVAMS once a week to allow the maintenance plan to work unimpeded by background processes, your database should be in good share unless you run 100's of searches each week that are accepted or rejected AND you delete DA Cases often.

2) If your DA server is a standalone that does not do any EV function, such as archiving, storage managment or indexing, you don't need the Enterprise Vault Admin Service running.  Just set that service startup property to Disabled and forget about it until you upgrade EV.  When you do upgrade, be sure to check this service as I've see where an upgrade of the EV files will change the startup property back to automatic.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

SOLUTION
Ariphaneus's picture

Continue to see these errors in the event viewer of the DA server.  Spoke with the vault admin who found no errors and is following the recommeded maintenance.  (Error 42086)  I'm tempted to write it off as inconsequential since the vault maintenance should take care of it (rebuilding the index rather than repairing it.) except the search that started at 10:15 this morning just kicked out almost 100 of these errors.  Seeing as a) the vault admin is telling me they're not finding anything in the failed columns or any missingindex.log files and b)  manually going through 100+ of these would be tedious.

Kenneth Adams's picture

Ask your vault admin to run a search against the index locations looking for all instances of the 'IndexMissing.log' files.  A simple windows search in Windows Explorer should suffice to find them all.  If none are found and the EV database is not reporting any index volumes with failed items, you can safely discount the errors.  There has to be something in your environment that is causing them to be thrown, though.  To date, we've only identified truly failed items as shown in the EV database or the presence of an 'IndexMissing.log' file.

 

Ken Adams

Backline Support for CA, DA, ACE, UCE, PSTD, ARMS, EVDC
US Support Region

EV_Ajay's picture

You can use following article :

Event ID 42086, Some items could not be searched.
http://www.symantec.com/docs/TECH189198

How to repair an Index Volume when it has items missing
http://www.symantec.com/docs/TECH130704

 

Solution :

1.    Log on to the Enterprise Vault Server.
2.    Check the “Index Volume” Tab for the archive which Archive ID is present in the Event Log.
3.    Check the “Failed Item” Option and check How many items Failed for Index.
4.    Open the Index folder for the affected archive and open the “Indexmissing.log” file.
5.    Check the Saveset IDs present in the “Indexmissing.log” file.
6.    Search for the physical DVS file from the SavesetID which present in the “Indexmissing.log” file.
7.    If DVS files are not found in the correct location then restore them from backup.
8.    If DVS files are found then repair the index volume for the affected archives. (Right Click on the Index Location and select “Repair” option. The status will change to “Rebuilding”. )
9.    Then give some time for synchronization between the EV & DA Server.

 

Thanks,

Ajay

EV_Ajay's picture

Hi,

Do you have any updates on this thread? Do you need more assistance regarding this topic?

If not then please mark the post that best solves your problem as the answer to this thread.

 

 

Thanks,

Ajay