Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DAG backup fails with 69

Created: 05 Mar 2013 • Updated: 07 Mar 2013 | 12 comments
This issue has been solved. See solution.

Hi all...

We are facing a problem of taking backup from passive node of the DAG

First we are running Netbackup 7.5.0.4 clustered master server on windows 2008 R2

we used to take backup of the Exchange 2010 from the passive node (2 passive nodes)...and everything was fine

till last Friday...where backup was interrupted by a communication issue...after that the backup fails with error 130...

we tried the VSS Fix batch...and the error now becomes 69...I am testing the backup on one DB only...still the same result...with DB_status is 103 now..

again...this happens with backup from passive node only....backup from active node is working fine...

the backup selection if u ask is as follows (Microsoft Exchange Database Availability Groups:\SHR-EXDAG-01\Microsoft Information Store\DB33)

attached bpfis log from my last try....

 

 

Comments 12 CommentsJump to latest comment

RamNagalla's picture

 

08:48:27.081 [2744.7856] <2> onlfi_vfms_logf: INF - Extended status = 69:1:Unable to backup Exchange database. It may not be mounted.
08:48:27.081 [2744.7856] <16> bpfis main: FTL - snapshot preparation failed - Unable to backup Exchange database. It may not be mounted., status 69

again...this happens with backup from passive node only....backup from active node is working fine.

 

so its looks like , passive node is not able to access the database, you would need to talk your  exchage admin, and make sure that everything is fine form exchage end.

aly.farouk's picture

 

Thanks for your fast response...

I asked them ...and yes....they can access the DBs from the passive node....

BTW...i found no bpkar or bpcd logs on the passive node....however, i tried the backup of a folder and it finished successfully....

so...any ideas what is wrong here?!!

RamNagalla's picture

I asked them ...and yes....they can access the DBs from the passive node....,  

we can not belive them alwasy.

try the backup from Passive node again.. and look in event viewer, I am sure it will give  some proof to find that issue ..

take that proof and talk with exchage admins again..

aly.farouk's picture

 

Hello Nagalla...

OK...i don't believe them either...but to my surprise...there is nothing appears on the passive node of DAG appears to be related to the backup...

attaching the filtered event viewer ...

AttachmentSize
event.rar 810 bytes
RLeon's picture

From your bpfis:

ERR - FindVolumesToSnap: Failure finding Microsoft Information Store:\DB33\

ERR - vss__complete: Exchange Transaction Logs will not be truncated by VSS because of errors encountered during the backup

There is definately something wrong with DB33.

 

 

And from your event viewer:

RPC request to the Microsoft Exchange Information Store service for log truncation failed for database DB33\PLZ-EXMB-P01. Error: 4294965485.

It is possible that the Exchange circular logging settings might have been changed, as discussed in the following link. Circular logging is disabled by default.
You may need to reseed the passive copy to fix the log sequence.

http://social.technet.microsoft.com/Forums/zh/exch...

Yogesh9881's picture

In continuation of above excellent post…

We also like to know what activity you performed on Friday ?  

pls communicate with exch team & let us know in details...

 

 

If this post has helped you, please vote or mark as solution.

Before break-up, make sure you have a good backup.....  ;-)

aly.farouk's picture

Hi there..
Thanks all for your reply...

I tried the backup of another DB on another passive node...
and the error changed to system error occurred (130) with the DB status 156...
attached the bpfis, event viewer and detailed status of the job

About what they did? they said they did nothing...nothing changed at all...
All what happened that the communication team upgraded the core switches...

AttachmentSize
logs.rar 51.26 KB
Mark_Solutions's picture

If there has been communication issues then replication may not be up to date in which case the passive node will not work

Get then to check that replication is all up to date and that the replication services are running

Restarting the replication service can fix the 156 errors so maybe have them re-start the servcies and wait until the replication is fully up to date before trying the backup again

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

aly.farouk's picture

Hi there...

Thanks for the reply...

I asked the exchange team...they said that everything is OK with the replication service....

I see that in the event viewer ....after the event ID 11000 (Microsoft Forefront Protection VSS Writer has successfully collected the metadata document in preparation for backup or restore.) ...there should be the event ID 9606 (Exchange VSS Writer (instance 4e137acf-3355-405e-ae9f-3ca09579084d) has prepared for backup successfully. ) which happen in normal case when backup is completed....however...after event ID 11000, the backup fails ith this error (130 system error occured), it is like that calling the Exchange VSS writer fails if this has meaning :) .

I feel like it is something about the VSS writers...but all of them are in stable state (as shown in the attached log, passive node 1 has DBs from 1 to 43, passive node 2 has DBs from 44 to 86) ...however i feel that one or more  writers are missing...is that possible?? how can i trace the VSS writers ??

Any help will be appreciated..

AttachmentSize
vssadmin list writers.txt 5.23 KB
aly.farouk's picture

Dear all...

thanks all for your help...we found it!!! It seems that this registry key has changed/or created recently

HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14\Replay\Parameters\EnableVSSWriter 

with decimal value set to 0. !!! ok...we inisited to make this value 1 , restart Microsoft Exchange Replication Writer and tried the backup...and backup runs smoothly now!!!

As a proof that this recently changed/created registry was the reason, we reveretd the value back to 0 and restrted the replication service and the backup failed with error 130 sysytem error occured!!

Back to set the value of registry to 1, restarted the replication service and backup is now running and writing yes

I think this closes this thread....Thanks again all for your help laugh

SOLUTION
CRZ's picture

Well done!  I'm marking your reply as solution.

We DO have some TechNotes talking about this registry key, but it appears none of them mention status code 69.  Here are two for status 13 and status 156:

NetBackup for Microsoft Exchange database availability group (DAG) backups fail with Status 13 on a Passive node copy
 http://symantec.com/docs/TECH171234

Exchange 2010 DAG backup returning snapshot 156 errors. Error: No valid VSS Provider of the type specified found
 http://symantec.com/docs/TECH129148

Looks like we might need one more TechNote!  In the mean time, I hope the search engines bring folks to your thread.


bit.ly/76LBN | APPLBN | 75LBN

aly.farouk's picture

Hi CRZ..

Thanks for your reply and mark :) 

However, the error was 69 at first...then changed to 130 when we tried backup from another passive node...

so this solution worked for teh error 130 (system error occured) , system call failed in the detailed status

smiley

Thnaks CRZ for the mark laugh