Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Data corruption - Associations failure

Created: 25 Jul 2014 • Updated: 15 Aug 2014 | 2 comments
This issue has been solved. See solution.

Hey all, I'm kind of going through a nightmare, and any help is much appreciated. 

 

Long story short: 

 

My SMP agent got connected to another SMP environment, that had newer agents on it, and all hell broke loose. I had to restore the backed up config file on the NS to simply re-install the agent on the NS itself. Once I did that, however, more problems started appearing. 

 

Current state: 

 

All my patch policies have no patches associated with them, and all my packages have "blank" command lines. However, on the SQL DB, the command lines show up for all the packages in the tables, but the patch policies infact don't hold any software updates. In the remidiation center, all patches show as downloaded but with no policies, it seems that some association got corrupt? 

 

Altiris logs are full of: 

 

Unable to generate policy XML for item: (Different Guids....)
System.NullReferenceException (Altiris.PatchManagementCore): Object reference not set to an instance of an object.

 

What I have tried: 

 

Reconfigured SMP, Client Suite, Patch Management multiple times. 

Ran CHECKDB on DB, no errors found. 

 

I am starting to run out of options, any ideas are greatly appreciated. Thanks! 

 

 

Operating Systems: