Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

DB and Logs backups (SQL)

Created: 02 Apr 2013 | 3 comments

Hello everyone,

Im using Backup exec 2010 R3 to backup SQL DB's. I have already separeted the jobs:

1) backup the DBs and set the method as "Full - Back up entire database".
2) backup the Logs and set the method as "Log - Back up transaction log".
N.B. I have set in SQL all DB's recovery mode as " FULL".
 

Problem is this: both jobs complete with exceptions:

JOB (Logs):  
V-79-57344-33959 - The master database only supports full backups.  Differential and log backups cannot be performed on the master database.

JOB (DBs):
V-79-40960-37914 - Database master is configured to maintain transaction logs.  Transaction log backups are not being performed.  This will result in the log growing to fill all available disk space.  Regular log backups should be scheduled or the database should be changed to the simple recovery mode.
 

How can I fix this issue? I'd prefer to leave recovery mode to "FULL", so I can restore DB to latest minute logs.

Thanks in advance for your answers! 

Operating Systems:

Comments 3 CommentsJump to latest comment

lmosla's picture

Hello kakagol, take a look at the following document that gives some helps on these SQL backup types http://www.symantec.com/business/support/index?pag...

pkh's picture

By default the Master database is using simple recovery mode.  I don't know what is the effect of setting it to full recovery mode.

I would suggest that you set the recovery mode of the Master database to simple and exclude it from your log backup.  This would solve both your errors.

Jaydeep S's picture

Adding to this, Master database is hard-coded in BE as to be a simple recovery model. So BE will only allow Full backup method on Master database. However, before the backup there is a check performed on all the databases on that instance to find out which database has a Full recovery model. And as there is not log backup performed on 'Master' database it would give out the warning.

The best way is to keep the Master database to default setings "Simple Recovery Model"