Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

DB2 backup gives errors 6 and 214

Created: 19 Dec 2013 • Updated: 21 Dec 2013 | 8 comments
This issue has been solved. See solution.

Master: 7.5.0.6 running on Windows 2k8

Media Server: 5230 running 2.5.3

Client: 7.5.0.4 on AIX

Anyone sucessfully backing up AIX DB2 with NetBackup?

db2level

DB21085I  Instance "scpprod" uses "64" bits and DB2 code release "SQL09058" with level identifier "06090107".

Informational tokens are "DB2 v9.5.0.8", "s110603", "IP23263", and Fix Pack "8".

Product is installed at "/opt/IBM/db2/V9.5".

Last Febuarary we started trying to get native DB2 backups to run on this client (they're backed up to disk files now) and actualy got one backup to run.  Then several things got in the way until now.

Attempts now give an error 214 on the sub-thread and an error 6 on the main thread.  With the help of the DBA (I don't have super user access) I've looked at all the permissions, the log files, and everything else I can find related to this error and still can't seem to figure out what's wrong.  This error occurs no matter how the backup is invoked.

Thinking that something might be damaged in the policy that existed since early this year, I deleted it and recreated it...still same error. 

The NetBackup DB2 Admin PDF is worse than useless since all it says is "run this wizard and the right policy will be created"...it doesn't give any examples of what the policy should look like after the wizard has run.  And there are examples in the Forums of people who ran the wizard for other database types and then had to rename the resulting schedules since the wizard didn't name the correctly in the first place.  And the troubleshooting section of the PDF just says "look at these files" rather than "this is what you should be seeing..."

So is it even possible to back up DB2 with NetBackup 7.5 or is it like a few other things that show up in the Marketing Pamphlets but doesn't actually work?

Operating Systems:

Comments 8 CommentsJump to latest comment

Nicolai's picture

I got DB2 on AIX running on Linux master and media servers.

However I have not seen the errors you see

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Marianne's picture

What you need to do now is to ensure that all the log folders exist on the db2 client with the correct 777 permissions.

After the next failure, check the log folders to see if log files were created.
If so, copy that log file to reflect process name (e.g. bpdb2.txt) and upload here as File attachments.
If we cannot help to identify the problem, we will advise you to log a Support call with Symantec.

PS - Not sure which manual you are looking at - I see good, detailed information for policy creation in  NetBackup for DB2 Administrator's Guide  http://www.symantec.com/docs/DOC5166 starting on p.32 - Adding a new NetBackup for DB2 policy.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

D.Flood's picture

Marianne,

About the manuals.  I'm more of a step-by-step, visual kind of person.  And too much of the NetBackup manuals are "just do this and expect the right results".  So it's taken a lot of trial and error to learn what little I do know about NetBackup.

Now to the problem at hand.  I turned up the client logging to max and ran another try from the NetBackup GUI (I don't have superuser access to run from command line) and here's the only two logs that got kicked out.  I'm also going to try to attach a screen shot of the policy.

AttachmentSize
policy.doc 62 KB
bphdb.txt 2.98 KB
bpdb2.txt 1.61 KB
Nicolai's picture

Is this DB2 database clustered ?

What does the DB2 admin say to this message : 

09:40:38.678 [1339602] <16> VxBSACreateObject: ERR - Could not create new image with file /DB2/SCP13P/node0000/20131220094026/SCP13P
.0.scpprod.node0000.1775.20131220094026.1.

Can the current user for backup write a test file in that location ?

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

D.Flood's picture

Boy don't I wish it were clustered!  One at HQ and one here at the DR site...but no...it isn't.

I've asked the DBA about that message and I'll let you know what he says.

Nicolai's picture

One thing to note -  always use the service name of the database (if used)

Has the DB2 host multiple NIC also (just to make it even more difficult) ?

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

D.Flood's picture

Nope, single NIC path.

And we just tried a backup in our other NetBackup Domain on a different development box and got the same errors.

So it's something about how the permissions are set up on those boxes and/or having to run the db2 command via sudo that is messing with things....

D.Flood's picture

Solved...somewhere since we last had it working the syntax of the db2.conf file changed.

In the past the SCHEDULE parm needed to be set to the name of the schedule that launched the backup.

Now it has to be set to whatever your Application_Backup schedule is called.

And there's nothing in the manual at all that I could find that says that.  I had to look at the examples in the db2.conf file and figure it out.

SOLUTION