Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Decisiononly workflow webservice - asmx page blank

Created: 14 Feb 2013 • Updated: 19 Feb 2013 | 4 comments
This issue has been solved. See solution.

I hope I'm missing something simple but I'm trying to setup a decision-only project as a webservice to be called from other workflows/systems, I've created a new decision-only project and setup a series of invocation target workflows within and set the input/outputs as needed, I have then published the workflow and accessed by the standard asmx page, but this is totally blank, no errors in the symantec log or IIS log, I've compared my settings to the SD.DataServices & the AM.Dataservices projects and settings are a exact match including the web.config files but the main page is still not showing the list of methods i should be able to call. I've restarted the Server extensions and done a IISReset, I tried to generate a integration library web caller but got a error (see below)

Cannot get request from URL:
LogicBase.Components.DynamicWebserviceCaller.UrlReference
System.InvalidOperationException: There is an error in XML document (0, 0). ---> System.Xml.XmlException: Root element is missing.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
   at System.Xml.XmlReader.MoveToContent()
   at System.Web.Services.Description.ServiceDescriptionSerializationReader.Read125_definitions()
   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events) 

I've attached screenshots of my settings.

 

Using Workflow 7.1.1500.2062

 

 

Comments 4 CommentsJump to latest comment

SDriver's picture

Update - I decided to move all the subprojects into a workflow project instead of a decision-only and published this and got the same blank page. project was set as a webservice.

reecardo's picture

I'd check the IIS logs (or use a tool like Fiddler) for any error codes that might be coming up. Try looking at the .asmx page in different browsers, often they will expose more information to help you solve the issue.

SDriver's picture

Issue found but not fixed - I tracked down whats causing the issue it was due to a complex datatype on one of my sub-models, I had set a output DataType to 'ADUserInfo' (submodel was a user search return) as soon as this was published I got a blank page, I can change the datatype to anything else even 'ADUserInfoSummary' and the asmx page shows fine, so either the 'ADUserInfo' datatype is too complex (contains nested arrays etc) or there is a glitch in it it somewhere, so either way I think I'll need to log this with symantec, in the mean time i'll try using a different datatype.

reecardo's picture

Aha... OK, this is something we have fixed:

2784143 Decision Only doesn't work with ADUserInfo datatype input or output data

This was fixed in May of this year, so it will be fixed in 7.5. I'm pretty sure this has also been pushed down to various rollups of earlier products as well.

7.1.1500.* is 7.1 sp2 mp1... if you are using the initial release of this product, you should request a rollup. The fix should be in that rollup.

SOLUTION