Video Screencast Help

Decommissioning of media server

Created: 20 Feb 2013 • Updated: 22 May 2013 | 9 comments
This issue has been solved. See solution.

Hi I am presently trying to decommission a media server when i run the command  nbemmcmd -deletehost -machinename kilo -machinetype media,

I get the error below:

The function returned the following failure status:
generic EMM SQL error (193)
Command did not complete successfully.

 

Regards.

Peter.
 

Comments 9 CommentsJump to latest comment

Nagalla's picture

hi,

did you try to remove and deassing the all associated tapes and Devies to the media server before you start decomm

check the below tech note and make sure you followed the steps.

http://www.symantec.com/business/support/index?pag...

Nicolai's picture

The error message means a resource is still assigned to the media server. If no obvious resources are assigned you may have to dump the EMM database to look for references:

As a example.

http://www.mass.dk/netbackup/guides/80-decommissio...

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Marianne's picture

Peter, which NBU version?

Are you aware of 'nbdecommission' tool?

If we know which NBU version and patch level we can provide appropriate link.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Peteros's picture

I am using netbackup version 7.0.1. I have also deassigned all tapes and drives associated with the media server before starting the decommissioning process. I also decomissioned one other media server and it was successful.

Symboy's picture

Hi 

 

 I would recommend to open a support case with symantec t check if there are any stale entries ( Drives / media / Images etc ) still referring to the media server . 

 

 

Note: If this post provides you with a solution don't forget to mark the discussion as solved.

SOLUTION
bigdog_40's picture

Peter,
Has NB already been uninstalled from the media server?

If so, you may have to run the following command from your master server:

nbemmcmd -deletealldevices -machinename -machinetype media

http://www.symantec.com/business/support/index?page=content&id=TECH62119

Peteros's picture

where am i going to run the command is it from the master server or the server to be decommissioned? Netbackup has not been uninstalled on the box. I still get the error ''generic EMM SQL error (193)'' when i try delete the media server.

Marianne's picture

nbemmcmd -deletealldevices is a master server command.

Are there any disk STU images assosciated with this media server?

Have all images been expired?

All storage units removed?

SAN Client entry associated with Media server?

Please post output of the following command on the master server:
nbemmcmd -listhosts -verbose

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

bigdog_40's picture

Peter,

Have you moved the images to a different media server?  I have found this issue, when there are still a couple remaining images out there.

If you have not already done so, please run the following command from the master server:

bpmedia -movedb -ev media_ID -oldserver <old_server> -newserver <new_server>