Video Screencast Help

'Decrypt failed! (No secret key) Code = 17' Error PLEASE HELP

Created: 31 Dec 2012 | 2 comments

I've sent a message to two different people multiple times now and every time they try to decrypt it they get this error.

'Decrypt failed! (No secret key)
Code = 17'

I did this this for months with no problems. I took a break for a while and encrypted my message the same way I always have and this started happening. 1- Copy and paste user's public key to note pad and save 2- Import user's key to PGP 3- Write message in a new notepad that I wish to encrypt 4- In the task bar find PGP, right click it, click 'current window', and 'encrypt' 5- Choose the corresponding user's key I wish to send the message to and ecrypt it 6- Copy and paste this encryption in the medium I send it to them though and send it

Both of the people I send it to know what they are doing and both get the same error. The only thing I could think of that might have changed is I messed around with my PGP after I stopped using it and I needed my passphrase, but I'd forgot it because I never had to use it. I thought maybe that had something to do with "no secret key." I created a new master key with a new passphrase and they both got the same error again! So I started completely over. I uninstalled PGP and erased all my keyrings. I even removed my key from the database online and made a new key from scratch. Same error!!!!!!

WTF!?

Comments 2 CommentsJump to latest comment

Tom Mc's picture

I'm thinking that this is not related to your own keypair, which consists of a public and private key.  Usuallly in encryption, the term secret key is in reference to the symmetric key that your data or email is actually encrypted to - it is what is acturally to your public key.  When PGP is decrypting an email, it is using the recipient's private key to decrypt the symmetric secret key, and then using this secret key to decrypt the email or data. 

Could you possibly be line wrapping the pasted encrypted email?

Are both of you using PGP, or are one or both maybe using an Open PGP compliant software?

If PGP is being used, what versions are you using?  What operating systems?

When you consider your issue resolved, please click Mark As Solution on the most helpful response.

Search the Knowledge Base &

PGP_Ben's picture

WHat key mode is your key using also?

If/when you consider your issue resolved, please click Mark As Solution on the most helpful response.