Video Screencast Help

Dedup-Pool fo offline by filling over 80 % ?

Created: 18 Oct 2012 • Updated: 22 May 2013 | 5 comments
Gunni75's picture
This issue has been solved. See solution.

Hello,

We have a great problem with our Netbackup Appliances 5220.
If the Dedup-pool raise by filling over 80% on the appliance, the dedup-pool go offline automaticly and the state is down !!!
Backups jobs to the dedup-pool of the appliance are not possible at this moment.
Is this a bug ?

Furthermore, in the the netbackup management console ( MasterServer) the filling rate ( % Full ) of the dedup-pool are different from the
CLI display at the appliance.
Why ?
Can anyone this explain ?

technical details:

Netbackup Appliance 5220
Firmware: 2.0.2
configured as mediaserver

MasterServer:
Windows Server 2008 R2 SP1
Netbackup Version: 7.1.0.3

thanks for your answers.
 

Comments 5 CommentsJump to latest comment

AbdulRasheed's picture

Hi Gunni75,

  For the version of the diskpool you have in NetBackup version less than 7.5 and appliance versions less than 2.5, there is a disconnect between what is reported in NetBackup UI and what is actuall there at container level. The details are and solution are documented here: http://www.symantec.com/docs/TECH128694

  NetBackup 5220 uses VxFS for file system. VxFS file system does not reserve space like traditional ext3 file systems and hence you can make the change suggested in TN. 

  Alternately, you may want to consider upgrading to NetBackup 7.5.x and appliance 2.5.x where this problem no longer exists!

  Talk to a support engineer if you need more clarification or guidance. 

 

 

Warm regards,

Abdul "Rasheed" Rasheed

Tweet me @AbdulRasheed127

Gunni75's picture

Hi,

thanks for the quick response.

 "NetBackup 5220 uses VxFS for file system. VxFS file system does not reserve space like traditional ext3 file systems and hence you can make the change suggested in TN."

What is TN ?

Is there a solution for this issue till we upgrading the masterserver and the appliance firmware ?

At this moment i run a manually Garbage collection on the dedup disk pool ( Appliance 5220 )
The DataStore Statistic are as follow:

************ Data Store statistics ************
Data storage       Size   Used  Avail Use%
                  32.0T  20.9T  11.1T  66%
Number of containers             : 91753
Average container size           : 265312380 bytes (253.02MB)
Space allocated for containers   : 24343206810196 bytes (22.14TB)
Space used within containers     : 23018537878533 bytes (20.94TB)
Space available within containers: 1324668931663 bytes (1.20TB)
Space needs compaction           : 780724168740 bytes (727.11GB)
Records marked for compaction    : 20109998
Active records                   : 400232654
Total records                    : 420342652

 

AbdulRasheed's picture

TN = TechNote, I was referring the the link provided. 

Did you see the document http://www.symantec.com/docs/TECH128694

You can follow the instructions here to resolve the issue if you do not want to upgrade at this time. Technical Support can also guide through this process. (It is really about editing a file, but you need to elevate the user access level so that you can edit that file). 

Warm regards,

Abdul "Rasheed" Rasheed

Tweet me @AbdulRasheed127

Gunni75's picture

thanks for your explaination

but in the TN there is a warning :

"for UNIX/Linux based MSDP platforms and for PureDisk storagepools, do not modify the WarningSpaceThreshold, LowSpaceThreshold and VeryLowSpace thresholds..."

but the 5220 Appliance is a UNIX/Linux based MSDP or not ?

Furthermore at this moment, i execuing the commands from this TN:

http://www.symantec.com/docs/TECH180659 ( Section 52xx )

Question:

must i reboot the appliance after completing the processes ?
or
suffices to execute commands so that the Fillrate ( in % ) display the right size on the netbackup management console ( MasterServer) ???

thanks

 

AbdulRasheed's picture

That warning was added as most UNIX/Linux file systems handle the file system full condition in a way that is not safe for this modification. 

You are right in stating that NetBackup 5220 has a Linux based OS. However the file system in NetBackup 5220 is Symantec's own VxFS which is not affected by the warning statement above. For appliances, you can follow the instructions. 

You need to restart NetBackup services after making the change. A reboot itself is not necessary. 

Warm regards,

Abdul "Rasheed" Rasheed

Tweet me @AbdulRasheed127

SOLUTION