Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Deduplication storage offline

Created: 23 Jun 2013 • Updated: 26 Aug 2013 | 4 comments
sweehan's picture
This issue has been solved. See solution.

Recently I've solve the problem of my SAN storage, but after the SAN storage issue solved, I found that the deduplication storage in backup exec 2012 was offline.

I tried to restart the PostgreSQL server 8.3 and backup exec deduplication engine services but failed.

I checked the eventlog and found this error mesage:

"Event ID: 0; Source: PostgresSQL

The description for Event ID 0 from source PostgreSQL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

2013-01-31 17:57:50 GMT FATAL: could not create lock file "postmaster.pid": Invalid argument "

I follow the troubleshoot guide from this link

http://www.symantec.com/business/support/index?page=content&id=TECH205809

I've checked the permission for this volume for the BESA account was full control.

Then I follow this link:

http://www.symantec.com/business/support/index?page=content&id=TECH136974

But there isn't delete option when I right click on the postmaster.pid. I try highlight the postmaster.pid and press the delete button but files was not able to delete.

I reboot the backup server and tried the solution again but the result still the same.

My backup exec 2012 has the latest update.

Hope for symantec expert to help me out.

Operating Systems:

Comments 4 CommentsJump to latest comment

pkh's picture

Have you "Use the Windows Services Control Panel to make sure that the postgresql-8.3 service is not running."?  If not, make sure that the service is not running.

You can also try setting this service to manual start and reboot the server.  After deleting the postmaster.pid file, you can then set the service to automatic start and start the service up.

sweehan's picture

Yes, I've checked in the window services on postgresql server 8.3 service. Tried reboot the server and delete postmaster.pid but unable to delete it.
I try to change ownership of the volume but was not successful

pkh's picture

I would suggest that you log a support case with Symantec for them to take a look at this problem.

sweehan's picture

I Found this article regarding the SAN Storage,

http://support.microsoft.com/kb/971436

After I run the diskpart command, I restart the deduplication services and the dedup storage goes online.

Tested backup also successful.

SOLUTION