Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Delete Archive Permissions?

Created: 18 Dec 2012 • Updated: 18 Dec 2012 | 5 comments
Sarah.Seftel's picture
This issue has been solved. See solution.

Hi,

 

scenario:

user have mailbox, archive created.

on exchange side - permission were set to an additional user, permissions inheritance to EV also worked.

the user left work.

after 30 days - mailbox deleted.

BUT - permissions of additional user were not removed prior to delete of mailbox, so now the additional user is "stuck" with viewing other user archive.

we cannot remove the permissions via GUI, as it got "automatically set".

cannot ZAP the mailbox as the DN of the original user does not exist anymore and we get error.

 

anything I can run against the archive itself to remove the permissions?

 

Sarah.

 

 

Comments 5 CommentsJump to latest comment

TonySterling's picture

Have you tried to change the Billing Owner to the VSA?  You could try to change that and then run the Zap.

Sarah.Seftel's picture

Not Working...

I get the following:

Processing mailbox: /o=BLA/ou=Exchange Administrative Group (AAA)/cn=Recipients/cn=biton

Error - Whilst processing mailbox with dn: /o=BLA/ou=Exchange Administrative Group (AAA)/cn=Recipients/cn=biton[0x8004011D]

which makes sense, as the ZAP will try to connect to the mailbox, but this specific mailbox no longer exists...

So... how can I change manually permissions on archive that is not associated to a mailbox?

 

 

 

R Meeker's picture

So you just want to remove the permissions for that person to the orhpaned archive.

Can't you just deny permissions?

TonySterling's picture

Ahh, you need to use ArchivePermissions in the EVPM script.  This just requires the archive name, not the mailbox.

[Directory]
DirectoryComputerName=kvsvault
SiteName=archivesite

[ArchivePermissions]
ArchiveName=Mary Jones
Zap=True

SOLUTION
Sarah.Seftel's picture

As usual, Tony to the rescue.

That did what I needed smiley