Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Delete Backup Exec. logs automatically ?

Created: 07 Oct 2013 • Updated: 14 Oct 2013 | 6 comments
This issue has been solved. See solution.

I have a client running Exchange on the same server as BE.   The C: drive got so full that the email quit letting external email come in.

While looking for where a bunch of the space was I found the folder (C:\program files\Symantec\Backup Exec\logs) had over 13 gig of log files.

Is there a way to purge files based on date or anything for this ??

Thanks

Mike

Operating Systems:

Comments 6 CommentsJump to latest comment

Donald Eady's picture

Have you ever had to troubleshoot any Exchange GRT restore issues?? the reason i ask is that when doing so it is often requested that EWS debugging be enabled.. This is normally disabled once the issue is resolved because if left on it will continue to generate very large logs... Please verify by looking Inside Debug Monitor, under tools\Settings dialog, select Job Engine & Remote Agent on the left. Then verify that Enable Job Engine and Remote Agent Debug outside of SGMon is not selected. If it is then please unselect it. Also under regedit browse to HKLM\Software\Symantec\Backup Exec for Windows\Backup Exec\Engine\Logging

- Look for the DWORD Value names:

   EnableEWSDebug and CreateEWSTrace

If present verify that the values for both are set to 0

if you have to make adjustment to the values of either of the DWORD names you would need to restart the server.. Please report as to whether or not these values were present and active on your Exchange/Media server. The following document is for you review in reard to EWS debuging.

http://www.symantec.com/docs/TECH124453

I hope this posting was helpful

  

SOLUTION
mli7777's picture

Very cool and great catch.

I didn't have the reg entries but the above mentioned inside the Debug Monitor was turned on.

So I turned it off and will be watching the logs to see if they grow anymore now.

Thanks much !!

Mike

Donald Eady's picture

Very cool... Please do keep us updated... 

Note .. you could browse to the log location and verify the size of the logs to confirm that these logs are what it is that is occupying the space... the debug logs can be deleted... provided you are not currently troubleshooting any other issue. 

The logs are created under -
BE Server - Program Files\Symantec\Backup Exec\Logs
Remote servers - Program Files\Symantec\Backup Exec\RAWS\Logs
The following logs create a new file each time BE services restart/debug is turned on:
ServerName-BEngine##.log
ServerName-BERemote##.log
ServerName-EWSLog##.log
The following logs append (single log file):
ServerName-SGMon.log
ewstrace.log
 

I hope this posting was helpful

  

GeorgeSamuel.d's picture

Hi,

Set the Exchange Writers logging level to "Expert"  so that Exchange reflects every detail of the Writers operation. See http://technet.microsoft.com/en-us/library/dd23325... for details

a) Check that the Replication is working properly among the Exchange Mailbox servers. (If you use DAG)

b) To prevent the log drive from filling up with transaction logs, you can remove the affected passive database copy instead of suspending it.

Related Tech Article : http://www.symantec.com/docs/TECH156654

c) Also Try Backing up Without AOFO

Related Tech Article : http://www.symantec.com/docs/TECH45295

Regards

George Samuel

mli7777's picture

Seems much better with logging turned off while you aren't using it and don't need it.  :)

So going to mark that as the solution.

Thanks for the help.

Mike