Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Delete information from page in Service Desk 7.5 MP1

Created: 02 Oct 2013 • Updated: 08 Oct 2013 | 5 comments
This issue has been solved. See solution.

Hello!

How to delete links from page in Service Desk 7.5 MP1 "Contact Support, Help, Make Home Page"?

 

Operating Systems:

Comments 5 CommentsJump to latest comment

dawi_x's picture

I know the help and contact link can be removed through the portal master settings (Admin - Portal - Master Settings) below 'Process Manager Settings' and 'Customization' tabs respectively.

Not sure if the Make Home Page can be removed within the GUI.

kr, dawi_x 

michael.george's picture

I couldn't find a way in the GUI, so I thought I'd get creative and modify the CSS to simply not display the link in the footer. C:\Program Files\Symantec\Workflow\ProcessManager\App_Themes\Symantec\Layout.css is the file used ("#graybottomCenter a" is the actual id in use, line 151) but when I added a "display: none;" to that section, it didn't seem to have any effect, even though it really should according to Firefox. I even cycled the application pool for the process manager with no luck.

I think if you could get the change in CSS to take effect, this method would work to remove all 3 links. Obviously, it wouldn't be supported by Symantec and you would likely have to do it again after a patch or upgrade of SD (or workflow).

If a post solves your issue, please mark it as a solution. It makes these forums better for everyone.

reecardo's picture

The actual file for the footer is in <PM install root>/Controls/Footer.ascx... you can modify this ascx file and add some HTML to get it to hide. Keep in mind that this is not supported, and upgrades will replace this.

The main differences are here (my changes are in bold):

&nbsp;<a id="lnkSupport" runat="server" target="_blank" style="display: none"><asp:Literal
                                    ID="litContactSupport" Text="Contact Support" runat="server" meta:resourcekey="litContactSupportResource1"
                                    /> </a>
                                &nbsp; <a id="lnkHelp" runat="server" target="_blank" style="display: none"><asp:Literal ID="litHelp"
                                    Text="Help" runat="server" meta:resourcekey="litHelpResource1" /></a>
                                <span id="spanHelp" runat="server" visible="false">|<a id="linkHelp" runat="server"
                                    target="_blank"><asp:Literal Text="Help" runat="server" ID="litHelpLnk"
                                    meta:resourcekey="litHelpLnkResource1"></asp:Literal></a></span><span id="spanSupportSeparator" runat="server" visible="false" style="display: none">&nbsp;&nbsp;|</span><span id="blah" style="display: none"><asp:LinkButton
                                        ID="lnkSetAsHome" runat="server" Text="Make Home Page" OnClick="SetHomeClick"
                                        CausesValidation="False" meta:resourcekey="lnkSetAsHomeResource1" /></span><span id="spanShowFeedBackSapperator" runat="server" visible="false">|</span>

 

Olga Kachalova's picture

Thanks for your an information. Links "help" and "contact" I hid the portal master settings. And link "make home page" I didn't delete.

michael.george's picture

Glad you found a solution! You should mark reecardo's answer as a solution to help others who find themselves needing the information.

If a post solves your issue, please mark it as a solution. It makes these forums better for everyone.