Video Screencast Help

Deleted drives have active entry in bptm logs

Created: 07 Nov 2013 • Updated: 08 Nov 2013 | 9 comments
rk1074's picture
This issue has been solved. See solution.

Hello experts,

 

we have 2 LTO4 drives removed from our library and they do not come up in GUI or the vmoprcmd output or any other utility.

 

But strangely, I can see entry for the same drives in bptm logs of the server having an REQID and ALOCID as well.

Any thought for this?

 

we are usinng 7.5.0.5 version of the NBU on Linux machine

Below is one entry from the bptm  logs for one drive:

 

14:40:57.348 [27360] <2> drivename_open: Called with Create 0, file IBM.ULTRIUM-TD4.000
14:40:57.348 [27360] <2> drivename_checklock: Called
14:40:57.348 [27360] <2> report_drives: DRIVE = IBM.ULTRIUM-TD4.000 LOCK = FALSE CURTIME = 1383856857
14:40:57.348 [27360] <2> report_drives: MODE = 2
14:40:57.348 [27360] <2> report_drives: TIME = 1380639995
14:40:57.348 [27360] <2> report_drives: MASTER = <server>
14:40:57.348 [27360] <2> report_drives: SR_KEY = 0 0
14:40:57.348 [27360] <2> report_drives: PATH = nrst0a
14:40:57.349 [27360] <2> report_drives: REQID = -1380109618
14:40:57.349 [27360] <2> report_drives: ALOCID = 6226
14:40:57.349 [27360] <2> report_drives: RBID = {1026B220-2AAB-11E3-A27F-0995D9711E23}
14:40:57.349 [27360] <2> report_drives: NDMP_HOST = <server.com>
14:40:57.349 [27360] <2> report_drives: PID = 8465
14:40:57.349 [27360] <2> report_drives: FILE = /usr/openv/netbackup/db/media/tpreq/drive_IBM.ULTRIUM-TD4.000
 

 

 

Operating Systems:

Comments 9 CommentsJump to latest comment

revaroo's picture

Was this your drive? IBM.ULTRIUM-TD4.000

SymTerry's picture

By removed, do you mean physically removed from the library? What process did you follow to remove them from NetBackup?

mph999's picture

If they are still showing I guess there is an entry somewhere in NBDB still.
If you don;t have too many / any other drives - run nbemmcmd -deletealldevices -allrecords
Then reconfigure back any drives you still have

You could perhaps first check the DB. If they are not showing in commands, do this.

/usr/openv/db/bin/nbdb_unload /tmp/db_dump

cd /tmp/db_dump

You should have a load of .dat files ....

grep TD4.000 *dat

Does it appear ?

If so, above commands (nbemmcmd) should splat it, but as mentioned you'll need to configure back any drives/ libraries across the environment.

Possible alternative:

Try deleteing the drive with tpconfig using the drivename.
or
I think vmglob has a delete option - you coud try that as well.

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
sri vani's picture

although it shd consider at final step..as suggested above,if u have only few drives delete the drives and reconfigure . (shrt cut wink

eg: tpconfig.exe -delete -drive 0

Jean-Pierre Bailly's picture

An output of tpconfig -d and scan from volmgr/bin would help us understand what you have running.

If NBU is allocating the device it exists and with the name of the device we see it is the default name. So it was probably discoverd by a wizard.

Mark_Solutions's picture

It sounds like there is an old orphaned bptm process running on the media server that had the drive

Check for bptm processes or bpbrm processes on that media server when nothing should be running

Also do a nbrbutil -dump to see if there are MDS allocations for the drive

A nbrbutil -resetall often hels once you have killed off orphaned bptm / bpbrm processes

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

ontherocks's picture

Hi rk1074,

 

Go to path "/usr/openv/netbackup/db/media/drives" and check if there are any files with similar name of deleted drive entries are still there in this directory.

If yes, then delete those files.

bprdreq -rereadconfig will solve this problem.

If required restart NBU services.

 

Regards,

OTR

OTR

SOLUTION
rk1074's picture

I cannot run nbemmcmd -deletealldevices -allrecords as I have active backups runnings at this time and cannot afford to  kill them as of now.

I checked  "/usr/openv/netbackup/db/media/drives" and yes there were 2 enties for those removed TD4 drives .

I deleted those two entries and reread  the config.

and vola!!! no more log entry for those TD4 in bptm now.

Thanks OntheRocks and all for ur suggestions

 

mph999's picture

Nice one ontherocks - hadn't thought of that .... 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805