Video Screencast Help

deleting empty Vault store Group

Created: 07 Mar 2012 • Updated: 10 Apr 2012 | 10 comments
K.G's picture
This issue has been solved. See solution.

hi,

İ deleted empty vault store group(it includes 1 vs and 1 ptn)(storage is SAN , not centera.)

it marked for deletion but event log says that;

 

Failed to delete a Partition. 
 Partition Entry Id : 13B842537FC58F94FA6C2FDAB5A1CBC161q10000VAULT 
 Vault Store Entry Id: 1F9E4FA5F543F274E9F9F7B20420689491210000VAULT 
 Internal references:
 Error     : The process cannot access the file because it is being used by another process.  (0x80070020)
 Reference : {CDeleteVault::DeletePartition} [.\DeletePartition.cpp, lines (16){...,66,67,68,69,70,71,72,73,74,81,85,112}, built Nov 11 21:03:35 2011]
For more information, see Help and Support Center at http://evevent.symantec.com/rosetta/showevent.asp?EvtID=7114
Discussion Filed Under:

Comments 10 CommentsJump to latest comment

ZeRoC00L's picture

Did you close the partition ?

If this response answers your concern, please mark it as a "solution"

Percy Vere's picture

You can always maunally remove the partition via the EV directory database \ partitionentry table in SQL. Just look for the row that contains the entryid as above and then right click and delete. If there are any FK restraints then you will need to delete them first. PLease ensure you take a backup of the database first.

K.G's picture

screenshoot is attached.

Percy, but this is not just ptn, if this is just ptn i can remove from partition entry table you are right but vs group +vs+ptn delete in sql i dont know the shortcut method. because as you know vs creates new db on the sql management consele,.

delete.JPG
MichelZ's picture

May sound trivial, but have you tried rebooting the server and trying again? :)

Percy Vere's picture

If you expand the Programmability \ Stored Procedures section under the Dir Database you will see the 'DeleteVaultStore' sp. If you view that you will see what tables are affected.

SOLUTION
TypoProne's picture

Hey KG.

 

Can you please mark this as solved and mark the person that solved it so:

1) people offering assistnace do not pop in trying to help when it is not needed

2) the next person having an issue knows how you solved it

3) to give the person donating their time helping the credit for having fixed your issue.

 

Many thanks!!

proacthantho's picture

Great Info,

Helped me getting rid of a Vault Store and Partition that got stuck in "being deleted".

 

 

Percy Vere's picture

Hi,

I would argue that the information provided by the forum members provided the resolution rather than the steps carried out by yourself. If you hadn't known the tables then you wouldn't have known what to delete.

ianG's picture

I find a quick restart of the storage service free's up the partition/store to be deleted. If that doesnt work, a full reboot should do the trick (as said)