Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Deploy anywhere "critical drivers missing" 7.1 issue

Created: 30 Mar 2011 • Updated: 09 Jun 2011 | 6 comments
This issue has been solved. See solution.

So far everything has been running pretty smoothly, I can capture and deploy a win7 image, send out patches, remote control, etc.

I'd like to move towards a hardware independent win7 image.  It seems that deployanywhere in 7.1 is supposed to take the place of copying down drivers via a script based on model

Everytime I check the box for "Include DeployAnywhere for hardware independent imaging" the deploy task fails and the deployanywhere.log file says "retargeting has been cancelled because some critical drivers are missing."

In CMS, driver database management, I've tried uploading drivers for this model (Latitude e6400) 2 different ways.

I've downloaded the win7x86 drivers from dell from this site and imported them folder by folder (so I did the audio folder, the network folder, etc).  http://dell.to/2oxlH

I wish the import tool told you "imported X drivers successfully."... the only way I know some drivers are going in to the database is because the total number of drivers in my database increases.

When that didn't solve the problem, I tried booting into win7 on that base machine and then running drivermax and that downloaded a whole bunch of drivers not already in my database.  Again, folder by folder, I uploaded various drivers to the database (this took awhile)... Most folders did upload a driver successfully, but a few said one of the 2 following errors:

"Driver(s) addition failed. This has happened due to the following reason(s):(1)Driver not found in selected folder" 

"driver not recognized.""

Tried again after uploading 50+ drivers from drivermax, but still same error during deployment saying critical drivers missing.

Is there any good way to upload drivers to deploy anywhere with 7.1 other than folder by folder (it doesn't seem to look 2 folders deep)? 

I'm using a rdeploy image if that matters - maybe I'll try ghost next.  I'm not sure what else to do to troubleshoot this further.  Anyone have ideas?

Comments 6 CommentsJump to latest comment

DavidAJLockwood's picture

Have you tried to run deployanywhere in eval mode to report on which critical drivers are missing?

From the docs :

"If /ddb is not specified then /eval will report all critical drivers missing from the target

If /ddb is specified then /eval will report all critical drivers missing from the target that are not in the driver database"

If you import the Ds 7.1 samples from HOWTO44396 there is a sample script that runs DeployAnywhere in eval mode. So hopefully that would point us to exactly which drivers are missing in the db.

Sally5432's picture

Thanks for posting.  Later in the day I did find the eval tool and figured out it's complaining about a broadcom wireless driver with error attached.

When I search my deploy anywhere database for 432b it shows the latest broadcom dell driver I had already uploaded.. and a more generic microsoft one "microsoft.netvwifibus.inf.4.176.75.21"

I've tried deleting both drivers and leaving one or the other but the eval still fails with the same error.  Not sure where to go from here.  I did re-add the drivers I had deleted.

post.jpg

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

arjain's picture

sally, i will not be help to you on this, but after seeing the screen shot i can suggest that you can share the logs created at

  X:\Program Files\AltirisAgent\Agent\Logs\DeployAnywhere.log
 
Incase, you want to take screenshot in Win PE environment you can use the utility shared at
 

~ SQA Manual - Crafting tomorrow

If a forum post solves your problem, please flag it as a solution. If you like an article or blog post vote for it.

DavidAJLockwood's picture

I think I've seen the same issue with the e6400 and this broadcom wireless driver. With that customer we just disabled the wireless nic in the BIOS and that enabled them to succesfully complete the imaging task.

Sally5432's picture

The deployanywhere log just says "error while retargeting the system.  Retargeting has been cancelled because some critical drivers are missing" - that's what got me hunting for the eval results.

If I turn off wireless in BIOS, the image does complete... and when I turn wireless back on I was surprised it worked and drive was there.  Is that because I built the image on the device or are the drivers pushed down once booted into production when deployanwhere is running?

I guess it's good it finished, but not really idea to be turning BIOS off/on for a few hundred machines if we run into this on our next mass purchase. 

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

Sally5432's picture

This appears to be fixed in SP1 of DS

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

SOLUTION