Video Screencast Help

Deploy image Return code 1 after Ghost

Created: 07 Feb 2014 • Updated: 11 Feb 2014 | 5 comments
steinb's picture
This issue has been solved. See solution.

We are running Symantec Management Console 7.1.8400. I created a Windows 7 32Bit Image. I am using Deploy image with the following options:

1) Image name

2) Product key

3) Include DeployAnywhere checked

4) Generate Sysprep configuration file using inventory data

5) have Credentials with full Active Directory rights.

We have 6 site servers. The task is failing on one with a return code 1 after the ghost completes.

If I uncheck Include DeployAnywhere, ghost completes tasks completes with a return code 0.

Any ideas what is happening?

Is there some place to go to see what Return Code 1 and other return codes mean?

Operating Systems:

Comments 5 CommentsJump to latest comment

JeffCarlson's picture

Get the newer version of DeployAnywhere.exe from

kzhang's picture

Hi Steinb,

As far as I know, return code 0 means the task or job completed successfully. Return code 1 is a general code for failed tasks or jobs. Return code -1 means the task or job failed because of a agent issue.

Which particular task did the job fail on?

steinb's picture

I download the deployanywhere code from the link. Still get the same problem.

I have a Deploy image task. It completes with a Return Code 1 on one of my 6 site servers.

The Deploy Image does at least 4 things. 1) Ghost restore 2) Creates an unattend.xml file with computer name and credentials to join a domain 3) run DeployAnywhere to update drivers 4) Copy stuff to C:\Windows\Panther for sysprep and join the domain.

I tried to create a Job to do what the Deploy Image task does, but it's not the same. I had 2 tasks in my job.

1) Deploy Image with just Ghost (No DeployAnywhere or sysprep checked)

2) A DeployAnywhere command script.

This works. Ghosts gets a return code 0, DeployAnywhere runs, but computer name is lost and join domain does not work.

Any suggestions on how to make the job work?

Or why Deploy Image is failing with a RC 1?

JeffCarlson's picture

You might also need to place firm.exe in the Task Handler directory.  Copy it from \\siteserver\deployment\Task Handler\rdeploy to \\siteserver\deployment\Task Handler\

I had this issue as well, but cant remember which fix it was.

steinb's picture

Thanks Jeff. That was it. I had the problem before also and thought the firm.exe had to be in the redeploy folder. Which it was. I copied to the Task Handler folder and all is well.